Accented characters

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Accented characters

Simon C. Tremblay
Good morning all,

last week I migrated from gramps4.1.3AIO on Windows 7 to Gramps4.2.1AIO on Windows 10 (64 bits on both platforms).  Since then, on the dashboard view, the titles of gramplets with accented characters are garbled: "Dernières modifications" is changed for "Dernières modifications" and  "À faire" is changed for "À faire".  

I did try to edit the titles in the customize view.  It's accepts the change and displays OK then, but if I close and reopen Gramps, the titles revert back to the mangled version.  This happens only on gramplets added to the dashboard.  I added the "À faire" gramplets to the Individual View and it displays OK.

I also noticed a problem with the file browser window (when attaching a media file for example) . The date displays as "19 févr. 2016" instead of "16 févr. 2016".  That is only for the date and not for the filename (a test file only because I make a point of not using special characters in my filenames). Not related to the bug, but is there a setting (in GTK I would guess) that would set this display to the system setting (yyyy-mm-dd in my case)?  

The accented characters display fine in data field like individuals name and places name.  I did not notice any data corruption, only weird display.

Before filling a bug report, I wanted to see if I'm the only one with this issue.

Simon



------------------------------------------------------------------------------
Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
http://pubads.g.doubleclick.net/gampad/clk?id=272487151&iu=/4140
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Accented characters

Simon C. Tremblay
Yes I did.  I filed 3 bug reports this week-end actually.

The first issue was resolved in 4.2.2, but I'm having issues with the NarratedWeb report, (it aborts reporting a missing media file) so I'll stick to 4.2.1 for now.  Guess I'll have to file another report.

The date one in the filechooser is being tracked here https://gramps-project.org/bugs/view.php?id=9337

I reported another one here https://gramps-project.org/bugs/view.php?id=9340 about display, but might not be related, but it was working fine in 4.1.3 and does not work in 4.2.x

Simon

On 28 March 2016 at 16:30, Paul Franklin <[hidden email]> wrote:
On 2/19/16, Simon C. Tremblay <[hidden email]> wrote:
> Good morning all,
>
> last week I migrated from gramps4.1.3AIO on Windows 7 to Gramps4.2.1AIO on
> Windows 10 (64 bits on both platforms).  Since then, on the dashboard view,
> the titles of gramplets with accented characters are garbled: "Dernières
> modifications" is changed for "Dernières modifications" and  "À faire" is
> changed for "À faire".
>
> I did try to edit the titles in the customize view.  It's accepts the
> change and displays OK then, but if I close and reopen Gramps, the titles
> revert back to the mangled version.  This happens only on gramplets added
> to the dashboard.  I added the "À faire" gramplets to the Individual View
> and it displays OK.
>
> I also noticed a problem with the file browser window (when attaching a
> media file for example) . The date displays as "19 févr. 2016" instead of
> "16 févr. 2016".  That is only for the date and not for the filename (a
> test file only because I make a point of not using special characters in my
> filenames). Not related to the bug, but is there a setting (in GTK I would
> guess) that would set this display to the system setting (yyyy-mm-dd in my
> case)?
>
> The accented characters display fine in data field like individuals name
> and places name.  I did not notice any data corruption, only weird display.
>
> Before filling a bug report, I wanted to see if I'm the only one with this
> issue.
>
> Simon
>

Did you file a bug?
(There are various bugs about Windows characters.)

Have you tried the 4.2.2 AIO (now that it exists)?


------------------------------------------------------------------------------
Transform Data into Opportunity.
Accelerate data analysis in your applications with
Intel Data Analytics Acceleration Library.
Click to learn more.
http://pubads.g.doubleclick.net/gampad/clk?id=278785471&iu=/4140
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users