Quantcast

Automatic updates and v3.4.3

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Automatic updates and v3.4.3

Nick Hall-6
Devs,

Since the url for the gramps-addons repository changed, users no longer
get automatic updates.

Doug made a change back on 30 Dec 2012, but we need a new release to
make it available to users.  Is it time for a new release?

Nick.


------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Automatic updates and v3.4.3

Benny Malengier



2013/3/12 Nick Hall <[hidden email]>
Devs,

Since the url for the gramps-addons repository changed, users no longer
get automatic updates.

Doug made a change back on 30 Dec 2012, but we need a new release to
make it available to users.  Is it time for a new release?

Probably yes. I'm still too busy with other stuff. Can you check roadmap, and coordinate with Jerome to do a release? I think Tim reverted the problematic commits in 3.4, so that should be good.

Benny

Nick.


------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel


------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Automatic updates and v3.4.3

jerome
In reply to this post by Nick Hall-6
I can move remaining bug reports[1] to 3.4.4 (or 4.0.0).

But maybe we should take care of some issues before 3.4.3 release:

* "6493: crash during Calculate Preview of a filtered XML export"[2]  
To fix the problem should be easy, but the problem will be the issue on class name.

* "6483: Listing the Family Trees can corrupt them"[3]

* "6195: Import from pro-gen"[4]

* "6336: Delayed update of bottom bar in Person View after merge"[5]

There is also one bug report related to python core modules under Windows OS: mime index, temp dir, cli and path => "6081: Crash after double-click on .gpkg file"[6]


[1] http://www.gramps-project.org/bugs/roadmap_page.php?version_id=35
[2] http://www.gramps-project.org/bugs/view.php?id=6493
[3] http://www.gramps-project.org/bugs/view.php?id=6483
[4] http://www.gramps-project.org/bugs/view.php?id=6195
[5] http://www.gramps-project.org/bugs/view.php?id=6336
[6] http://www.gramps-project.org/bugs/view.php?id=6081


Jérôme


--- En date de : Mer 13.3.13, Benny Malengier <[hidden email]> a écrit :

De: Benny Malengier <[hidden email]>
Objet: Re: [Gramps-devel] Automatic updates and v3.4.3
À: "Nick Hall" <[hidden email]>
Cc: "Gramps Development List" <[hidden email]>
Date: Mercredi 13 mars 2013, 10h24




2013/3/12 Nick Hall <[hidden email]>

Devs,



Since the url for the gramps-addons repository changed, users no longer

get automatic updates.



Doug made a change back on 30 Dec 2012, but we need a new release to

make it available to users.  Is it time for a new release?

Probably yes. I'm still too busy with other stuff. Can you check roadmap, and coordinate with Jerome to do a release? I think Tim reverted the problematic commits in 3.4, so that should be good.


Benny



Nick.





------------------------------------------------------------------------------

Everyone hates slow websites. So do we.

Make your web apps faster with AppDynamics

Download AppDynamics Lite for free today:

http://p.sf.net/sfu/appdyn_d2d_mar

_______________________________________________

Gramps-devel mailing list

[hidden email]

https://lists.sourceforge.net/lists/listinfo/gramps-devel




-----La pièce jointe associée suit-----

------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
-----La pièce jointe associée suit-----

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel


------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Automatic updates and v3.4.3

Nick Hall-6
Jérôme,

Is there anything you would like me to look at?

I think that bug #6336 might be fixed, but I need someone to test it.

Bug #6483 is related to bsddb database upgrade, but this is not really
my area.

You can change the target release for bug #6128 to 3.4.4.

Nick.


On 13/03/13 10:37, jerome wrote:

> I can move remaining bug reports[1] to 3.4.4 (or 4.0.0).
>
> But maybe we should take care of some issues before 3.4.3 release:
>
> * "6493: crash during Calculate Preview of a filtered XML export"[2]
> To fix the problem should be easy, but the problem will be the issue on class name.
>
> * "6483: Listing the Family Trees can corrupt them"[3]
>
> * "6195: Import from pro-gen"[4]
>
> * "6336: Delayed update of bottom bar in Person View after merge"[5]
>
> There is also one bug report related to python core modules under Windows OS: mime index, temp dir, cli and path => "6081: Crash after double-click on .gpkg file"[6]
>
>
> [1]http://www.gramps-project.org/bugs/roadmap_page.php?version_id=35
> [2]http://www.gramps-project.org/bugs/view.php?id=6493
> [3]http://www.gramps-project.org/bugs/view.php?id=6483
> [4]http://www.gramps-project.org/bugs/view.php?id=6195
> [5]http://www.gramps-project.org/bugs/view.php?id=6336
> [6]http://www.gramps-project.org/bugs/view.php?id=6081
>


------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Automatic updates and v3.4.3

jerome
Nick,


We set some bug reports as target.
Most remaining bugs[1] seem to be behavior issues.
I also put some of them on roadmaps... but status sounds rather as
'pending'.

eg, "4939: Ctrl-v does not work sometimes"[2] was submitted on
2011-05-27, but is a problem when we need to "paste a string into an
entry in the sidebar filter panel" via common Ctrl-v shortcut on keyboard.

It is around pageview/navigationview, maybe you can quickly reproduce it
or to know what is wrong with that?

24808: ERROR: gramps.py: line 178: Unhandled exception
Traceback (most recent call last):
   File "/usr/local/share/gramps/gui/views/navigationview.py", line 509,
in key_press_handler
     return super(NavigationView, self).key_press_handler(widget, event)
   File "/usr/local/share/gramps/gui/views/pageview.py", line 220, in
key_press_handler
     self.call_paste()
   File "/usr/local/share/gramps/gui/views/pageview.py", line 279, in
call_paste
     clipboard = ScratchPadWindow(self.dbstate, self.uistate)
   File "/usr/local/share/gramps/ScratchPad.py", line 1338, in __init__
     self.object_list.remove_invalid_objects()
AttributeError: 'ScratchPadListView' object has no attribute
'remove_invalid_objects'

Gary has looked "how Ctrl-C/Ctrl-V is working. It seems that it is
implemented in pageview.py so if Ctrl-C is pressed when an object (e.g a
person, event etc) is selected then that object is put on the clipboard.
Ctrl-V is merely a shortcut to make the clipboard visible again. It
seems the actual copy off the clipboard still needs to be done with the
mouse, because I guess you need to indicate where the object has to be
copied to."

No one seems to have fun to fix this...
Maybe this should be planned on next major release (4.0.x, 4.1.x) and to
move it from 3.4.3 roadmap?

> You can change the target release for bug #6128 to 3.4.4.

There is no 3.4.4 target on bug tracker yet!
Should one be created (how?) or we should move bug reports not yet fixed
after 3.4.3 to 4.0.0 roadmap?


[1] http://www.gramps-project.org/bugs/roadmap_page.php?version_id=35
[2] http://www.gramps-project.org/bugs/view.php?id=4939


Jérôme.


Le 15/03/2013 22:29, Nick Hall a écrit :

> Jérôme,
>
> Is there anything you would like me to look at?
>
> I think that bug #6336 might be fixed, but I need someone to test it.
>
> Bug #6483 is related to bsddb database upgrade, but this is not really
> my area.
>
> You can change the target release for bug #6128 to 3.4.4.
>
> Nick.
>
>
> On 13/03/13 10:37, jerome wrote:
>> I can move remaining bug reports[1] to 3.4.4 (or 4.0.0).
>>
>> But maybe we should take care of some issues before 3.4.3 release:
>>
>> * "6493: crash during Calculate Preview of a filtered XML export"[2]
>> To fix the problem should be easy, but the problem will be the issue
>> on class name.
>>
>> * "6483: Listing the Family Trees can corrupt them"[3]
>>
>> * "6195: Import from pro-gen"[4]
>>
>> * "6336: Delayed update of bottom bar in Person View after merge"[5]
>>
>> There is also one bug report related to python core modules under
>> Windows OS: mime index, temp dir, cli and path => "6081: Crash after
>> double-click on .gpkg file"[6]
>>
>>
>> [1]http://www.gramps-project.org/bugs/roadmap_page.php?version_id=35
>> [2]http://www.gramps-project.org/bugs/view.php?id=6493
>> [3]http://www.gramps-project.org/bugs/view.php?id=6483
>> [4]http://www.gramps-project.org/bugs/view.php?id=6195
>> [5]http://www.gramps-project.org/bugs/view.php?id=6336
>> [6]http://www.gramps-project.org/bugs/view.php?id=6081
>>
>
>


------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Automatic updates and v3.4.3

Benny Malengier



2013/3/16 Jérôme <[hidden email]>
Nick,


We set some bug reports as target.
Most remaining bugs[1] seem to be behavior issues.
I also put some of them on roadmaps... but status sounds rather as 'pending'.

eg, "4939: Ctrl-v does not work sometimes"[2] was submitted on 2011-05-27, but is a problem when we need to "paste a string into an entry in the sidebar filter panel" via common Ctrl-v shortcut on keyboard.

It is around pageview/navigationview, maybe you can quickly reproduce it or to know what is wrong with that?

24808: ERROR: gramps.py: line 178: Unhandled exception
Traceback (most recent call last):
  File "/usr/local/share/gramps/gui/views/navigationview.py", line 509, in key_press_handler
    return super(NavigationView, self).key_press_handler(widget, event)
  File "/usr/local/share/gramps/gui/views/pageview.py", line 220, in key_press_handler
    self.call_paste()
  File "/usr/local/share/gramps/gui/views/pageview.py", line 279, in call_paste
    clipboard = ScratchPadWindow(self.dbstate, self.uistate)
  File "/usr/local/share/gramps/ScratchPad.py", line 1338, in __init__
    self.object_list.remove_invalid_objects()
AttributeError: 'ScratchPadListView' object has no attribute 'remove_invalid_objects'

Gary has looked "how Ctrl-C/Ctrl-V is working. It seems that it is implemented in pageview.py so if Ctrl-C is pressed when an object (e.g a person, event etc) is selected then that object is put on the clipboard. Ctrl-V is merely a shortcut to make the clipboard visible again. It seems the actual copy off the clipboard still needs to be done with the mouse, because I guess you need to indicate where the object has to be copied to."

No one seems to have fun to fix this...
Maybe this should be planned on next major release (4.0.x, 4.1.x) and to move it from 3.4.3 roadmap?


You can change the target release for bug #6128 to 3.4.4.

There is no 3.4.4 target on bug tracker yet!
Should one be created (how?) or we should move bug reports not yet fixed after 3.4.3 to 4.0.0 roadmap?

I created a 3.4.4, and 3.4.5

Only move things that should be fixed together with 4.0 release to 3.4.4, rest 3.4.5 or 4.0.0

Benny


[1] http://www.gramps-project.org/bugs/roadmap_page.php?version_id=35
[2] http://www.gramps-project.org/bugs/view.php?id=4939


Jérôme.


Le 15/03/2013 22:29, Nick Hall a écrit :

Jérôme,

Is there anything you would like me to look at?

I think that bug #6336 might be fixed, but I need someone to test it.

Bug #6483 is related to bsddb database upgrade, but this is not really
my area.

You can change the target release for bug #6128 to 3.4.4.

Nick.


On 13/03/13 10:37, jerome wrote:
I can move remaining bug reports[1] to 3.4.4 (or 4.0.0).

But maybe we should take care of some issues before 3.4.3 release:

* "6493: crash during Calculate Preview of a filtered XML export"[2]
To fix the problem should be easy, but the problem will be the issue
on class name.

* "6483: Listing the Family Trees can corrupt them"[3]

* "6195: Import from pro-gen"[4]

* "6336: Delayed update of bottom bar in Person View after merge"[5]

There is also one bug report related to python core modules under
Windows OS: mime index, temp dir, cli and path => "6081: Crash after
double-click on .gpkg file"[6]


[1]http://www.gramps-project.org/bugs/roadmap_page.php?version_id=35
[2]http://www.gramps-project.org/bugs/view.php?id=6493
[3]http://www.gramps-project.org/bugs/view.php?id=6483
[4]http://www.gramps-project.org/bugs/view.php?id=6195
[5]http://www.gramps-project.org/bugs/view.php?id=6336
[6]http://www.gramps-project.org/bugs/view.php?id=6081






------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Automatic updates and v3.4.3

Tim Lyons
Administrator
Benny Malengier wrote
I created a 3.4.4, and 3.4.5
Excellent. I think (and hope) that 3.4.x will have a long life.

I don't know what the anticipated timescale for 4.x is and I don't know what the anticipated audience for it is.

Gramps 4.x requires at least pygobject 3.3.2, so will only be available on leading edge distributions (e.g. on Ubuntu Quantal 12.10 not Ubuntu Precise 12.04LTS). As I understand it, spell checking, OsmGpsMap, GExiv2 (any others?) are only available if you compile the relevant packages. http://www.gramps-project.org/wiki/index.php?title=GEPS_029:_GTK3-GObject_introspection_Conversion#OsmGpsMap_for_Geography needs to be updated!

There have been a number of messages about difficulties of installing Gramps 4.x on various platforms such as Ubuntu 12.04, 12.10, Mint, Fedora 16, Fedora 18 etc. Benny's approach is to push the boundaries, on the grounds that only by doing so will bugs in various components be fixed (I am not arguing about that). Therefore it makes sense for developers to try to build things so that bugs are resolved. It is also reasonable for a developer to build something on an unsupported platform just because he finds it more convenient to do development in that way. And of course there will be some users who are willing and able to build on platforms that do not provide the dependencies.

But please don't think that you are pioneering the way for normal users by building on platforms that don't meet the minimum requirements for Gramps. Gramps 4.x is pushing the boundaries, so it won't be ready for release for users till the dependencies are readily available.

[Of course, the Mac OS X and windows distributions are different because they come with all the necessary dependencies build-in]

We should probably be starting to construct a list of minimum distributions that will run Gramps 4.x. The current installation instructions just seem to assume that the dependencies will be available in the distribution's normal repository.

Benny Malengier wrote
Only move things that should be fixed together with 4.0 release to 3.4.4,
rest 3.4.5 or 4.0.0
Following on from the above, I would prefer to move things to 3.4.4, at least until we understand when 4.0.0 might be released and who might be able to use it.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Automatic updates and v3.4.3

Tim Lyons
Administrator
Tim Lyons wrote
As I understand it, spell checking, OsmGpsMap, GExiv2 (any others?) are only available if you compile the relevant packages. http://www.gramps-project.org/wiki/index.php?title=GEPS_029:_GTK3-GObject_introspection_Conversion#OsmGpsMap_for_Geography needs to be updated!
I don't know why I referred to OsmGpsMap; I don't know of any particular problem there. I think I meant to say GEPS 029 needs updating with build instructions.

Anyway, I have updated GEPS 029 to include instructions for building GExiv2 taken from this mailing list.

I have also updated trunk and gramps40 (rev 2170/6171) with clearer warnings when a module is missing. I have included what the problem is, what the effect is, and what to do about it, mainly by reference to build instructions in GEPS 029. I hope that before Gramps 4.0.0 is released we will be able to replace those with instructions to "use your package manager to install foobar".

Regards,
Tim.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Automatic updates and v3.4.3

enno
Hi Tim,
> Tim Lyons wrote
>> As I understand it, spell checking, OsmGpsMap, GExiv2 (any others?) are
>> only available if you compile the relevant packages.
>> http://www.gramps-project.org/wiki/index.php?title=GEPS_029:_GTK3-GObject_introspection_Conversion#OsmGpsMap_for_Geography
>> needs to be updated!
> I don't know why I referred to OsmGpsMap; I don't know of any particular
> problem there. I think I meant to say GEPS 029 needs updating with build
> instructions.
You did right. I got this message on my Mint 14 setup today:

2013-03-17 15:16:41.732: WARNING: geography.gpr.py: line 61: OsmGpsMap
module not loaded. Geography functionality will not be available.
To build it for Gramps see
http://www.gramps-project.org/wiki/index.php?title=GEPS_029:_GTK3-GObject_introspection_Conversion#OsmGpsMap_for_Geography

On visiting the page, I followed the instructions, and found that the
general ones work fine on Mint, except for those to start Gramps itself,
because they refer to src/gramps.py, instead of Gramps.py.

On reading further, I found the instructions for Mint 14, and saw that
they refer to the right Gramps.py, but otherwise they look quite
redundant to me now. Would you agree with me removing them and
correcting the src/gramps.py reference?

thanks,

Enno


------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Automatic updates and v3.4.3

Tim Lyons
Administrator
enno wrote
On visiting the page, I followed the instructions, and found that the
general ones work fine on Mint, except for those to start Gramps itself,
because they refer to src/gramps.py, instead of Gramps.py.

On reading further, I found the instructions for Mint 14, and saw that
they refer to the right Gramps.py, but otherwise they look quite
redundant to me now. Would you agree with me removing them and
correcting the src/gramps.py reference?
Enno,

Please do go ahead and update the Wiki instructions. I haven't tried any of them out myself, so don't know whether they are right or not.

Regards,
Tim
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Automatic updates and v3.4.3

enno
Hi Tim,
> Please do go ahead and update the Wiki instructions. I haven't tried
> any of them out myself, so don't know whether they are right or not.
Done.

Hope you don't mind me asking: Are you kulath on Mantis?

regards,

Enno

Loading...