Dependencies for Gramps 5.0a3

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Dependencies for Gramps 5.0a3

brian fitzgerald
Could someone please post the specific external dependencies for the gramps 5.0a3 . It might be possible to list them for the most common linux distros (ubuntu 16.04LTS, mint 18, etc) on the download page or the project wiki.

just saying "pygobject 3.12" does not help much since no reference to this appears either in Ubuntu' synaptic nor in Mint's.

It would make testing easier and would prevent much anxiety.

brian



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
https://gramps-project.org
Reply | Threaded
Open this post in threaded view
|

Re: Dependencies for Gramps 5.0a3

Ron Johnson
On 01/07/2018 07:33 PM, brian fitzgerald wrote:
Could someone please post the specific external dependencies for the gramps 5.0a3 . It might be possible to list them for the most common linux distros (ubuntu 16.04LTS, mint 18, etc) on the download page or the project wiki.

just saying "pygobject 3.12" does not help much since no reference to this appears either in Ubuntu' synaptic nor in Mint's.

It would make testing easier and would prevent much anxiety.

Are the v5.0 dependencies that different from v4.2?

-- 
World Peace Through Nuclear Pacification

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
https://gramps-project.org
Reply | Threaded
Open this post in threaded view
|

Re: Dependencies for Gramps 5.0a3

Nick Hall
In reply to this post by brian fitzgerald
On 08/01/18 01:33, brian fitzgerald wrote:
Could someone please post the specific external dependencies for the gramps 5.0a3 . It might be possible to list them for the most common linux distros (ubuntu 16.04LTS, mint 18, etc) on the download page or the project wiki.

just saying "pygobject 3.12" does not help much since no reference to this appears either in Ubuntu' synaptic nor in Mint's.

It would make testing easier and would prevent much anxiety.


See:

https://gramps-project.org/wiki/index.php?title=Linux:Build_from_source#Gramps_4.2_and_up

For v5.0 add sqlite3.


Nick.



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
https://gramps-project.org