ERROR: Plugin file ... has a version of "4.2" which is invalid for Gramps "5.0.1".

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

ERROR: Plugin file ... has a version of "4.2" which is invalid for Gramps "5.0.1".

Ron Johnson

After upgrading from 4.2.8 to 5.0.1 using the deb from
https://github.com/gramps-project/gramps/releases/tag/v5.0.1, I see these
errors when starting gramps, even after updating all addons from
Edit->Preferences.

Is this a known issue?

ron@haggis:~$ gramps
ERROR: Plugin file
/usr/lib/python3/dist-packages/gramps/plugins/tree/ancestor.py has a version
of "4.2" which is invalid for Gramps "5.0.1".
ERROR: Plugin file
/usr/lib/python3/dist-packages/gramps/plugins/tree/descendant.py has a
version of "4.2" which is invalid for Gramps "5.0.1".

ron@haggis:~$ gramps -v
Gramps Settings:
----------------
  python    : 3.5.2
  gramps    : 5.0.1
  gtk++     : 3.18.9
  pygobject : 3.20.0
  pango     : 1.38.1
  cairo     : 1.14.6
  pycairo   : 1.10.0
  osmgpsmap : 1.0
  GExiv2    : 0.10
  ICU       : 55.1
  PyICU     : 1.9.2
  o.s.      : linux
  kernel    : 4.4.0-140-generic

Environment settings:
---------------------
  LANG      : en_US.UTF-8
  LANGUAGE  : en
  GRAMPSI18N: not set
  GRAMPSHOME: not set
  GRAMPSDIR : not set
  PYTHONPATH:
     /usr/lib/python3/dist-packages/gramps
     /usr/bin
/usr/local/lib/python3.5/dist-packages/pyexcel-0.5.8-py3.5.egg
/usr/local/lib/python3.5/dist-packages/texttable-1.4.0-py3.5.egg
/usr/local/lib/python3.5/dist-packages/pyexcel_io-0.5.7-py3.5.egg
/usr/local/lib/python3.5/dist-packages/lml-0.0.1-py3.5.egg
     /usr/lib/python35.zip
     /usr/lib/python3.5
     /usr/lib/python3.5/plat-x86_64-linux-gnu
     /usr/lib/python3.5/lib-dynload
     /usr/local/lib/python3.5/dist-packages
     /usr/lib/python3/dist-packages

Non-python dependencies:
------------------------
  Graphviz  : 2.38
  Ghostscr. : 9.26

System PATH env variable:
-------------------------
      /home/ron/bin
      /usr/local/sbin
      /usr/local/bin
      /usr/sbin
      /usr/bin
      /sbin
      /bin
      /usr/games
      /usr/local/games
      /snap/bin

Databases:
-------------------------
  bsddb     :
      version     : 6.1.0
      db version  : 5.3.28
      location    : /usr/lib/python3/dist-packages/bsddb3/__init__.py
  sqlite3   :
      version     : 3.11.0
      py version  : 2.6.0
      location    : /usr/lib/python3.5/sqlite3/__init__.py


--
Angular momentum makes the world go 'round.


_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
https://gramps-project.org
Reply | Threaded
Open this post in threaded view
|

Re: ERROR: Plugin file ... has a version of "4.2" which is invalid for Gramps "5.0.1".

Ron Johnson
On 12/21/18 5:08 PM, Sam Manzi wrote:

> >> /usr/lib/python3/dist-packages/gramps/plugins/tree/ancestor.py has a
> version of "4.2" which is invalid for Gramps "5.0.1".
> >> ERROR: Plugin file
> >> /usr/lib/python3/dist-packages/gramps/plugins/tree/descendant.py has a
> version of "4.2" which is invalid for Gramps "5.0.1".
>
> I've opened the 5.0.1 deb file (you can unzip by renaming the file) and no
> directory for "tree" exist with those file names.[1]
>
> My guess it looks like you have manually added those files sometime in the
> past; most likley to test an older version of the genealogytree (latex)
> addon.[2]
>
> I suggest you remove all those files manually or remove all previous
> versions of Gramps and reinstall again.
>
> [1]
> https://github.com/gramps-project/gramps/tree/maintenance/gramps50/gramps/plugins
> [2] https://gramps-project.org/bugs/view.php?id=10223#c53948

It appears that gramps_5.0.1-1_all.deb does not remove gramps 4.2.

ron@haggis:~$ dpkg -l | grep gramps
ii  gramps            5.0.1-1    all          Genealogical research program
ic  python3-gramps    4.2.6      all          Genealogical research program

I'll purge both and then reinstall v5.0.1.

--
Angular momentum makes the world go 'round.


_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
https://gramps-project.org
Reply | Threaded
Open this post in threaded view
|

Re: ERROR: Plugin file ... has a version of "4.2" which is invalid for Gramps "5.0.1".

Nick Hall
On 21/12/2018 23:22, Ron Johnson wrote:
On 12/21/18 5:08 PM, Sam Manzi wrote:
>> /usr/lib/python3/dist-packages/gramps/plugins/tree/ancestor.py has a version of "4.2" which is invalid for Gramps "5.0.1".
>> ERROR: Plugin file
>> /usr/lib/python3/dist-packages/gramps/plugins/tree/descendant.py has a version of "4.2" which is invalid for Gramps "5.0.1".

I've opened the 5.0.1 deb file (you can unzip by renaming the file) and no directory for "tree" exist with those file names.[1]

My guess it looks like you have manually added those files sometime in the past; most likley to test an older version of the genealogytree (latex) addon.[2]

I suggest you remove all those files manually or remove all previous versions of Gramps and reinstall again.

[1] https://github.com/gramps-project/gramps/tree/maintenance/gramps50/gramps/plugins
[2] https://gramps-project.org/bugs/view.php?id=10223#c53948

It appears that gramps_5.0.1-1_all.deb does not remove gramps 4.2.

ron@haggis:~$ dpkg -l | grep gramps
ii  gramps            5.0.1-1    all          Genealogical research program
ic  python3-gramps    4.2.6      all          Genealogical research program

I'll purge both and then reinstall v5.0.1.

Yes.  It looks like you helped test the genealogytree functionality in v4.2.

Nick.




_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
https://gramps-project.org
Reply | Threaded
Open this post in threaded view
|

Re: ERROR: Plugin file ... has a version of "4.2" which is invalid for Gramps "5.0.1".

Doug-11
In reply to this post by Ron Johnson
On 21/12/2018 23:22, Ron Johnson wrote:

> On 12/21/18 5:08 PM, Sam Manzi wrote:
>> >>
>> /usr/lib/python3/dist-packages/gramps/plugins/tree/ancestor.py
>> has a version of "4.2" which is invalid for Gramps "5.0.1".
>> >> ERROR: Plugin file
>> >>
>> /usr/lib/python3/dist-packages/gramps/plugins/tree/descendant.py
>> has a version of "4.2" which is invalid for Gramps "5.0.1".
>>
>> I've opened the 5.0.1 deb file (you can unzip by renaming
>> the file) and no directory for "tree" exist with those
>> file names.[1]
>>
>> My guess it looks like you have manually added those
>> files sometime in the past; most likley to test an older
>> version of the genealogytree (latex) addon.[2]
>>
>> I suggest you remove all those files manually or remove
>> all previous versions of Gramps and reinstall again.
>>
>> [1]
>> https://github.com/gramps-project/gramps/tree/maintenance/gramps50/gramps/plugins
>> [2] https://gramps-project.org/bugs/view.php?id=10223#c53948
>
> It appears that gramps_5.0.1-1_all.deb does not remove
> gramps 4.2.
>
> ron@haggis:~$ dpkg -l | grep gramps
> ii  gramps            5.0.1-1  Â
> all          Genealogical research program
> ic  python3-gramps    4.2.6     
> all         Genealogical research program
>
> I'll purge both and then reinstall v5.0.1.
>
No, it doesn't. I have both running on separate workspaces.

Doug





_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
https://gramps-project.org
Reply | Threaded
Open this post in threaded view
|

Re: ERROR: Plugin file ... has a version of "4.2" which is invalid for Gramps "5.0.1".

Doug-11
In reply to this post by Ron Johnson
On 21/12/2018 23:22, Ron Johnson wrote:

> On 12/21/18 5:08 PM, Sam Manzi wrote:
>> >>
>> /usr/lib/python3/dist-packages/gramps/plugins/tree/ancestor.py
>> has a version of "4.2" which is invalid for Gramps "5.0.1".
>> >> ERROR: Plugin file
>> >>
>> /usr/lib/python3/dist-packages/gramps/plugins/tree/descendant.py
>> has a version of "4.2" which is invalid for Gramps "5.0.1".
>>
>> I've opened the 5.0.1 deb file (you can unzip by renaming
>> the file) and no directory for "tree" exist with those
>> file names.[1]
>>
>> My guess it looks like you have manually added those
>> files sometime in the past; most likley to test an older
>> version of the genealogytree (latex) addon.[2]
>>
>> I suggest you remove all those files manually or remove
>> all previous versions of Gramps and reinstall again.
>>
>> [1]
>> https://github.com/gramps-project/gramps/tree/maintenance/gramps50/gramps/plugins
>> [2] https://gramps-project.org/bugs/view.php?id=10223#c53948
>
> It appears that gramps_5.0.1-1_all.deb does not remove
> gramps 4.2.
>
> ron@haggis:~$ dpkg -l | grep gramps
> ii  gramps            5.0.1-1  Â
> all          Genealogical research program
> ic  python3-gramps    4.2.6     
> all         Genealogical research program
>
> I'll purge both and then reinstall v5.0.1.
>
Sorry for the previous post. Running 4.2.8 and 5.0,0.1

Doug



_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
https://gramps-project.org