Fontconfig

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Fontconfig

Ross Gammon
Hi All,

I see some mails on the user list about users having to install
python3-fontconfig.

Is this a new dependency?

When doing the Debian package I noticed that the gtk and python versions
had been bumped and a new dependency on geocodeglib added, when I
checked the README.

Or was there another package that used to pull this dependency in?

Sorry - I didn't do a lot of testing when I created the deb file this time.

Ross



_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Fontconfig

prculley
I think the python3-fontconfig is considered optional; it is used to support the new Genealogical Symbols panel in the Preferences.
At least the panel works without it and just puts up a message that the dependency is needed.

Paul C.

On Sat, Aug 31, 2019 at 7:19 AM Ross Gammon <[hidden email]> wrote:
Hi All,

I see some mails on the user list about users having to install
python3-fontconfig.

Is this a new dependency?

When doing the Debian package I noticed that the gtk and python versions
had been bumped and a new dependency on geocodeglib added, when I
checked the README.

Or was there another package that used to pull this dependency in?

Sorry - I didn't do a lot of testing when I created the deb file this time.

Ross

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel


_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel