Fwd: Re: gramps 4.1.0.0 on Debian Wheezy

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Fwd: Re: gramps 4.1.0.0 on Debian Wheezy

Ross Gammon
Forwarding back to the list

-------- Forwarded Message --------
Subject: Re: [Gramps-users] gramps 4.1.0.0 on Debian Wheezy
Date: Sun, 10 Aug 2014 15:40:38 -0600
From: Alvin Larson <[hidden email]>
To: Ross Gammon <[hidden email]>

Hello Ross,

Thanks much for your reply.

On 08/09/2014 06:32 AM, Ross Gammon wrote:

> Hi Alvin,
>
> On 08/09/2014 02:37 AM, Alvin Larson wrote:
>> Hello:
>>
>> I tried to install python-gramps  4.1.0.0 on a fresh install of Debian
>> Wheezy 7.6.0.  There seems to be a
>> problem with python dependencies.  Is there a fix for this?
>>
> The default Gramps in Debian Wheezy is 3.4.0. Whilst it is probably
> possible to get Gramps 4.x working, I imagine it would be a lot of work
> to get all of the dependencies installed. My general advice to people
> using Wheezy would be to stick to the 3.4 series (currently 3.4.8).
I did manage to import the .gramps backup file into a Gramps 3.4.7-3
install and it looks good. Fortunately the backup was very recent.
> But as you need to work with a database generated with 4.1.x, this is no
> help to you. You could try upgrading to Debian Jessie (currently in
> testing) and install 4.1.0 from the Gramps website? Or if you want
> something more stable, Ubuntu 14.04 LTS might be a better base?
In the future I will try using Debian Jessie, as you suggest, at least to
upgrade Python and Gramps.  I used Ubuntu a lot a few years ago but I
always ran into the problem that I couldn't run the newest versions of
Gramps because of dependency problems.  I then went to Aptosid (a rolling
distribution based on Debian Sid) and it ran the latest Gramps for a long
time.  However, now a dist-upgrade with Aptosid has a tendency to wipe
out access to X windows and I have to do a complete reinstall to get
back in business.

Sincerely,  Alvin

>> My reason for asking is I have a .gramps node, which I would like to
>> use.  It was generated with gramps 4.1.?.? on a Aptosid installation
>> that went kuput.  I also have a .gpkg backup file made with gramps
>> 4.1.??.  I don't want to go back to Aptosid if I don't have to.
>>
> Maybe some others on the list have some ideas with what you can do using
> the .gramps directory or the gpkg backup file?
>
>> Thank you for help,
>>
>> Alvin Larson
>>
> Regards,
>
> Ross
>
> ------------------------------------------------------------------------------
> _______________________________________________
> Gramps-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gramps-users
>




------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users