GRAMPS 2.2 Release Candidate 1 available

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

GRAMPS 2.2 Release Candidate 1 available

Don Allingham
The GRAMPS project is pleased to announce the first release candidate
for the upcoming 2.2.0 release. This release, GRAMPS 2.2.0-0rc1 ("Help,
Help! I'm being repressed!") is available for download at
http://sourceforge.net/projects/gramps

Packages for different distributions may become available over the next
several days.

Changes since 2.1.95 include:

Version 2.2.0rc1 -- the "Help, Help! I'm being repressed!" release
* Address has county, Location has street now.
* Improved icons (James Leigh).
* DB transactions are adjusted by the user.
* Drag and Drop improvements.
* Czech relationship calculator (Zdenek Hatas).
* Bug fixes.


-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users

signature.asc (198 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: GRAMPS 2.2 Release Candidate 1 available

Richard Bos
Op donderdag 12 oktober 2006 05:18, schreef Don Allingham:
> The GRAMPS project is pleased to announce the first release candidate
> for the upcoming 2.2.0 release. This release, GRAMPS 2.2.0-0rc1 ("Help,
> Help! I'm being repressed!") is available for download at
> http://sourceforge.net/projects/gramps

A version number like the one above may give problems in the future when
moving to a released 2.2.0 version.  Apt on rpm systems e.g. considere
2.2.0rcX to be newer than 2.2.0 and as such users that have a 2.2.0rcX
installed won't get the released version.  If possible it's better to use the
2.1.9x version numbering scheme.

--
Richard Bos
Without a home the journey is endless

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: GRAMPS 2.2 Release Candidate 1 available

Alex Roitman
Richard,

On Fri, 2006-10-13 at 20:39 +0200, Richard Bos wrote:

> Op donderdag 12 oktober 2006 05:18, schreef Don Allingham:
> > The GRAMPS project is pleased to announce the first release candidate
> > for the upcoming 2.2.0 release. This release, GRAMPS 2.2.0-0rc1 ("Help,
> > Help! I'm being repressed!") is available for download at
> > http://sourceforge.net/projects/gramps
>
> A version number like the one above may give problems in the future when
> moving to a released 2.2.0 version.  Apt on rpm systems e.g. considere
> 2.2.0rcX to be newer than 2.2.0 and as such users that have a 2.2.0rcX
> installed won't get the released version.  If possible it's better to use the
> 2.1.9x version numbering scheme.
It makes sense. Too bad we did not think about it before the release,
because now we can't "unrelease" it.

Maybe we just do 2.2.1 when we are ready, instead of 2.2.0?

Alex

--
Alexander Roitman   http://www.gramps-project.org

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: GRAMPS 2.2 Release Candidate 1 available

Gerald Britton-2
Users can just be told to uninstall the RC before installing the full
release.  Seems easier to me

On 10/13/06, Alex Roitman <[hidden email]> wrote:

> Richard,
>
> On Fri, 2006-10-13 at 20:39 +0200, Richard Bos wrote:
> > Op donderdag 12 oktober 2006 05:18, schreef Don Allingham:
> > > The GRAMPS project is pleased to announce the first release candidate
> > > for the upcoming 2.2.0 release. This release, GRAMPS 2.2.0-0rc1 ("Help,
> > > Help! I'm being repressed!") is available for download at
> > > http://sourceforge.net/projects/gramps
> >
> > A version number like the one above may give problems in the future when
> > moving to a released 2.2.0 version.  Apt on rpm systems e.g. considere
> > 2.2.0rcX to be newer than 2.2.0 and as such users that have a 2.2.0rcX
> > installed won't get the released version.  If possible it's better to use the
> > 2.1.9x version numbering scheme.
>
> It makes sense. Too bad we did not think about it before the release,
> because now we can't "unrelease" it.
>
> Maybe we just do 2.2.1 when we are ready, instead of 2.2.0?
>
> Alex
>
> --
> Alexander Roitman   http://www.gramps-project.org
>
>
> -------------------------------------------------------------------------
> Using Tomcat but need to do more? Need to support web services, security?
> Get stuff done quickly with pre-integrated technology to make your job easier
> Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
> http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
>
> _______________________________________________
> Gramps-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gramps-users
>
>
>
>

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: GRAMPS 2.2 Release Candidate 1 available

Richard Bos
Op vrijdag 13 oktober 2006 21:22, schreef u:
> Users can just be told to uninstall the RC before installing the full
> release.  Seems easier to me

It does not work like that, then using package managers.  In case of the later
the pkg mngr takes for selecting the latest one, as 2.2.0rcX is considered to
be newer than just 2.2.0 it is never offered to the user by the pkg mngr.  
So, you're not able to tell the user to uninstall the RC version....

--
Richard Bos
Without a home the journey is endless

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: GRAMPS 2.2 Release Candidate 1 available

Gerald Britton-2
you can install/uninstall specific packages with dpkg.  AFAIK the RCs
shouldn't be placed into stable archives and shouldn't be installable
via apt-get, but only via dpkg or the equivalent on your system.


On gentoo, it's easier since emerge allows you to specify a particular version.

On 10/13/06, Richard Bos <[hidden email]> wrote:

> Op vrijdag 13 oktober 2006 21:22, schreef u:
> > Users can just be told to uninstall the RC before installing the full
> > release. Seems easier to me
>
> It does not work like that, then using package managers.  In case of the later
> the pkg mngr takes for selecting the latest one, as 2.2.0rcX is considered to
> be newer than just 2.2.0 it is never offered to the user by the pkg mngr.
> So, you're not able to tell the user to uninstall the RC version....
>
> --
> Richard Bos
> Without a home the journey is endless
>
> -------------------------------------------------------------------------
> Using Tomcat but need to do more? Need to support web services, security?
> Get stuff done quickly with pre-integrated technology to make your job easier
> Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
> http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
> _______________________________________________
> Gramps-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gramps-users
>

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: GRAMPS 2.2 Release Candidate 1 available

Sarolite
In reply to this post by Richard Bos
Or release it as 2.2.0s (higher alphabetically should be seen as newer, yes?). Call it s for stable!

----- Original Message ----
From: Richard Bos <[hidden email]>
To: [hidden email]
Sent: Friday, October 13, 2006 1:46:18 PM
Subject: Re: [Gramps-users] GRAMPS 2.2 Release Candidate 1 available

Op vrijdag 13 oktober 2006 21:22, schreef u:
> Users can just be told to uninstall the RC before installing the full
> release.  Seems easier to me

It does not work like that, then using package managers.  In case of the later
the pkg mngr takes for selecting the latest one, as 2.2.0rcX is considered to
be newer than just 2.2.0 it is never offered to the user by the pkg mngr.  
So, you're not able to tell the user to uninstall the RC version....

--
Richard Bos
Without a home the journey is endless

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users


-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: GRAMPS 2.2 Release Candidate 1 available

Don Allingham
Wasn't it released as 2.2.0-0rc1? If so, 2.2.0-1 should be higher.

Don

On Fri, 2006-10-13 at 16:10 -0700, Sarolite wrote:

> Or release it as 2.2.0s (higher alphabetically should be seen as
> newer, yes?). Call it s for stable!
>
> ----- Original Message ----
> From: Richard Bos <[hidden email]>
> To: [hidden email]
> Sent: Friday, October 13, 2006 1:46:18 PM
> Subject: Re: [Gramps-users] GRAMPS 2.2 Release Candidate 1 available
>
> Op vrijdag 13 oktober 2006 21:22, schreef u:
> > Users can just be told to uninstall the RC before installing the
> full
> > release.  Seems easier to me
>
> It does not work like that, then using package managers.  In case of
> the later
> the pkg mngr takes for selecting the latest one, as 2.2.0rcX is
> considered to
> be newer than just 2.2.0 it is never offered to the user by the pkg
> mngr.  
> So, you're not able to tell the user to uninstall the RC version....
>
> --
> Richard Bos
> Without a home the journey is endless
>
> -------------------------------------------------------------------------
> Using Tomcat but need to do more? Need to support web services,
> security?
> Get stuff done quickly with pre-integrated technology to make your job
> easier
> Download IBM WebSphere Application Server v.1.0.1 based on Apache
> Geronimo
> http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
> _______________________________________________
> Gramps-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gramps-users
>
>
>
> -------------------------------------------------------------------------
> Using Tomcat but need to do more? Need to support web services, security?
> Get stuff done quickly with pre-integrated technology to make your job easier
> Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
> http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
> _______________________________________________ Gramps-users mailing list [hidden email] https://lists.sourceforge.net/lists/listinfo/gramps-users

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users

signature.asc (198 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: GRAMPS 2.2 Release Candidate 1 available

Richard Bos
In reply to this post by Don Allingham
Op donderdag 12 oktober 2006 05:18, schreef Don Allingham:
> Packages for different distributions may become available over the next
> several days.

For suse-1.0 and beyond they can be downloaded from:
http://ftp-1.gwdg.de/pub/opensuse/repositories/home:/rbos/

--
Richard Bos
Without a home the journey is endless

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

unicode ascii problem

bm-7
Hi,

writing the latitude longitude converter function, I recieve following
complaint
(not error):

"""
sys:1: DeprecationWarning: Non-ASCII character '\xc2' in file PlaceUtils.py on
line 65, but no encoding declared; see
http://www.python.org/peps/pep-0263.html
for details
"""

This is apparently due to the use of the degree symbol °, unicode \xc2\xb0 or
in html &#176;

Everything seems to work however.
If I add to the file at the top "# coding: latin-1".
However, other files in gramps to not have the coding identifier.
Does anybody see a problem if this is needed for a plugin/utility?

Benny

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.


-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: unicode ascii problem

Alex Roitman
Benny,

On Sat, 2006-10-14 at 23:50 +0200, [hidden email] wrote:

> """
> sys:1: DeprecationWarning: Non-ASCII character '\xc2' in file PlaceUtils.py on
> line 65, but no encoding declared; see
> http://www.python.org/peps/pep-0263.html
> for details
> """
>
> This is apparently due to the use of the degree symbol °, unicode \xc2\xb0 or
> in html &#176;
>
> Everything seems to work however.
> If I add to the file at the top "# coding: latin-1".
This is the way to go.

> However, other files in gramps to not have the coding identifier.

Actually, some do:
   $ grep coding\: src/*py
   src/const.py:# -*- coding: utf-8 -*-
   src/date_test.py:# -*- coding: utf-8 -*-
   src/DdTargets.py:# -*- coding: utf-8 -*-
   src/GrampsLocale.py:# -*- coding: iso-8859-1 -*-
   src/ToolTips.py:# -*- coding: utf-8 -*-

It's only when there're non-ascii chars that coding needs defining.

> Does anybody see a problem if this is needed for a plugin/utility?

Not at all. The only thing I would ask for is utf-8 instead of latin-1.
On cyrillic, chinese, etc systems latin-1 will not show up well anyway.

Alex

--
Alexander Roitman   http://www.gramps-project.org

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users

signature.asc (196 bytes) Download Attachment