GRAMPS fails to start in Ubuntu 8.10

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

GRAMPS fails to start in Ubuntu 8.10

Duncan Lithgow-2
I've just reported this bug at Launchpad:

Ubuntu 8.10
gramps 3.0.1-1

All I've done is installed the Intrepid Ibex on a spare machine,
installed GRAMPS via apt-get and tried to start it - resulting in this
crash.

https://bugs.edge.launchpad.net/ubuntu/+source/gramps/+bug/261596

Duncan

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: GRAMPS fails to start in Ubuntu 8.10

Stéphane Charette-2
> https://bugs.edge.launchpad.net/ubuntu/+source/gramps/+bug/261596

> StacktraceTop:
>  readdir64 () from /lib/tls/i686/cmov/libc.so.6
>  g_dir_read_name () from /usr/lib/libglib-2.0.so.0
>  MySpellChecker::requestDictionary ()
>  ?? () from /usr/lib/enchant/libenchant_myspell.so
>  ?? () from /usr/lib/libenchant.so.1
> Title: gramps.py crashed with SIGSEGV in readdir64()


This is the (known) speller issue.

Stéphane

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: GRAMPS fails to start in Ubuntu 8.10

Duncan Lithgow-2
2008/8/27 Stéphane Charette <[hidden email]>:
> This is the (known) speller issue.
Oh, that again.
-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: GRAMPS fails to start in Ubuntu 8.10

Jay Treacy
In reply to this post by Stéphane Charette-2
On Tue, Aug 26, 2008 at 05:15:40PM -0700, Stéphane Charette wrote:

> > https://bugs.edge.launchpad.net/ubuntu/+source/gramps/+bug/261596
>
> > StacktraceTop:
> >  readdir64 () from /lib/tls/i686/cmov/libc.so.6
> >  g_dir_read_name () from /usr/lib/libglib-2.0.so.0
> >  MySpellChecker::requestDictionary ()
> >  ?? () from /usr/lib/enchant/libenchant_myspell.so
> >  ?? () from /usr/lib/libenchant.so.1
> > Title: gramps.py crashed with SIGSEGV in readdir64()
>
>
> This is the (known) speller issue.

Has anyone really looked into this issue? It appears that it is only
biting a small group of users. I have been unable to replicate it on
my system. Of course this could be related to the debian package being
built on it.

Having gramps conflict with python-gtk2-extras is not a good solution
as at least one user uses another program that has that as a
dependency.

--
                       A: Because it messes up the order in which people normally read text.
James Treacy           Q: Why is top-posting such a bad thing?
[hidden email]      A: Top-posting.
                       Q: What is the most annoying thing in e-mail?

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: GRAMPS fails to start in Ubuntu 8.10

Benny Malengier


2008/8/29 James A. Treacy <[hidden email]>
On Tue, Aug 26, 2008 at 05:15:40PM -0700, Stéphane Charette wrote:
> > https://bugs.edge.launchpad.net/ubuntu/+source/gramps/+bug/261596
>
> > StacktraceTop:
> >  readdir64 () from /lib/tls/i686/cmov/libc.so.6
> >  g_dir_read_name () from /usr/lib/libglib-2.0.so.0
> >  MySpellChecker::requestDictionary ()
> >  ?? () from /usr/lib/enchant/libenchant_myspell.so
> >  ?? () from /usr/lib/libenchant.so.1
> > Title: gramps.py crashed with SIGSEGV in readdir64()
>
>
> This is the (known) speller issue.

Has anyone really looked into this issue? It appears that it is only
biting a small group of users. I have been unable to replicate it on
my system. Of course this could be related to the debian package being
built on it.

it is a new issue, that is for sure. However, as there are changes to the spell checkers in debian/ubuntu, it is very likely an upstream issue, no?
 
Having gramps conflict with python-gtk2-extras is not a good solution
as at least one user uses another program that has that as a
dependency.

Gramps should not conflict. If spell checking no longer works, the worst case scenario is to disable it in Debian/Ubuntu, by manually editing the src/Spell.py file to no longer import the package, and make Debian/Ubuntu packages based on that (so no spell check in GRAMPS).

Benny


-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: GRAMPS fails to start in Ubuntu 8.10

Duncan Lithgow-2
The bug seems to be in the enchant package:
https://bugs.edge.launchpad.net/ubuntu/+source/enchant/+bug/261596

But surely GRAMPS should be able to handle something like this a bit
more gracefully.

Duncan

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: GRAMPS fails to start in Ubuntu 8.10

Benny Malengier


2008/8/29 Duncan Lithgow <[hidden email]>
The bug seems to be in the enchant package:
https://bugs.edge.launchpad.net/ubuntu/+source/enchant/+bug/261596

But surely GRAMPS should be able to handle something like this a bit
more gracefully.

No, this is not possible. It appears we import a package, and then a hard crash happens, so control is not returned to GRAMPS:

    gramps.py crashed with SIGSEGV in readdir64()

Are you on 64bit? Perhaps there is a reason for only affecting some people?

Benny


-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: GRAMPS fails to start in Ubuntu 8.10

Duncan Lithgow-2
2008/8/29 Benny Malengier <[hidden email]>:
> Are you on 64bit? Perhaps there is a reason for only affecting some people?
Can you see if I'm on 64bit by looking at the bug?
https://bugs.edge.launchpad.net/ubuntu/+source/enchant/+bug/261596
(I'm not on a 64bit machine)

The machine is a standard IBM Notepad A31 with Ubuntu 8.10 installed
and updated. All I've added to that machine is scribus, inkscape,
gramps and kino

Duncan

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: GRAMPS fails to start in Ubuntu 8.10

Jay Treacy
On Fri, Aug 29, 2008 at 12:32:57PM +0200, Duncan Lithgow wrote:
> 2008/8/29 Benny Malengier <[hidden email]>:
> > Are you on 64bit? Perhaps there is a reason for only affecting some people?
> Can you see if I'm on 64bit by looking at the bug?
> https://bugs.edge.launchpad.net/ubuntu/+source/enchant/+bug/261596
> (I'm not on a 64bit machine)
>
> The machine is a standard IBM Notepad A31 with Ubuntu 8.10 installed
> and updated. All I've added to that machine is scribus, inkscape,
> gramps and kino

>From https://bugs.edge.launchpad.net/ubuntu/+source/enchant/+bug/261596
Architecture: i386
So, yes you can tell what your machine is from the bug report.
64 bit machines show 'amd64'.

FYI, I am on a 64 bit machine and gramps doesn't crash with
python-gnome2-extras installed.

I agree it is unfortunate, but I will be uploading a debian package
with spell checking disabled until this is fixed. It would be doubly
unfortunate if the next release of Debian (possibly in Sep) doesn't
include spell checking.

--
                       A: Because it messes up the order in which people normally read text.
James Treacy           Q: Why is top-posting such a bad thing?
[hidden email]      A: Top-posting.
                       Q: What is the most annoying thing in e-mail?

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: GRAMPS fails to start in Ubuntu 8.10

Jay Treacy
It turns out that it is not a 64 vs 32 bit problem as one of the
replies on http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=492212 is
from someone running a 64 bit machine.

As an aside, I noticed a significant difference in startup time when
spelling is enabled (6sec) and when it is not (2sec). Why would
enabling a spell checker take so long?

--
                       A: Because it messes up the order in which people normally read text.
James Treacy           Q: Why is top-posting such a bad thing?
[hidden email]      A: Top-posting.
                       Q: What is the most annoying thing in e-mail?

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: GRAMPS fails to start in Ubuntu 8.10

Duncan Lithgow-2
James, you've closed the debian bug not because (quote) "the bug you
reported is fixed", but because you've disabled the functionality that
triggered the bug. Maybe the bug should therefore remain open?

Duncan

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel