Gedcom import error

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Gedcom import error

HomesteadMommy
I'm  trying to import a gedcom from RootsMagic 7 into Gramps 4.1.3-1 on
Linux Mint 17.1.  Each time I try it gives me the error below.

62585: ERROR: dbloader.py: line 269: Failed to import database.
Traceback (most recent call last):
   File "/usr/lib/python2.7/dist-packages/gramps/gui/dbloader.py", line
258, in do_import
     uistate=self.uistate))
   File
"/usr/lib/python2.7/dist-packages/gramps/plugins/importer/importgedcom.py",
line 157, in importData
     gedparse.parse_gedcom_file(False)
   File
"/usr/lib/python2.7/dist-packages/gramps/plugins/lib/libgedcom.py", line
2805, in parse_gedcom_file
     self.__parse_record()
   File
"/usr/lib/python2.7/dist-packages/gramps/plugins/lib/libgedcom.py", line
3529, in __parse_record
     self.__parse_indi(line)
   File
"/usr/lib/python2.7/dist-packages/gramps/plugins/lib/libgedcom.py", line
3628, in __parse_indi
     self.__parse_level(state, self.indi_parse_tbl, self.__person_event)
   File
"/usr/lib/python2.7/dist-packages/gramps/plugins/lib/libgedcom.py", line
3582, in __parse_level
     func(line, state)
   File
"/usr/lib/python2.7/dist-packages/gramps/plugins/lib/libgedcom.py", line
3944, in __person_std_event
     self.__parse_level(sub_state, self.event_parse_tbl, self.__undefined)
   File
"/usr/lib/python2.7/dist-packages/gramps/plugins/lib/libgedcom.py", line
3582, in __parse_level
     func(line, state)
   File
"/usr/lib/python2.7/dist-packages/gramps/plugins/lib/libgedcom.py", line
5625, in __event_addr
     refs = list(self.dbase.find_backlink_handles(place_handle))
   File "/usr/lib/python2.7/dist-packages/gramps/gen/db/write.py", line
1189, in find_backlink_handles
     referenced_cur = self.get_reference_map_referenced_cursor()
   File "/usr/lib/python2.7/dist-packages/gramps/gen/db/write.py", line
410, in try_
     return func(self, *args, **kwargs)
   File "/usr/lib/python2.7/dist-packages/gramps/gen/db/write.py", line
492, in get_reference_map_referenced_cursor
     self.txn)
   File "/usr/lib/python2.7/dist-packages/gramps/gen/db/write.py", line
245, in __init__
     self.cursor = source.cursor(txn)
DBError: (0, 'DB object has been closed')

After I close the error message I can see it's imported about 20
people.  This happens with every gedcom I'm trying to import generated
by RootsMagic 7.  I didn't have any problems that last time I did this
back in the winter.
I tried making a gedcom from Family Tree Maker 2012 and it imports fine
with out this error.

Since my main db is in RM7 I would prefer to do the export from it. Is
there something I can do to fix this error?

Thanks,
Kim

------------------------------------------------------------------------------
Monitor 25 network devices or servers for free with OpManager!
OpManager is web-based network management software that monitors
network devices and physical & virtual servers, alerts via email & sms
for fault. Monitor 25 devices for free with no restriction. Download now
http://ad.doubleclick.net/ddm/clk/292181274;119417398;o
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Gedcom import error

enno
Kim,

This is a known error registered at:


I hope that it will be repaired in the next version of Gramps, but if you want to work with this tree now, and you don't have other trees that rely on 4.1.3, can also try an older version like 4.1.2, or maybe even 3.4.9.

Gramps 3.4.9 and 4.1.3 were modified to read address details exported in RootsMagic GEDCOM files, but the modification has an error that did not show in my test. Gramps 3.4.9 will probably not crash, and import address details in the street address, where 4.1.2 will import places that have the same main address into one, which is wrong. In 3.4.9 you will get multiple places with the same name/title, but with different street addresses.

regards,

Enno


Verzonden met Windows Mail

Van: [hidden email]
Verzonden: ‎zaterdag‎ ‎27‎ ‎juni‎ ‎2015 ‎19‎:‎09
Aan: [hidden email]

I'm  trying to import a gedcom from RootsMagic 7 into Gramps 4.1.3-1 on
Linux Mint 17.1.  Each time I try it gives me the error below.

62585: ERROR: dbloader.py: line 269: Failed to import database.
Traceback (most recent call last):
   File "/usr/lib/python2.7/dist-packages/gramps/gui/dbloader.py", line
258, in do_import
     uistate=self.uistate))
   File
"/usr/lib/python2.7/dist-packages/gramps/plugins/importer/importgedcom.py",
line 157, in importData
     gedparse.parse_gedcom_file(False)
   File
"/usr/lib/python2.7/dist-packages/gramps/plugins/lib/libgedcom.py", line
2805, in parse_gedcom_file
     self.__parse_record()
   File
"/usr/lib/python2.7/dist-packages/gramps/plugins/lib/libgedcom.py", line
3529, in __parse_record
     self.__parse_indi(line)
   File
"/usr/lib/python2.7/dist-packages/gramps/plugins/lib/libgedcom.py", line
3628, in __parse_indi
     self.__parse_level(state, self.indi_parse_tbl, self.__person_event)
   File
"/usr/lib/python2.7/dist-packages/gramps/plugins/lib/libgedcom.py", line
3582, in __parse_level
     func(line, state)
   File
"/usr/lib/python2.7/dist-packages/gramps/plugins/lib/libgedcom.py", line
3944, in __person_std_event
     self.__parse_level(sub_state, self.event_parse_tbl, self.__undefined)
   File
"/usr/lib/python2.7/dist-packages/gramps/plugins/lib/libgedcom.py", line
3582, in __parse_level
     func(line, state)
   File
"/usr/lib/python2.7/dist-packages/gramps/plugins/lib/libgedcom.py", line
5625, in __event_addr
     refs = list(self.dbase.find_backlink_handles(place_handle))
   File "/usr/lib/python2.7/dist-packages/gramps/gen/db/write.py", line
1189, in find_backlink_handles
     referenced_cur = self.get_reference_map_referenced_cursor()
   File "/usr/lib/python2.7/dist-packages/gramps/gen/db/write.py", line
410, in try_
     return func(self, *args, **kwargs)
   File "/usr/lib/python2.7/dist-packages/gramps/gen/db/write.py", line
492, in get_reference_map_referenced_cursor
     self.txn)
   File "/usr/lib/python2.7/dist-packages/gramps/gen/db/write.py", line
245, in __init__
     self.cursor = source.cursor(txn)
DBError: (0, 'DB object has been closed')

After I close the error message I can see it's imported about 20
people.  This happens with every gedcom I'm trying to import generated
by RootsMagic 7.  I didn't have any problems that last time I did this
back in the winter.
I tried making a gedcom from Family Tree Maker 2012 and it imports fine
with out this error.

Since my main db is in RM7 I would prefer to do the export from it. Is
there something I can do to fix this error?

Thanks,
Kim

------------------------------------------------------------------------------
Monitor 25 network devices or servers for free with OpManager!
OpManager is web-based network management software that monitors
network devices and physical & virtual servers, alerts via email & sms
for fault. Monitor 25 devices for free with no restriction. Download now
http://ad.doubleclick.net/ddm/clk/292181274;119417398;o
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users

------------------------------------------------------------------------------
Monitor 25 network devices or servers for free with OpManager!
OpManager is web-based network management software that monitors
network devices and physical & virtual servers, alerts via email & sms
for fault. Monitor 25 devices for free with no restriction. Download now
http://ad.doubleclick.net/ddm/clk/292181274;119417398;o
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users