Geography category not showing in Gramps 4.0.1 (Linux Mint 15)

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Geography category not showing in Gramps 4.0.1 (Linux Mint 15)

Brad Hernlem
Any suggestions how to resolve this problem?

Brad

------------------------------------------------------------------------------
Introducing Performance Central, a new site from SourceForge and
AppDynamics. Performance Central is your source for news, insights,
analysis and resources for efficient Application Performance Management.
Visit us today!
http://pubads.g.doubleclick.net/gampad/clk?id=48897511&iu=/4140/ostg.clktrk
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Geography category not showing in Gramps 4.0.1 (Linux Mint 15)

Stuart
Hi Brad,

I am having the same problem.  I thought it was because Gramps needs Osm-Gps-Map installed.  The website says you can install it on Debian based distros as follows:
sudo apt-get install libosmgpsmap-dev python-osmgpsmap
But I tried this and I still cannot get the Geography view to work, so I am in the same boat as you.  Hopefully someone else is able to help

Regards,
Stuart

On 26/08/13 19:13, Brad Hernlem wrote:
Any suggestions how to resolve this problem?

Brad


------------------------------------------------------------------------------
Introducing Performance Central, a new site from SourceForge and 
AppDynamics. Performance Central is your source for news, insights, 
analysis and resources for efficient Application Performance Management. 
Visit us today!
http://pubads.g.doubleclick.net/gampad/clk?id=48897511&iu=/4140/ostg.clktrk


_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users


------------------------------------------------------------------------------
Introducing Performance Central, a new site from SourceForge and
AppDynamics. Performance Central is your source for news, insights,
analysis and resources for efficient Application Performance Management.
Visit us today!
http://pubads.g.doubleclick.net/gampad/clk?id=48897511&iu=/4140/ostg.clktrk
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Geography category not showing in Gramps 4.0.1 (Linux Mint 15)

Serge Noiraud-2
Hi,

The osm-gps-map package is not available on the majority of the distributions.
You need to compile it. For this, read the following :

http://www.gramps-project.org/wiki/index.php?title=GEPS_029:_GTK3-GObject_introspection_Conversion#OsmGpsMap_for_Geography

Le 27/08/2013 00:29, Stuart a écrit :
Hi Brad,

I am having the same problem.  I thought it was because Gramps needs Osm-Gps-Map installed.  The website says you can install it on Debian based distros as follows:
sudo apt-get install libosmgpsmap-dev python-osmgpsmap
But I tried this and I still cannot get the Geography view to work, so I am in the same boat as you.  Hopefully someone else is able to help

Regards,
Stuart

On 26/08/13 19:13, Brad Hernlem wrote:
Any suggestions how to resolve this problem?

Brad
Serge

------------------------------------------------------------------------------
Introducing Performance Central, a new site from SourceForge and
AppDynamics. Performance Central is your source for news, insights,
analysis and resources for efficient Application Performance Management.
Visit us today!
http://pubads.g.doubleclick.net/gampad/clk?id=48897511&iu=/4140/ostg.clktrk
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Geography category not showing in Gramps 4.0.1 (Linux Mint 15)

jerome
In reply to this post by Brad Hernlem

Hi,

I get it working under a Debian based distro (Ubuntu precise based!).

I followed instructions from
http://www.gramps-project.org/wiki/index.php?title=GEPS_029:_GTK3-GObject_introspection_Conversion#OsmGpsMap_for_Geography

I have both versions installed (for pygtk and python GObject) and they
are working fine for Gramps 3.4.x and 4.0.x!

Note, documentation on http://nzjrs.github.io/osm-gps-map/ was unclear
for me.

"Installing From Source

To build from source on Linux you will need to install the following
dependencies;

    libsoup-2.4
    gtk+-3.0
    cairo
    gobject-introspection

Once the dependencies have been installed you can build
osm-gps-map. On Linux perform the following;

    ./configure; make; make install #C library
    cd python; ./configure; make; make install #Python bindings"

I never saw this python directory on source... 

Anyway, after following steps on gramps wiki page and custom commands,
I got it working.


Jérôme


Le mar. 27 août 2013 at 0:13,Brad Hernlem <[hidden email]> a écrit
:
> Any suggestions how to resolve this problem?
>
> Brad
>


------------------------------------------------------------------------------
Introducing Performance Central, a new site from SourceForge and
AppDynamics. Performance Central is your source for news, insights,
analysis and resources for efficient Application Performance Management.
Visit us today!
http://pubads.g.doubleclick.net/gampad/clk?id=48897511&iu=/4140/ostg.clktrk
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Geography category not showing in Gramps 4.0.1 (Linux Mint 15)

Doug
On 27/08/13 07:48, Jerome wrote:

>
> Hi,
>
> I get it working under a Debian based distro (Ubuntu precise based!).
>
> I followed instructions from
> http://www.gramps-project.org/wiki/index.php?title=GEPS_029:_GTK3-GObject_introspection_Conversion#OsmGpsMap_for_Geography
>
> I have both versions installed (for pygtk and python GObject) and they
> are working fine for Gramps 3.4.x and 4.0.x!
>
> Note, documentation on http://nzjrs.github.io/osm-gps-map/ was unclear
> for me.
>
> "Installing From Source
>
> To build from source on Linux you will need to install the following
> dependencies;
>
> Â  Â  libsoup-2.4
> Â  Â  gtk+-3.0
> Â  Â  cairo
> Â  Â  gobject-introspection
>
> Once the dependencies have been installed you can build
> osm-gps-map. On Linux perform the following;
>
> Â  Â  ./configure; make; make install #C library
> Â  Â  cd python; ./configure; make; make install #Python bindings"
>
> I never saw this python directory on source...Â
>
<snip>

Hi,

I have it working on Mint Debian update 6 for 4.0.x with
python3 and Gtk3; but I have to admit it was something of a
struggle, getting all the dependencies installed and picked
up properly. The instructions were not all that clear to me
either.

As a first step it might be worth modifying the 'configure'
slightly to
./configure > fred (or suitable filename),then looking at
'fred' for any hints as to missing dependencies or the like
(or ones which you know are there but the compilation is not
going to pick up).

Doug


------------------------------------------------------------------------------
Learn the latest--Visual Studio 2012, SharePoint 2013, SQL 2012, more!
Discover the easy way to master current and previous Microsoft technologies
and advance your career. Get an incredible 1,500+ hours of step-by-step
tutorial videos with LearnDevNow. Subscribe today and save!
http://pubads.g.doubleclick.net/gampad/clk?id=58040911&iu=/4140/ostg.clktrk
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Geography category not showing in Gramps 4.0.1 (Linux Mint 15)

Brad Hernlem
I was about ready to give up on this after following the instructions in GEP_029 and still failing to see the Geography category in Gramps 4.0.1 even though I was convinced that I had all the requisite dependencies and packages installed. Going back to earlier version of Gramps returned the Geography category. But I wasn't content so I tried reinstalling 4.0.1 using GDebi and now it works.

Not sure why, but it works .... so far.

Brad


On Fri, Aug 30, 2013 at 7:47 AM, Brad Hernlem <[hidden email]> wrote:
I was about ready to give up on this after following the instructions in GEP_029 and still failing to see the Geography category in Gramps 4.0.1 even though I was convinced that I had all the requisite dependencies and packages installed. Going back to earlier version of Gramps returned the Geography category. But I wasn't content so I tried reinstalling 4.0.1 using GDebi and now it works.

Not sure why, but it works .... so far.

Brad


On Wed, Aug 28, 2013 at 4:02 AM, doug <[hidden email]> wrote:
On 27/08/13 07:48, Jerome wrote:
>
> Hi,
>
> I get it working under a Debian based distro (Ubuntu precise based!).
>
> I followed instructions from
> http://www.gramps-project.org/wiki/index.php?title=GEPS_029:_GTK3-GObject_introspection_Conversion#OsmGpsMap_for_Geography
>
> I have both versions installed (for pygtk and python GObject) and they
> are working fine for Gramps 3.4.x and 4.0.x!
>
> Note, documentation on http://nzjrs.github.io/osm-gps-map/ was unclear
> for me.
>
> "Installing From Source
>
> To build from source on Linux you will need to install the following
> dependencies;
>
> Â  Â  libsoup-2.4
> Â  Â  gtk+-3.0
> Â  Â  cairo
> Â  Â  gobject-introspection
>
> Once the dependencies have been installed you can build
> osm-gps-map. On Linux perform the following;
>
> Â  Â  ./configure; make; make install #C library
> Â  Â  cd python; ./configure; make; make install #Python bindings"
>
> I never saw this python directory on source...Â
>
<snip>

Hi,

I have it working on Mint Debian update 6 for 4.0.x with
python3 and Gtk3; but I have to admit it was something of a
struggle, getting all the dependencies installed and picked
up properly. The instructions were not all that clear to me
either.

As a first step it might be worth modifying the 'configure'
slightly to
./configure > fred (or suitable filename),then looking at
'fred' for any hints as to missing dependencies or the like
(or ones which you know are there but the compilation is not
going to pick up).

Doug


------------------------------------------------------------------------------
Learn the latest--Visual Studio 2012, SharePoint 2013, SQL 2012, more!
Discover the easy way to master current and previous Microsoft technologies
and advance your career. Get an incredible 1,500+ hours of step-by-step
tutorial videos with LearnDevNow. Subscribe today and save!
http://pubads.g.doubleclick.net/gampad/clk?id=58040911&iu=/4140/ostg.clktrk
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users



------------------------------------------------------------------------------
Learn the latest--Visual Studio 2012, SharePoint 2013, SQL 2012, more!
Discover the easy way to master current and previous Microsoft technologies
and advance your career. Get an incredible 1,500+ hours of step-by-step
tutorial videos with LearnDevNow. Subscribe today and save!
http://pubads.g.doubleclick.net/gampad/clk?id=58040911&iu=/4140/ostg.clktrk
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Geography category not showing in Gramps 4.0.1 (Linux Mint 15)

Doug
On 30/08/13 15:48, Brad Hernlem wrote:

> I was about ready to give up on this after following the instructions in
> GEP_029 and still failing to see the Geography category in Gramps 4.0.1
> even though I was convinced that I had all the requisite dependencies and
> packages installed. Going back to earlier version of Gramps returned the
> Geography category. But I wasn't content so I tried reinstalling 4.0.1
> using GDebi and now it works.
>
> Not sure why, but it works .... so far.
>
> Brad
>
>
<snip>

Hope it continues to do so - it's a wizard feature, isn't it!

Doug


------------------------------------------------------------------------------
Learn the latest--Visual Studio 2012, SharePoint 2013, SQL 2012, more!
Discover the easy way to master current and previous Microsoft technologies
and advance your career. Get an incredible 1,500+ hours of step-by-step
tutorial videos with LearnDevNow. Subscribe today and save!
http://pubads.g.doubleclick.net/gampad/clk?id=58040911&iu=/4140/ostg.clktrk
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Geography category not showing in Gramps 4.0.1 (Linux Mint 15)

Hivernat Emmanuel
Hello,

I'm running ubuntu 13.04 and i remember that it takes me time to make geography run. But I follow the indication in this page
http://www.gramps-project.org/wiki/index.php?title=Linux:Build_from_source#Full_install_walkthrough_Gramps_4.0_Ubuntu_derivatives
libgexiv2 must be 0.6.1
and osmgpsmap ***must be***** the Github version (no other version runs for me)
****very important to uninstall all other versions ******you have of this two elements (libosmgpsmap2, python-osmgpsmap)

of course this is only from my experience on my system 

Le 30/08/2013 19:56, doug a écrit :
On 30/08/13 15:48, Brad Hernlem wrote:
I was about ready to give up on this after following the instructions in
GEP_029 and still failing to see the Geography category in Gramps 4.0.1
even though I was convinced that I had all the requisite dependencies and
packages installed. Going back to earlier version of Gramps returned the
Geography category. But I wasn't content so I tried reinstalling 4.0.1
using GDebi and now it works.

Not sure why, but it works .... so far.

Brad


<snip>

Hope it continues to do so - it's a wizard feature, isn't it!

Doug


------------------------------------------------------------------------------
Learn the latest--Visual Studio 2012, SharePoint 2013, SQL 2012, more!
Discover the easy way to master current and previous Microsoft technologies
and advance your career. Get an incredible 1,500+ hours of step-by-step
tutorial videos with LearnDevNow. Subscribe today and save!
http://pubads.g.doubleclick.net/gampad/clk?id=58040911&iu=/4140/ostg.clktrk
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users




------------------------------------------------------------------------------
Learn the latest--Visual Studio 2012, SharePoint 2013, SQL 2012, more!
Discover the easy way to master current and previous Microsoft technologies
and advance your career. Get an incredible 1,500+ hours of step-by-step
tutorial videos with LearnDevNow. Subscribe today and save!
http://pubads.g.doubleclick.net/gampad/clk?id=58040911&iu=/4140/ostg.clktrk
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users