Gramps 4.1.1 rpm for fc20

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Gramps 4.1.1 rpm for fc20

Stan Cruise

Is there an ETA when a gracious person will create an rpm for fedora 20
for the 4.1.1 release?

A truely awesome thing would be an rpm for centos 7.0 .....




------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Gramps 4.1.1 rpm for fc20

Tom Hughes
On 30/10/14 23:42, Stan Cruise wrote:

> Is there an ETA when a gracious person will create an rpm for fedora 20
> for the 4.1.1 release?

No guarantees, but I've put the one I'm using up here:

   http://download.compton.nu/rpms/

It's just the existing 4.1.0 one from F21 beta rebuilt with the 4.1.1
source.

Tom

--
Tom Hughes ([hidden email])
http://compton.nu/

------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
--
Tom Hughes (tom@compton.nu)
http://compton.nu/
Reply | Threaded
Open this post in threaded view
|

Re: Gramps 4.1.1 rpm for fc20

Stan Cruise
Many thanks Tom, I will give it a try.

I feel the dumb one for begging for rpms, however I need to get up to
speed on compiling from source. I have the basic software background,
but it was a long time ago :).

Stan


On 10/30/2014 06:04 PM, Tom Hughes wrote:

> On 30/10/14 23:42, Stan Cruise wrote:
>
>> Is there an ETA when a gracious person will create an rpm for fedora 20
>> for the 4.1.1 release?
>
> No guarantees, but I've put the one I'm using up here:
>
>   http://download.compton.nu/rpms/
>
> It's just the existing 4.1.0 one from F21 beta rebuilt with the 4.1.1
> source.
>
> Tom
>


------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Gramps 4.1.1 rpm for fc20

Stan Cruise
Well I gave a try to installing from source - got a good way into it,
but gramps.grampsapp does not appear to be present, on several tries,
following the script on the gramps site. Kinda need the app I am guessing.

Then I tried out your rpm. But got snagged on python3-pyicu, which is
not available it seems for fc20. Then I read your note again and it does
day fc21, which makes sense.

It looks like I need to get to fc21. Not the first time that I have
snagged on the need for fc21 so will have to bite that bullet.

Thanks again,

Stan


On 10/30/2014 07:23 PM, Stan Cruise wrote:

> Many thanks Tom, I will give it a try.
>
> I feel the dumb one for begging for rpms, however I need to get up to
> speed on compiling from source. I have the basic software background,
> but it was a long time ago :).
>
> Stan
>
>
> On 10/30/2014 06:04 PM, Tom Hughes wrote:
>> On 30/10/14 23:42, Stan Cruise wrote:
>>
>>> Is there an ETA when a gracious person will create an rpm for fedora 20
>>> for the 4.1.1 release?
>>
>> No guarantees, but I've put the one I'm using up here:
>>
>>   http://download.compton.nu/rpms/
>>
>> It's just the existing 4.1.0 one from F21 beta rebuilt with the 4.1.1
>> source.
>>
>> Tom
>>
>


------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Gramps 4.1.1 rpm for fc20

Tom Hughes
On 31/10/14 05:07, Stan Cruise wrote:

> Then I tried out your rpm. But got snagged on python3-pyicu, which is
> not available it seems for fc20. Then I read your note again and it does
> day fc21, which makes sense.

Oh sorry, I forgot I had had to do that as well. I've added that to the
same place now. Again, just a build of the F21 package for F20.

Tom

--
Tom Hughes ([hidden email])
http://compton.nu/

------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
--
Tom Hughes (tom@compton.nu)
http://compton.nu/
Reply | Threaded
Open this post in threaded view
|

Re: Gramps 4.1.1 rpm for fc20

Eric Doutreleau
you can try mine here :)

http://rpms.doutreleau.fr

Le 31/10/2014 08:07, Tom Hughes a écrit :

> On 31/10/14 05:07, Stan Cruise wrote:
>
>> Then I tried out your rpm. But got snagged on python3-pyicu, which is
>> not available it seems for fc20. Then I read your note again and it does
>> day fc21, which makes sense.
> Oh sorry, I forgot I had had to do that as well. I've added that to the
> same place now. Again, just a build of the F21 package for F20.
>
> Tom
>


------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Gramps 4.1.1 rpm for fc20

Paul Franklin-5
I see that about nine hours ago somebody put RPMs
for fc20, fc19, and el7 centos into the gramps SourceForge
4.1.1 downloads page:

http://sourceforge.net/projects/gramps/files/Stable/4.1.1/

------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Gramps 4.1.1 rpm for fc20

Stan Cruise
In reply to this post by Tom Hughes
I installed the python3-yicu and then the gramps install worked. And
yes, the ToDo is fixed!
Nice. Many Thanks.

-----------------------------------------------------------------------

Understanding that this forum does not pertain to Linux basics, if
anyone can point me to a good place to educate myself on source building
etc, that would be nice. I am pretty good at working in the Linux world,
as I have a large number of VMs working, that I can experiment with. My
old software background will help me self-learn. I followed the source
build instructions for gramps, but I am missing something and therefore
require more careful work on this.

I did actually try pretty hard to find the update for python3, as I had
another problem where Evolution stopped connecting to iCloud
(authentication issue), and it appears that upgrading Evolution is the
only fix. But ran into the same dependency issue. So maybe I can fix
this now with the python3 rpm.

On the other hand I had taken it as a message that one needs to keep
moving on the Fedora wave, and simply get past fc20.

Again thanks a bunch. Very good to have support out there - not all
alone any more.


Stan


On 10/31/2014 01:07 AM, Tom Hughes wrote:

> On 31/10/14 05:07, Stan Cruise wrote:
>
>> Then I tried out your rpm. But got snagged on python3-pyicu, which is
>> not available it seems for fc20. Then I read your note again and it does
>> day fc21, which makes sense.
> Oh sorry, I forgot I had had to do that as well. I've added that to the
> same place now. Again, just a build of the F21 package for F20.
>
> Tom
>


------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Gramps 4.1.1 rpm for fc20

Paul Franklin-5
On 10/31/14, Stan Cruise <[hidden email]> wrote:
> Understanding that this forum does not pertain to Linux basics, if
> anyone can point me to a good place to educate myself on source building
> etc, that would be nice.

https://gramps-project.org/wiki/index.php?title=Running_a_development_version_of_Gramps
https://gramps-project.org/wiki/index.php?title=Linux:Build_from_source
https://gramps-project.org/wiki/index.php?title=Getting_started_with_Gramps_development

------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Gramps 4.1.1 rpm for fc20

Stan Cruise
In reply to this post by Paul Franklin-5
I tried the el7 one on CentOS 7, and the common rpm installed, but the
main rpm has 4 dependency issues. (gtk2 mostly). I found one as an rpm
and tried to install that, and it came back with even more gtk2
dependency issues. Usually at the second level of dependency hell I back
off before breaking my VM.

I will next try out the fc20 one on a clean fc20 VM.

Really, Dec 9 is not that far to wait for fc21 ....

However, to get working on CentOS 7 would be a coup, given its lifecycle.


On 10/31/2014 10:32 AM, Paul Franklin wrote:

> I see that about nine hours ago somebody put RPMs
> for fc20, fc19, and el7 centos into the gramps SourceForge
> 4.1.1 downloads page:
>
> http://sourceforge.net/projects/gramps/files/Stable/4.1.1/
>
> ------------------------------------------------------------------------------
> _______________________________________________
> Gramps-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gramps-users


------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Gramps 4.1.1 rpm for fc20

Ron Johnson
In reply to this post by Paul Franklin-5
This is why I fled the RPM World for that of Debian (and now Xubuntu).

On 11/01/2014 12:45 PM, Stan Cruise wrote:

> I tried the el7 one on CentOS 7, and the common rpm installed, but the
> main rpm has 4 dependency issues. (gtk2 mostly). I found one as an rpm
> and tried to install that, and it came back with even more gtk2
> dependency issues. Usually at the second level of dependency hell I back
> off before breaking my VM.
>
> I will next try out the fc20 one on a clean fc20 VM.
>
> Really, Dec 9 is not that far to wait for fc21 ....
>
> However, to get working on CentOS 7 would be a coup, given its lifecycle.
>
>
> On 10/31/2014 10:32 AM, Paul Franklin wrote:
>> I see that about nine hours ago somebody put RPMs
>> for fc20, fc19, and el7 centos into the gramps SourceForge
>> 4.1.1 downloads page:
>>
>> http://sourceforge.net/projects/gramps/files/Stable/4.1.1/


--
My word, man!  Don't you know your quantum statistics?


------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users