Gramps install problem on clean Ubuntu 15.04

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Gramps install problem on clean Ubuntu 15.04

brian fitzgerald
I just got a new workstation and  put a Ubuntu 15.05 Vervit on it. When I installed the Git repo 4.1.3 .deb file for Python 3 it went fine, seemingly, but when I started Gramps from the command line I got this;

brian@hercules:~$ gramps
.gramps.gen.utils.grampslocale.WARNING: ICU not loaded because No module named 'PyICU'. Localization will be impaired. Use your package manager to install PyICU
2015-06-02 11:29:14.172: WARNING: grampsapp.py: line 151:
You don't have the python bsddb3 package installed. This package is needed to start Gramps.

Gramps will terminate now.

what should I do next?
Thanks
Brian

------------------------------------------------------------------------------

_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Gramps install problem on clean Ubuntu 15.04

Ross Gammon
On 06/02/2015 10:46 PM, brian fitzgerald wrote:

> I just got a new workstation and  put a Ubuntu 15.05 Vervit on it. When
> I installed the Git repo 4.1.3 .deb file for Python 3 it went fine,
> seemingly, but when I started Gramps from the command line I got this;
>
> brian@hercules:~$ gramps
> .gramps.gen.utils.grampslocale.WARNING: ICU not loaded because No module
> named 'PyICU'. Localization will be impaired. Use your package manager
> to install PyICU
> 2015-06-02 11:29:14.172: WARNING: grampsapp.py: line 151:
> You don't have the python bsddb3 package installed. This package is
> needed to start Gramps.
>
> Gramps will terminate now.
>
> what should I do next?
$ sudo apt-get install python3-bsddb3 python3-icu

The ICU package is optional, but on a new machine there should be plenty
of space :-)

Cheers,

Ross


------------------------------------------------------------------------------

_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users

signature.asc (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Gramps install problem on clean Ubuntu 15.04

Dave Gilmore

On 2015-06-02 13:58, Ross Gammon wrote:

On 06/02/2015 10:46 PM, brian fitzgerald wrote:
I just got a new workstation and put a Ubuntu 15.05 Vervit on it. When I installed the Git repo 4.1.3 .deb file for Python 3 it went fine, seemingly, but when I started Gramps from the command line I got this; [hidden email]~$ gramps .gramps.gen.utils.grampslocale.WARNING: ICU not loaded because No module named 'PyICU'. Localization will be impaired. Use your package manager to install PyICU 2015-06-02 11:29:14.172: WARNING: grampsapp.py: line 151: You don't have the python bsddb3 package installed. This package is needed to start Gramps. Gramps will terminate now. what should I do next?
$ sudo apt-get install python3-bsddb3 python3-icu

The ICU package is optional, but on a new machine there should be plenty
of space :-)

Cheers,

Ross


------------------------------------------------------------------------------

_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users

I had the same issue and rather than installing the python3 stuff just installed the regular python deb package on Mint. Is there a big difference between using the python 2.x version vs python 3?

 

------------------------------------------------------------------------------

_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re : Gramps install problem on clean Ubuntu 15.04

jerome
In reply to this post by brian fitzgerald
Ah yes, launcher is designed for 'python'

#!/usr/bin/env python -O

Not certain what is the default python version?

Maybe something should be fixed on gramps42 branch and master,
where python3 is the python version?

https://github.com/gramps-project/gramps/blob/master/scripts/gramps


--------------------------------------------
En date de : Mar 2.6.15, brian fitzgerald <[hidden email]> a écrit :

 Objet: [Gramps-users] Gramps install problem on clean Ubuntu 15.04
 À: [hidden email]
 Date: Mardi 2 juin 2015, 22h46
 
 I just
 got a new workstation and  put a Ubuntu 15.05 Vervit on it.
 When I installed the Git repo 4.1.3 .deb file for Python 3
 it went fine, seemingly, but when I started Gramps from the
 command line I got this;
 
 brian@hercules:~$ gramps
 .gramps.gen.utils.grampslocale.WARNING: ICU not loaded
 because No module named 'PyICU'. Localization will
 be impaired. Use your package manager to install PyICU
 2015-06-02 11:29:14.172: WARNING: grampsapp.py: line 151:
 You don't have the python bsddb3 package installed. This
 package is needed to start Gramps.
 
 Gramps will terminate now.
 
 what should I do next?
 Thanks
 Brian
 
 -----La pièce jointe associée suit-----
 
 ------------------------------------------------------------------------------
 
 -----La pièce jointe associée suit-----
 
 _______________________________________________
 Gramps-users mailing list
 [hidden email]
 https://lists.sourceforge.net/lists/listinfo/gramps-users
 

------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Gramps install problem on clean Ubuntu 15.04

Peter Merchant
In reply to this post by brian fitzgerald

reformat the hard disk and install ubuntu 14.04 or .10
Ubuntu 15 is not clean.  I would wait for it for a few months.

PM.

On 02/06/15 21:46, brian fitzgerald wrote:
I just got a new workstation and  put a Ubuntu 15.05 Vervit on it. When I installed the Git repo 4.1.3 .deb file for Python 3 it went fine, seemingly, but when I started Gramps from the command line I got this;

brian@hercules:~$ gramps
.gramps.gen.utils.grampslocale.WARNING: ICU not loaded because No module named 'PyICU'. Localization will be impaired. Use your package manager to install PyICU
2015-06-02 11:29:14.172: WARNING: grampsapp.py: line 151:
You don't have the python bsddb3 package installed. This package is needed to start Gramps.

Gramps will terminate now.

what should I do next?
Thanks
Brian


------------------------------------------------------------------------------


_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users


------------------------------------------------------------------------------

_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Gramps install problem on clean Ubuntu 15.04

jan bullock
*I can say this is working fine in pclinuxos, as I just set up a
bootable usb with persistence and installed gramps from the repository.


jan
*

>
> reformat the hard disk and install ubuntu 14.04 or .10
> Ubuntu 15 is not clean.  I would wait for it for a few months.
>
> PM.
>
> On 02/06/15 21:46, brian fitzgerald wrote:
>> I just got a new workstation and  put a Ubuntu 15.05 Vervit on it.
>> When I installed the Git repo 4.1.3 .deb file for Python 3 it went
>> fine, seemingly, but when I started Gramps from the command line I
>> got this;
>>
>> brian@hercules:~$ gramps
>> .gramps.gen.utils.grampslocale.WARNING: ICU not loaded because No
>> module named 'PyICU'. Localization will be impaired. Use your package
>> manager to install PyICU
>> 2015-06-02 11:29:14.172: WARNING: grampsapp.py: line 151:
>> You don't have the python bsddb3 package installed. This package is
>> needed to start Gramps.
>>
>> Gramps will terminate now.
>>
>> what should I do next?
>> Thanks
>> Brian
>>
>>
>> ------------------------------------------------------------------------------
>>    
>>
>>
>> _______________________________________________
>> Gramps-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/gramps-users
>>    
>
> ------------------------------------------------------------------------
>
> ------------------------------------------------------------------------------
>  
> ------------------------------------------------------------------------
>
> _______________________________________________
> Gramps-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gramps-users
>  


------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users