Gtkspell v3

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Gtkspell v3

Ron Johnson
Hi,

http://www.gramps-project.org/wiki/index.php?title=GEPS_029:_GTK3-GObject_introspection_Conversion#Spell_Check_Install

This page says that we need v3.3.0, but http://gtkspell.sourceforge.net/ 
says that v3.0.3 is the latest version.  Is this a typo in the gramps docs
or am I missing something?

BTW, Ubuntu 13.04 also has v3.0.0 but v13.10 will have v3.0.3.

--
"There are no solutions; there are only tradeoffs."
Thomas Sowell


------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Gtkspell v3

Benny Malengier



2013/7/1 Ron Johnson <[hidden email]>
Hi,

http://www.gramps-project.org/wiki/index.php?title=GEPS_029:_GTK3-GObject_introspection_Conversion#Spell_Check_Install

This page says that we need v3.3.0, but http://gtkspell.sourceforge.net/
says that v3.0.3 is the latest version.  Is this a typo in the gramps docs
or am I missing something?

Yes,  GtkSpell-3.0.typelib is suffiient to have spell checking.
confusion comes frrom the fact you need gtkspell3 3.0 which looks like 3.3.0

GtkSpell was not converted yet officially when we used it, so version numbers were not yet certain. I have working spell check in ubuntu 12.10.

Benny


BTW, Ubuntu 13.04 also has v3.0.0 but v13.10 will have v3.0.3.

--
"There are no solutions; there are only tradeoffs."
Thomas Sowell


------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users


------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Gtkspell v3

Ron Johnson
In reply to this post by Ron Johnson
For people using 13.04 Raring, the gir1.2-gtkspell3-3.0 and libgtkspell3-3-0 from ppa:vascofalves/gnome-backports enables spell checking even though it's only gtkspell v3.0.2.

https://launchpad.net/~vascofalves/+archive/gnome-backports

On 07/01/2013 04:05 AM, Benny Malengier wrote:



2013/7/1 Ron Johnson <[hidden email]>
Hi,

http://www.gramps-project.org/wiki/index.php?title=GEPS_029:_GTK3-GObject_introspection_Conversion#Spell_Check_Install

This page says that we need v3.3.0, but http://gtkspell.sourceforge.net/
says that v3.0.3 is the latest version.  Is this a typo in the gramps docs
or am I missing something?

Yes,  GtkSpell-3.0.typelib is suffiient to have spell checking.
confusion comes frrom the fact you need gtkspell3 3.0 which looks like 3.3.0

GtkSpell was not converted yet officially when we used it, so version numbers were not yet certain. I have working spell check in ubuntu 12.10.

Benny


-- 
"There are no solutions; there are only tradeoffs."
Thomas Sowell

------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Gtkspell v3

enno
In reply to this post by Benny Malengier
Benny,
> Yes,  GtkSpell-3.0.typelib is suffiient to have spell checking.
> confusion comes frrom the fact you need gtkspell3 3.0 which looks like
> 3.3.0
And was also spelled as 3.3.0 on the wiki, twice. I just corrected that
[1] to match your text above.

regards,

Enno

[1]
http://www.gramps-project.org/wiki/index.php?title=GEPS_029:_GTK3-GObject_introspection_Conversion#Spell_Check_Install


------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users