Mac OS X 10.10.1

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Mac OS X 10.10.1

Elvin Birth
I have upgraded computer and software. Now my Gramps 4.1.3-1 won't open. 

What are the remedies?  I don't believe I have the ability to go back to an earlier version of OS X.

Elvin Birth

------------------------------------------------------------------------------

_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Mac OS X 10.10.1

Ron Johnson
Open a command window and type "gramps".  Then paste in any error messages.

On 06/18/2015 03:14 PM, Elvin Birth wrote:
> I have upgraded computer and software. Now my Gramps 4.1.3-1 won't open.
>
> What are the remedies?  I don't believe I have the ability to go back to
> an earlier version of OS X.
>
> Elvin Birth

--
"Where it is a duty to worship the sun it is pretty sure to be a
crime to examine the laws of heat." Christopher Morley


------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Mac OS X 10.10.1

Tim Lyons
Administrator
In reply to this post by Elvin Birth
You will probably have to use Console (in Applications -> Utilities) to see the error messages. Run Console, and select the 'All Messages' entry from the Log List. Then try to run Grams again.

You should see some error messages in Console. Click on the first applicable message, then shift click on the last, and copy them and post them on this mailing list.

Regards,
Tim.
Reply | Threaded
Open this post in threaded view
|

Re: Mac OS X 10.10.1

jerome
In reply to this post by Ron Johnson
See also https://gramps-project.org/wiki/index.php?title=Gramps_4.1_Wiki_Manual_-_Command_Line#Mac_OS_X



--------------------------------------------
En date de : Jeu 18.6.15, Ron Johnson <[hidden email]> a écrit :

 Objet: Re: [Gramps-users] Mac OS X 10.10.1
 À: "GRAMPS" <[hidden email]>
 Date: Jeudi 18 juin 2015, 22h26
 
 Open a command window and type
 "gramps".  Then paste in any error messages.
 
 On 06/18/2015 03:14 PM, Elvin Birth wrote:
 > I have upgraded computer and software. Now my Gramps
 4.1.3-1 won't open.
 >
 > What are the remedies?  I don't believe I have the
 ability to go back to
 > an earlier version of OS X.
 >
 > Elvin Birth
 
 --
 "Where it is a duty to worship the sun it is pretty sure to
 be a
 crime to examine the laws of heat." Christopher Morley
 
 
 ------------------------------------------------------------------------------
 _______________________________________________
 Gramps-users mailing list
 [hidden email]
 https://lists.sourceforge.net/lists/listinfo/gramps-users
 

------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Mac OS X 10.10.1

Elvin Birth
In reply to this post by Elvin Birth
Thank you, all, for the tips and clarifications. Here are the error messages:

Terminal message—

Last login: Fri Jun 19 09:53:04 on console
Elvin-Birth-MacBook-Air:~ elvinbirth$ /Applications/Gramps.app/Contents/MacOS/Gramps
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.


Console messages—-

6/19/15 10:02:44.219 AM Console[528]: Failed to connect (_consoleX) outlet from (NSApplication) to (ConsoleX): missing setter or instance variable
6/19/15 10:03:28.434 AM defaults[547]: 
The domain/default pair of (/Users/elvinbirth/Library/Preferences/org.gramps-project.gramps, AppleCollationOrder) does not exist
6/19/15 10:06:00.984 AM login[554]: USER_PROCESS: 554 ttys000
6/19/15 10:06:05.529 AM defaults[570]: 
The domain/default pair of (/Users/elvinbirth/Library/Preferences/org.gramps-project.gramps, AppleCollationOrder) does not exist
6/19/15 10:07:39.363 AM CoreServicesUIAgent[321]: unexpected message <OS_xpc_error: <error: 0x7fff7a70dc60> { count = 1, contents =
"XPCErrorDescription" => <string: 0x7fff7a70df70> { length = 18, contents = "Connection invalid" }
}>

Also appearing was the Gramps error message saying that "Gramps is locked"  

Elvin


------------------------------------------------------------------------------

_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Mac OS X 10.10.1

Tim Lyons
Administrator
Elvin Birth wrote
Thank you, all, for the tips and clarifications. Here are the error
messages:

Terminal message—

Last login: Fri Jun 19 09:53:04 on console
Elvin-Birth-MacBook-Air:~ elvinbirth$
/Applications/Gramps.app/Contents/MacOS/Gramps
Gtk-Message: GtkDialog mapped without a transient parent. This is
discouraged.


Console messages—-

6/19/15 10:02:44.219 AM Console[528]: Failed to connect (_consoleX) outlet
from (NSApplication) to (ConsoleX): missing setter or instance variable
6/19/15 10:03:28.434 AM defaults[547]:
The domain/default pair of
(/Users/elvinbirth/Library/Preferences/org.gramps-project.gramps,
AppleCollationOrder) does not exist
6/19/15 10:06:00.984 AM login[554]: USER_PROCESS: 554 ttys000
6/19/15 10:06:05.529 AM defaults[570]:
The domain/default pair of
(/Users/elvinbirth/Library/Preferences/org.gramps-project.gramps,
AppleCollationOrder) does not exist
6/19/15 10:07:39.363 AM CoreServicesUIAgent[321]: unexpected message
<OS_xpc_error: <error: 0x7fff7a70dc60> { count = 1, contents =
"XPCErrorDescription" => <string: 0x7fff7a70df70> { length = 18, contents =
"Connection invalid" }
}>

Also appearing was the Gramps error message saying that "Gramps is locked"
There is no indication in the messages that you have shown that Gramps is failing to start in the new operating system. The fact that you are getting a Gramps message about something being 'locked' suggests that the problem is that your database is locked.

Please have a look at
https://gramps-project.org/wiki/index.php?title=Gramps_4.1_Wiki_Manual_-_Manage_Family_Trees#Unlocking_a_Family_Tree
which may help you to identify (and possibly resolve) this issue.

regards,
Tim.