Making gramplet available in plugin manager

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Making gramplet available in plugin manager

Stephen Adams
Hi everyone,

While on vacation I noticed I couldn't use the plugin manager to install the gramplet I created prior to the release of Gramps v5.0.0.  At that time it was suggested I choose a target version of 5.1 so that certain merges could happen prior to unleashing it on the general masses.

Now that 5.0.0 is released should I edit the .gpy file in the repository to reflect 5.0.0?  Is this the only change that is required in order for the gramplet to start appearing in the Plugin Manager?

Thanks

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: Making gramplet available in plugin manager

prculley
Assuming you have the addon in the master branch of the Gramps-addons repository, you would want to make a copy of your addon to the gramps50 branch of the repository, with the gramps_target_version = '5.0' in the gpr file.
Then you would do the build and listing steps as described in the addons development wiki (or get someone else to do those if you don't have push rights to the 'addons' repository yet).

I also assume you have tested your addon with the Gramps 5.0.0 release, to make sure it works and that any required fixes or enhancements are actually present in that release.

Paul C.


On Sun, Aug 26, 2018 at 9:12 AM Stephen Adams <[hidden email]> wrote:
Hi everyone,

While on vacation I noticed I couldn't use the plugin manager to install the gramplet I created prior to the release of Gramps v5.0.0.  At that time it was suggested I choose a target version of 5.1 so that certain merges could happen prior to unleashing it on the general masses.

Now that 5.0.0 is released should I edit the .gpy file in the repository to reflect 5.0.0?  Is this the only change that is required in order for the gramplet to start appearing in the Plugin Manager?

Thanks
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel