Network Chart Report - installation errors in gramps 5.0.0

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Network Chart Report - installation errors in gramps 5.0.0

Doug-11
When I try installing the new Network Chart Report I get the
following error message:

"Installation Errors - The following addons had errors.
  Network Chart (0.0.12)"

I'm running LMDE2 with python3-networkx 1.9, graphviz
2.38.0-7 and graphviz-dev, python-pygraphviz 1.3,
python3-pygraph 1.8.
My gramps settings are:
----------------
  python    : 3.4.2
  gramps    : 5.0.0
  gtk++     : 3.14.5
  pygobject : 3.14.0
  pango     : 1.36.8
  cairo     : 1.14.0
  pycairo   : 1.10.0
  osmgpsmap : 1.0
  GExiv2    : 0.10
  ICU       : 52.1
  PyICU     : 1.8
  o.s.      : linux
  kernel    : 3.16.0-6-amd64

Environment settings:
---------------------
  LANG      : en_GB.UTF-8
  LANGUAGE  : en_GB
  GRAMPSI18N: not set
  GRAMPSHOME: not set
  GRAMPSDIR : not set
  PYTHONPATH:
     /usr/lib/python3/dist-packages/gramps
     /usr/bin
     /usr/lib/python3.4
     /usr/lib/python3.4/plat-x86_64-linux-gnu
     /usr/lib/python3.4/lib-dynload
     /usr/local/lib/python3.4/dist-packages
     /usr/lib/python3/dist-packages

Non-python dependencies:
------------------------
  Graphviz  : 2.38
  Ghostscr. : 9.06

System PATH env variable:
-------------------------
      /usr/local/bin
      /usr/bin
      /bin
      /usr/local/games
      /usr/games
      /usr/local/sbin
      /usr/sbin
      /sbin
      /usr/local/sbin
      /usr/sbin
      /sbin

Databases:
-------------------------
  bsddb     :
      version     : 6.1.0
      db version  : 5.3.28
      location    :
/usr/lib/python3/dist-packages/bsddb3/__init__.py
  sqlite3   :
      version     : 3.8.7.1
      py version  : 2.6.0
      location    : /usr/lib/python3.4/sqlite3/__init__.py


Can someone throw light on what's wrong? What do I need to do?

Doug





_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: Network Chart Report - installation errors in gramps 5.0.0

Doug-11
Thanks, Paul and Sam.

The Prerequisites Checker gramplet is a godsend!
I've been able to install Network Chart and get it running
fine on a clean 5.0 installation.

My original problem was on a different computer running 4.2
on which I also installed 5.0. Although the two gramps
versions seem to co-exist happily, I haven't yet got to the
bottom of the 5.0 prerequisites, so I don't know for sure
whether the Network Chart error is due to the prerequisites
or to some version incompatibility.

Doug


On 21/09/18 02:45, Sam Manzi wrote:

> Does any of the advice from the third party addons support
> page Troubleshooting section help?
>
> https://gramps-project.org/wiki/index.php?title=NetworkChart#Prerequisites
>
> On 18 September 2018 at 22:29, Doug
> <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     When I try installing the new Network Chart Report I get
>     the following error message:
>
>     "Installation Errors - The following addons had
>     errors.  Network Chart (0.0.12)"
>
>     I'm running LMDE2 with python3-networkx 1.9, graphviz
>     2.38.0-7 and graphviz-dev, python-pygraphviz 1.3,
>     python3-pygraph 1.8.
>     My gramps settings are:
>     ----------------
>      python    : 3.4.2
>      gramps    : 5.0.0
>      gtk++     : 3.14.5
>      pygobject : 3.14.0
>      pango     : 1.36.8
>      cairo     : 1.14.0
>      pycairo   : 1.10.0
>      osmgpsmap : 1.0
>      GExiv2    : 0.10
>      ICU       : 52.1
>      PyICU     : 1.8
>      o.s.      : linux
>      kernel    : 3.16.0-6-amd64
>
>     Environment settings:
>     ---------------------
>      LANG      : en_GB.UTF-8
>      LANGUAGE  : en_GB
>      GRAMPSI18N: not set
>      GRAMPSHOME: not set
>      GRAMPSDIR : not set
>      PYTHONPATH:
>         /usr/lib/python3/dist-packages/gramps
>         /usr/bin
>         /usr/lib/python3.4
>         /usr/lib/python3.4/plat-x86_64-linux-gnu
>         /usr/lib/python3.4/lib-dynload
>         /usr/local/lib/python3.4/dist-packages
>         /usr/lib/python3/dist-packages
>
>     Non-python dependencies:
>     ------------------------
>      Graphviz  : 2.38
>      Ghostscr. : 9.06
>
>     System PATH env variable:
>     -------------------------
>          /usr/local/bin
>          /usr/bin
>          /bin
>          /usr/local/games
>          /usr/games
>          /usr/local/sbin
>          /usr/sbin
>          /sbin
>          /usr/local/sbin
>          /usr/sbin
>          /sbin
>
>     Databases:
>     -------------------------
>      bsddb     :
>          version     : 6.1.0
>          db version  : 5.3.28
>          location    :
>     /usr/lib/python3/dist-packages/bsddb3/__init__.py
>      sqlite3   :
>          version     : 3.8.7.1
>          py version  : 2.6.0
>          location    :
>     /usr/lib/python3.4/sqlite3/__init__.py
>
>
>     Can someone throw light on what's wrong? What do I need
>     to do?
>
>     Doug
>
>
>
>
>
>     _______________________________________________
>     Gramps-devel mailing list
>     [hidden email]
>     <mailto:[hidden email]>
>     https://lists.sourceforge.net/lists/listinfo/gramps-devel <https://lists.sourceforge.net/lists/listinfo/gramps-devel>
>
>



_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: Network Chart Report - installation errors in gramps 5.0.0

dave.khuon@gmail.com
Me too, I have both 4.2.6 and 5.0 installed.  I never used the network chart before.  

Upon receiving your email yesterday, I clicked to install everything found by the plugins manager (new updates, new available plugins), then I ran the network chart.  It went fine for me.  My platform is Win 10, and I am using the AIO installation.

Hope this would help.

On Fri, Sep 21, 2018, 5:19 AM Doug <[hidden email]> wrote:
Thanks, Paul and Sam.

The Prerequisites Checker gramplet is a godsend!
I've been able to install Network Chart and get it running
fine on a clean 5.0 installation.

My original problem was on a different computer running 4.2
on which I also installed 5.0. Although the two gramps
versions seem to co-exist happily, I haven't yet got to the
bottom of the 5.0 prerequisites, so I don't know for sure
whether the Network Chart error is due to the prerequisites
or to some version incompatibility.

Doug


On 21/09/18 02:45, Sam Manzi wrote:
> Does any of the advice from the third party addons support
> page Troubleshooting section help?
>
> https://gramps-project.org/wiki/index.php?title=NetworkChart#Prerequisites
>
> On 18 September 2018 at 22:29, Doug
> <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     When I try installing the new Network Chart Report I get
>     the following error message:
>
>     "Installation Errors - The following addons had
>     errors.  Network Chart (0.0.12)"
>
>     I'm running LMDE2 with python3-networkx 1.9, graphviz
>     2.38.0-7 and graphviz-dev, python-pygraphviz 1.3,
>     python3-pygraph 1.8.
>     My gramps settings are:
>     ----------------
>     Â python    : 3.4.2
>     Â gramps    : 5.0.0
>     Â gtk++     : 3.14.5
>     Â pygobject : 3.14.0
>     Â pango     : 1.36.8
>     Â cairo     : 1.14.0
>     Â pycairo   : 1.10.0
>     Â osmgpsmap : 1.0
>     Â GExiv2    : 0.10
>     Â ICU       : 52.1
>     Â PyICU     : 1.8
>     Â o.s.      : linux
>     Â kernel    : 3.16.0-6-amd64
>
>     Environment settings:
>     ---------------------
>     Â LANG      : en_GB.UTF-8
>     Â LANGUAGE  : en_GB
>     Â GRAMPSI18N: not set
>     Â GRAMPSHOME: not set
>     Â GRAMPSDIR : not set
>     Â PYTHONPATH:
>     Â Â Â  /usr/lib/python3/dist-packages/gramps
>     Â Â Â  /usr/bin
>     Â Â Â  /usr/lib/python3.4
>     Â Â Â  /usr/lib/python3.4/plat-x86_64-linux-gnu
>     Â Â Â  /usr/lib/python3.4/lib-dynload
>     Â Â Â  /usr/local/lib/python3.4/dist-packages
>     Â Â Â  /usr/lib/python3/dist-packages
>
>     Non-python dependencies:
>     ------------------------
>     Â Graphviz  : 2.38
>     Â Ghostscr. : 9.06
>
>     System PATH env variable:
>     -------------------------
>     Â Â Â Â  /usr/local/bin
>     Â Â Â Â  /usr/bin
>     Â Â Â Â  /bin
>     Â Â Â Â  /usr/local/games
>     Â Â Â Â  /usr/games
>     Â Â Â Â  /usr/local/sbin
>     Â Â Â Â  /usr/sbin
>     Â Â Â Â  /sbin
>     Â Â Â Â  /usr/local/sbin
>     Â Â Â Â  /usr/sbin
>     Â Â Â Â  /sbin
>
>     Databases:
>     -------------------------
>     Â bsddb     :
>     Â Â Â Â  version     : 6.1.0
>     Â Â Â Â  db version  : 5.3.28
>     Â Â Â Â  location    :
>     /usr/lib/python3/dist-packages/bsddb3/__init__.py
>     Â sqlite3   :
>     Â Â Â Â  version     : 3.8.7.1
>     Â Â Â Â  py version  : 2.6.0
>     Â Â Â Â  location    :
>     /usr/lib/python3.4/sqlite3/__init__.py
>
>
>     Can someone throw light on what's wrong? What do I need
>     to do?
>
>     Doug
>
>
>
>
>
>     _______________________________________________
>     Gramps-devel mailing list
>     [hidden email]
>     <mailto:[hidden email]>
>     https://lists.sourceforge.net/lists/listinfo/gramps-devel <https://lists.sourceforge.net/lists/listinfo/gramps-devel>
>
>



_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel


_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: Network Chart Report - installation errors in gramps 5.0.0

Doug-11
Hmm. I've been running 4.2.6 for several years, but added
5.0 quite recently. I suspect 4.2.6 might have set things up
with some dependencies that are out of date for 5.0 (but I
haven't got to the bottom of the prequisites checker list yet).

Which way round did you install 4.2.6 and 5.0? 5.0, then
4.2.6 or like me?

Doug

On 21/09/18 15:28, Dave Khuon wrote:

> Me too, I have both 4.2.6 and 5.0 installed.  I never used
> the network chart before. Â
>
> Upon receiving your email yesterday, I clicked to install
> everything found by the plugins manager (new updates, new
> available plugins), then I ran the network chart.  It went
> fine for me.  My platform is Win 10, and I am using the AIO
> installation.
>
> Hope this would help.
>
> On Fri, Sep 21, 2018, 5:19 AM Doug
> <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Thanks, Paul and Sam.
>
>     The Prerequisites Checker gramplet is a godsend!
>     I've been able to install Network Chart and get it running
>     fine on a clean 5.0 installation.
>
>     My original problem was on a different computer running 4.2
>     on which I also installed 5.0. Although the two gramps
>     versions seem to co-exist happily, I haven't yet got to the
>     bottom of the 5.0 prerequisites, so I don't know for sure
>     whether the Network Chart error is due to the prerequisites
>     or to some version incompatibility.
>
>     Doug
>
>
>     On 21/09/18 02:45, Sam Manzi wrote:
>      > Does any of the advice from the third party addons
>     support
>      > page Troubleshooting section help?
>      >
>      >
>     https://gramps-project.org/wiki/index.php?title=NetworkChart#Prerequisites
>      >
>      > On 18 September 2018 at 22:29, Doug
>      > <[hidden email]
>     <mailto:[hidden email]>
>      > <mailto:[hidden email]
>     <mailto:[hidden email]>>> wrote:
>      >
>      >     When I try installing the new Network Chart
>     Report I get
>      >     the following error message:
>      >
>      >     "Installation Errors - The following addons had
>      >     errors.  Network Chart (0.0.12)"
>      >
>      >     I'm running LMDE2 with python3-networkx 1.9,
>     graphviz
>      >     2.38.0-7 and graphviz-dev, python-pygraphviz 1.3,
>      >     python3-pygraph 1.8.
>      >     My gramps settings are:
>      >     ----------------
>      >     Â python    : 3.4.2
>      >     Â gramps    : 5.0.0
>      >     Â gtk++     : 3.14.5
>      >     Â pygobject : 3.14.0
>      >     Â pango     : 1.36.8
>      >     Â cairo     : 1.14.0
>      >     Â pycairo   : 1.10.0
>      >     Â osmgpsmap : 1.0
>      >     Â GExiv2    : 0.10
>      >     Â ICU       : 52.1
>      >     Â PyICU     : 1.8
>      >     Â o.s.      : linux
>      >     Â kernel    : 3.16.0-6-amd64
>      >
>      >     Environment settings:
>      >     ---------------------
>      >     Â LANG      : en_GB.UTF-8
>      >     Â LANGUAGE  : en_GB
>      >     Â GRAMPSI18N: not set
>      >     Â GRAMPSHOME: not set
>      >     Â GRAMPSDIR : not set
>      >     Â PYTHONPATH:
>      >     Â Â Â  /usr/lib/python3/dist-packages/gramps
>      >     Â Â Â  /usr/bin
>      >     Â Â Â  /usr/lib/python3.4
>      >     Â Â ÂÂ
>     /usr/lib/python3.4/plat-x86_64-linux-gnu
>      >     Â Â Â  /usr/lib/python3.4/lib-dynload
>      >     Â Â ÂÂ
>     /usr/local/lib/python3.4/dist-packages
>      >     Â Â Â  /usr/lib/python3/dist-packages
>      >
>      >     Non-python dependencies:
>      >     ------------------------
>      >     Â Graphviz  : 2.38
>      >     Â Ghostscr. : 9.06
>      >
>      >     System PATH env variable:
>      >     -------------------------
>      >     Â Â Â Â  /usr/local/bin
>      >     Â Â Â Â  /usr/bin
>      >     Â Â Â Â  /bin
>      >     Â Â Â Â  /usr/local/games
>      >     Â Â Â Â  /usr/games
>      >     Â Â Â Â  /usr/local/sbin
>      >     Â Â Â Â  /usr/sbin
>      >     Â Â Â Â  /sbin
>      >     Â Â Â Â  /usr/local/sbin
>      >     Â Â Â Â  /usr/sbin
>      >     Â Â Â Â  /sbin
>      >
>      >     Databases:
>      >     -------------------------
>      >     Â bsddb     :
>      >     Â Â Â Â  version     : 6.1.0
>      >     Â Â Â Â  db version  : 5.3.28
>      >     Â Â Â Â  location    :
>      >     /usr/lib/python3/dist-packages/bsddb3/__init__.py
>      >     Â sqlite3   :
>      >     Â Â Â Â  version     : 3.8.7.1
>      >     Â Â Â Â  py version  : 2.6.0
>      >     Â Â Â Â  location    :
>      >     /usr/lib/python3.4/sqlite3/__init__.py
>      >
>      >
>      >     Can someone throw light on what's wrong? What
>     do I need
>      >     to do?
>      >
>      >     Doug
>      >
>      >
>      >
>      >
>      >
>      >     _______________________________________________
>      >     Gramps-devel mailing list
>      >     [hidden email]
>     <mailto:[hidden email]>
>      >     <mailto:[hidden email]
>     <mailto:[hidden email]>>
>      >    Â
>     https://lists.sourceforge.net/lists/listinfo/gramps-devel <https://lists.sourceforge.net/lists/listinfo/gramps-devel>
>      >
>      >
>
>
>
>     _______________________________________________
>     Gramps-devel mailing list
>     [hidden email]
>     <mailto:[hidden email]>
>     https://lists.sourceforge.net/lists/listinfo/gramps-devel
>



_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: Network Chart Report - installation errors in gramps 5.0.0

dave.khuon@gmail.com
4.2.6 for about a year (?), Then 5.0.0 when it became available in August (?).  I am bad at the dates.

On Fri, Sep 21, 2018, 11:40 AM Doug <[hidden email]> wrote:
Hmm. I've been running 4.2.6 for several years, but added
5.0 quite recently. I suspect 4.2.6 might have set things up
with some dependencies that are out of date for 5.0 (but I
haven't got to the bottom of the prequisites checker list yet).

Which way round did you install 4.2.6 and 5.0? 5.0, then
4.2.6 or like me?

Doug

On 21/09/18 15:28, Dave Khuon wrote:
> Me too, I have both 4.2.6 and 5.0 installed.  I never used
> the network chart before. Â
>
> Upon receiving your email yesterday, I clicked to install
> everything found by the plugins manager (new updates, new
> available plugins), then I ran the network chart.  It went
> fine for me.  My platform is Win 10, and I am using the AIO
> installation.
>
> Hope this would help.
>
> On Fri, Sep 21, 2018, 5:19 AM Doug
> <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Thanks, Paul and Sam.
>
>     The Prerequisites Checker gramplet is a godsend!
>     I've been able to install Network Chart and get it running
>     fine on a clean 5.0 installation.
>
>     My original problem was on a different computer running 4.2
>     on which I also installed 5.0. Although the two gramps
>     versions seem to co-exist happily, I haven't yet got to the
>     bottom of the 5.0 prerequisites, so I don't know for sure
>     whether the Network Chart error is due to the prerequisites
>     or to some version incompatibility.
>
>     Doug
>
>
>     On 21/09/18 02:45, Sam Manzi wrote:
>      > Does any of the advice from the third party addons
>     support
>      > page Troubleshooting section help?
>      >
>      >
>     https://gramps-project.org/wiki/index.php?title=NetworkChart#Prerequisites
>      >
>      > On 18 September 2018 at 22:29, Doug
>      > <[hidden email]
>     <mailto:[hidden email]>
>      > <mailto:[hidden email]
>     <mailto:[hidden email]>>> wrote:
>      >
>      >     When I try installing the new Network Chart
>     Report I get
>      >     the following error message:
>      >
>      >     "Installation Errors - The following addons had
>      >     errors.  Network Chart (0.0.12)"
>      >
>      >     I'm running LMDE2 with python3-networkx 1.9,
>     graphviz
>      >     2.38.0-7 and graphviz-dev, python-pygraphviz 1.3,
>      >     python3-pygraph 1.8.
>      >     My gramps settings are:
>      >     ----------------
>      >     Â python    : 3.4.2
>      >     Â gramps    : 5.0.0
>      >     Â gtk++     : 3.14.5
>      >     Â pygobject : 3.14.0
>      >     Â pango     : 1.36.8
>      >     Â cairo     : 1.14.0
>      >     Â pycairo   : 1.10.0
>      >     Â osmgpsmap : 1.0
>      >     Â GExiv2    : 0.10
>      >     Â ICU       : 52.1
>      >     Â PyICU     : 1.8
>      >     Â o.s.      : linux
>      >     Â kernel    : 3.16.0-6-amd64
>      >
>      >     Environment settings:
>      >     ---------------------
>      >     Â LANG      : en_GB.UTF-8
>      >     Â LANGUAGE  : en_GB
>      >     Â GRAMPSI18N: not set
>      >     Â GRAMPSHOME: not set
>      >     Â GRAMPSDIR : not set
>      >     Â PYTHONPATH:
>      >     Â Â Â  /usr/lib/python3/dist-packages/gramps
>      >     Â Â Â  /usr/bin
>      >     Â Â Â  /usr/lib/python3.4
>      >     Â Â ÂÂ
>     /usr/lib/python3.4/plat-x86_64-linux-gnu
>      >     Â Â Â  /usr/lib/python3.4/lib-dynload
>      >     Â Â ÂÂ
>     /usr/local/lib/python3.4/dist-packages
>      >     Â Â Â  /usr/lib/python3/dist-packages
>      >
>      >     Non-python dependencies:
>      >     ------------------------
>      >     Â Graphviz  : 2.38
>      >     Â Ghostscr. : 9.06
>      >
>      >     System PATH env variable:
>      >     -------------------------
>      >     Â Â Â Â  /usr/local/bin
>      >     Â Â Â Â  /usr/bin
>      >     Â Â Â Â  /bin
>      >     Â Â Â Â  /usr/local/games
>      >     Â Â Â Â  /usr/games
>      >     Â Â Â Â  /usr/local/sbin
>      >     Â Â Â Â  /usr/sbin
>      >     Â Â Â Â  /sbin
>      >     Â Â Â Â  /usr/local/sbin
>      >     Â Â Â Â  /usr/sbin
>      >     Â Â Â Â  /sbin
>      >
>      >     Databases:
>      >     -------------------------
>      >     Â bsddb     :
>      >     Â Â Â Â  version     : 6.1.0
>      >     Â Â Â Â  db version  : 5.3.28
>      >     Â Â Â Â  location    :
>      >     /usr/lib/python3/dist-packages/bsddb3/__init__.py
>      >     Â sqlite3   :
>      >     Â Â Â Â  version     : 3.8.7.1
>      >     Â Â Â Â  py version  : 2.6.0
>      >     Â Â Â Â  location    :
>      >     /usr/lib/python3.4/sqlite3/__init__.py
>      >
>      >
>      >     Can someone throw light on what's wrong? What
>     do I need
>      >     to do?
>      >
>      >     Doug
>      >
>      >
>      >
>      >
>      >
>      >     _______________________________________________
>      >     Gramps-devel mailing list
>      >     [hidden email]
>     <mailto:[hidden email]>
>      >     <mailto:[hidden email]
>     <mailto:[hidden email]>>
>      >    Â
>     https://lists.sourceforge.net/lists/listinfo/gramps-devel <https://lists.sourceforge.net/lists/listinfo/gramps-devel>
>      >
>      >
>
>
>
>     _______________________________________________
>     Gramps-devel mailing list
>     [hidden email]
>     <mailto:[hidden email]>
>     https://lists.sourceforge.net/lists/listinfo/gramps-devel
>



_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: Network Chart Report - installation errors in gramps 5.0.0

Doug-11
In that case maybe it has to do with different Linux versions.
4.2.6 is on LMDE2; I installed LMDE3 on another PC and put
the clean 5.0 on that.
I'll press on; if anything new comes out of it I'll post it.

Doug

On 21/09/18 21:20, Dave Khuon wrote:

> 4.2.6 for about a year (?), Then 5.0.0 when it became
> available in August (?).  I am bad at the dates.
>
> On Fri, Sep 21, 2018, 11:40 AM Doug
> <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Hmm. I've been running 4.2.6 for several years, but added
>     5.0 quite recently. I suspect 4.2.6 might have set
>     things up
>     with some dependencies that are out of date for 5.0 (but I
>     haven't got to the bottom of the prequisites checker
>     list yet).
>
>     Which way round did you install 4.2.6 and 5.0? 5.0, then
>     4.2.6 or like me?
>
>     Doug
>
>     On 21/09/18 15:28, Dave Khuon wrote:
>      > Me too, I have both 4.2.6 and 5.0 installed.  I
>     never used
>      > the network chart before. Â
>      >
>      > Upon receiving your email yesterday, I clicked to
>     install
>      > everything found by the plugins manager (new updates,
>     new
>      > available plugins), then I ran the network chart.ÂÂ
>     It went
>      > fine for me.  My platform is Win 10, and I am
>     using the AIO
>      > installation.
>      >
>      > Hope this would help.
>      >
>      > On Fri, Sep 21, 2018, 5:19 AM Doug
>      > <[hidden email]
>     <mailto:[hidden email]>
>      > <mailto:[hidden email]
>     <mailto:[hidden email]>>> wrote:
>      >
>      >     Thanks, Paul and Sam.
>      >
>      >     The Prerequisites Checker gramplet is a godsend!
>      >     I've been able to install Network Chart and
>     get it running
>      >     fine on a clean 5.0 installation.
>      >
>      >     My original problem was on a different
>     computer running 4.2
>      >     on which I also installed 5.0. Although the
>     two gramps
>      >     versions seem to co-exist happily, I haven't
>     yet got to the
>      >     bottom of the 5.0 prerequisites, so I don't
>     know for sure
>      >     whether the Network Chart error is due to the
>     prerequisites
>      >     or to some version incompatibility.
>      >
>      >     Doug
>      >
>      >
>      >     On 21/09/18 02:45, Sam Manzi wrote:
>      >      > Does any of the advice from the third party
>     addons
>      >     support
>      >      > page Troubleshooting section help?
>      >      >
>      >      >
>      >    Â
>     https://gramps-project.org/wiki/index.php?title=NetworkChart#Prerequisites
>      >      >
>      >      > On 18 September 2018 at 22:29, Doug
>      >      > <[hidden email]
>     <mailto:[hidden email]>
>      >     <mailto:[hidden email]
>     <mailto:[hidden email]>>
>      >      > <mailto:[hidden email]
>     <mailto:[hidden email]>
>      >     <mailto:[hidden email]
>     <mailto:[hidden email]>>>> wrote:
>      >      >
>      >      >     When I try installing the new
>     Network Chart
>      >     Report I get
>      >      >     the following error message:
>      >      >
>      >      >     "Installation Errors - The
>     following addons had
>      >      >     errors.  Network Chart
>     (0.0.12)"
>      >      >
>      >      >     I'm running LMDE2 with
>     python3-networkx 1.9,
>      >     graphviz
>      >      >     2.38.0-7 and graphviz-dev,
>     python-pygraphviz 1.3,
>      >      >     python3-pygraph 1.8.
>      >      >     My gramps settings are:
>      >      >     ----------------
>      >      >  ÂÂ
>      Â python    : 3.4.2
>      >      >  ÂÂ
>      Â gramps    : 5.0.0
>      >      >  ÂÂ
>      Â gtk++     :
>     3.14.5
>      >      >     Â pygobject : 3.14.0
>      >      >  ÂÂ
>      Â pango     :
>     1.36.8
>      >      >  ÂÂ
>      Â cairo     :
>     1.14.0
>      >      >  ÂÂ
>      Â pycairo   : 1.10.0
>      >      >     Â osmgpsmap : 1.0
>      >      >  ÂÂ
>      Â GExiv2    : 0.10
>      >      >  ÂÂ
>      Â ICU     ÂÂÂ
>     : 52.1
>      >      >  ÂÂ
>      Â PyICU     : 1.8
>      >      >  ÂÂ
>      Â o.s.    ÂÂÂ
>     : linux
>      >      >  ÂÂ
>      Â kernel    :
>     3.16.0-6-amd64
>      >      >
>      >      >     Environment settings:
>      >      >     ---------------------
>      >      >  ÂÂ
>      Â LANG    ÂÂÂ
>     : en_GB.UTF-8
>      >      >     Â LANGUAGE  : en_GB
>      >      >     Â GRAMPSI18N: not set
>      >      >     Â GRAMPSHOME: not set
>      >      >     Â GRAMPSDIR : not set
>      >      >     Â PYTHONPATH:
>      >      >     Â Â ÂÂÂ
>     /usr/lib/python3/dist-packages/gramps
>      >      >     Â Â ÂÂÂ
>     /usr/bin
>      >      >     Â Â ÂÂÂ
>     /usr/lib/python3.4
>      >      >     Â Â ÂÂ
>      >     /usr/lib/python3.4/plat-x86_64-linux-gnu
>      >      >     Â Â ÂÂÂ
>     /usr/lib/python3.4/lib-dynload
>      >      >     Â Â ÂÂ
>      >     /usr/local/lib/python3.4/dist-packages
>      >      >     Â Â ÂÂÂ
>     /usr/lib/python3/dist-packages
>      >      >
>      >      >     Non-python dependencies:
>      >      >     ------------------------
>      >      >     Â Graphviz  : 2.38
>      >      >     Â Ghostscr. : 9.06
>      >      >
>      >      >     System PATH env variable:
>      >      >     -------------------------
>      >      >  ÂÂ
>      Â Â Â Â  /usr/local/bin
>      >      >  ÂÂ
>      Â Â Â Â  /usr/bin
>      >      >  ÂÂ
>      Â Â Â Â  /bin
>      >      >  ÂÂ
>      Â Â Â Â  /usr/local/games
>      >      >  ÂÂ
>      Â Â Â Â  /usr/games
>      >      >  ÂÂ
>      Â Â Â Â  /usr/local/sbin
>      >      >  ÂÂ
>      Â Â Â Â  /usr/sbin
>      >      >  ÂÂ
>      Â Â Â Â  /sbin
>      >      >  ÂÂ
>      Â Â Â Â  /usr/local/sbin
>      >      >  ÂÂ
>      Â Â Â Â  /usr/sbin
>      >      >  ÂÂ
>      Â Â Â Â  /sbin
>      >      >
>      >      >     Databases:
>      >      >     -------------------------
>      >      >  ÂÂ
>      Â bsddb     :
>      >      >  ÂÂ
>      Â Â Â ÂÂÂ
>     version     : 6.1.0
>      >      >  ÂÂ
>      Â Â Â Â  db
>     version  : 5.3.28
>      >      >  ÂÂ
>      Â Â Â ÂÂÂ
>     location    :
>      >      >  ÂÂ
>      /usr/lib/python3/dist-packages/bsddb3/__init__.py
>      >      >  ÂÂ
>      Â sqlite3   :
>      >      >  ÂÂ
>      Â Â Â ÂÂÂ
>     version     : 3.8.7.1
>      >      >  ÂÂ
>      Â Â Â Â  py
>     version  : 2.6.0
>      >      >  ÂÂ
>      Â Â Â ÂÂÂ
>     location    :
>      >      >  ÂÂ
>      /usr/lib/python3.4/sqlite3/__init__.py
>      >      >
>      >      >
>      >      >     Can someone throw light on
>     what's wrong? What
>      >     do I need
>      >      >     to do?
>      >      >
>      >      >     Doug
>      >      >
>      >      >
>      >      >
>      >      >
>      >      >
>      >      >  ÂÂ
>      _______________________________________________
>      >      >     Gramps-devel mailing list
>      >      >    Â
>     [hidden email]
>     <mailto:[hidden email]>
>      >     <mailto:[hidden email]
>     <mailto:[hidden email]>>
>      >      >  ÂÂ
>      <mailto:[hidden email]
>     <mailto:[hidden email]>
>      >     <mailto:[hidden email]
>     <mailto:[hidden email]>>>
>      >      >    Â
>      >    Â
>     https://lists.sourceforge.net/lists/listinfo/gramps-devel <https://lists.sourceforge.net/lists/listinfo/gramps-devel>
>      >      >
>      >      >
>      >
>      >
>      >
>      >     _______________________________________________
>      >     Gramps-devel mailing list
>      >     [hidden email]
>     <mailto:[hidden email]>
>      >     <mailto:[hidden email]
>     <mailto:[hidden email]>>
>      >    Â
>     https://lists.sourceforge.net/lists/listinfo/gramps-devel
>      >
>



_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel