Postgresql

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Postgresql

John Allen

i am trying to setup Gramps 5 to use PostgreSQL 9.6.

I can connect to the my db server but the postgresql fails as the db is either not known or not defined.

1)  is it possible to use a hostssl connection. What I want to do is securely connect to the db server.

2) where can i find the info on the postgresql setup needed.





------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
https://gramps-project.org
Reply | Threaded
Open this post in threaded view
|

Re: Postgresql

John Allen

I can get the connection working, but cannot find any info on the PostgreSQL setup. The connection fails with unknown DB, or if I create an empty I get a messages about missing stuff ...

I want to use SQL dbs so that I can use Gramps from any of my systems.

JohnA


On 2017-05-01 10:05 PM, Sam Manzi wrote:

Hello john,

Gramps 5 has not been released yet. As for using Gramps master(eg: the future Gramps 5) with postgresql I can only direct you to the following page:

https://gramps-project.org/wiki/index.php?title=DB-API_Database_Backend

Note that the information provided may not work any longer as I seem to recall one of the developers mentioning that only sqlite3 will be initially supported.

Kind regards
Sam



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
https://gramps-project.org