Problem on trying to start GRAMPS

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem on trying to start GRAMPS

jerome
I suppose we cannot propose a package name based on a lang variable
during the installation and check of the .deb file?

Also, gramps can run from CLI, this is GUI stuff and should not block run.

Currently, we need at least:

Package: python3-gramps
Depends:
 gir1.2-gtk-3.0 (>= 3.10.0),
 librsvg2-2,
 python3-gi,
 python3-gi-cairo,
 python3-bsddb3,
 xdg-utils,
 ${misc:Depends},
 ${python3:Depends}

https://github.com/gramps-project/gramps/blob/master/debian/control

"librsvg2-2" and "xdg-utils" are GUI stuff too,
but they are common, whatever locale set.


Jérôme



--------------------------------------------
En date de : Mer 4.5.16, Peter Hewett <[hidden email]> a écrit :

 Objet: Re: [Gramps-users] Problem on trying to start GRAMPS
 À: [hidden email]
 Date: Mercredi 4 mai 2016, 1h20
 
 
 ------------------------
 From:
 Bret Busby <[hidden email]>
 Date: Tue, 3 May 2016 22:23:06 +0800
 To: [hidden email]
 Subject: [Gramps-users] Problem on trying to
 start GRAMPS
 
 > On trying
 to start GRAMPS, I get the following.
 >   Gramps detected an incomplete
 GTK installation
 
 
 I have had similar error messages on Kubuntu
 15.10 and 16.04. It happens
 with the default
 version of Gramps 4.2.2 and with the Sourceforge
 version 4.2.3. Installing this package (below)
 makes the error messages
 go away on my
 PC;
  language-pack-gnome-en
 
 
 HTH
 
 Peter
 
 ------------------------------------------------------------------------------
 Find and fix application performance issues
 faster with Applications Manager
 Applications Manager provides deep performance
 insights into multiple tiers of
 your
 business applications. It resolves application problems
 quickly and
 reduces your MTTR. Get your free
 trial!
 https://ad.doubleclick.net/ddm/clk/302982198;130105516;z
 _______________________________________________
 Gramps-users mailing list
 [hidden email]
 https://lists.sourceforge.net/lists/listinfo/gramps-users

------------------------------------------------------------------------------
Find and fix application performance issues faster with Applications Manager
Applications Manager provides deep performance insights into multiple tiers of
your business applications. It resolves application problems quickly and
reduces your MTTR. Get your free trial!
https://ad.doubleclick.net/ddm/clk/302982198;130105516;z
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem on trying to start GRAMPS

Ross Gammon
I had forgotten that the README (or INSTALL) file recommends installing
the gtk language pack for your language.

Defaulting to the English-English locale will help (as we know we have
translations), but I wonder if it will help more (especially for other
languages) to tweak the message to additionally say "This may be because
the gtk language pack for your language is not installed - see
/usr/.../README etc. for further information".

On 05/04/2016 07:12 AM, jerome wrote:
> I suppose we cannot propose a package name based on a lang variable
> during the installation and check of the .deb file?

It is probably possible to dynamically select a package at build time
based on $LANG. But this is not helpful because then everybody would get
the locale of the build server. Doing it in a post-install script (as
you suggest) is theoretically possible, but complex. And the users can
change their locale at any time.

The best thing is to follow the advice in the README and install the
language pack for your language.

Cheers,

Ross


------------------------------------------------------------------------------
Find and fix application performance issues faster with Applications Manager
Applications Manager provides deep performance insights into multiple tiers of
your business applications. It resolves application problems quickly and
reduces your MTTR. Get your free trial!
https://ad.doubleclick.net/ddm/clk/302982198;130105516;z
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users

signature.asc (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Problem on trying to start GRAMPS

Peter Hewett-2

------------------------
From: Ross Gammon <[hidden email]>
Date: Wed, 4 May 2016 20:41:43 +0200
To: [hidden email]
Subject: Re: [Gramps-users] Problem on trying to start GRAMPS

> I had forgotten that the README (or INSTALL) file recommends installing
> the gtk language pack for your language.

Oh. My bad. I didn't look in the readme.

Best solution would be if the install process could automagically
install the correct language pack for the user's language setting, but
maybe that is not feasible.

It would be very helpful if the error message could provide a hint on
how to fix it. Such as to install language-pack-gnome-xx or to look at
the readme file.

It would also be helpful for the wiki page to have a note on this.
https://gramps-project.org/wiki/index.php?title=Download
(I'd update the wiki, but that page is protected.)

cheers

Peter


 

------------------------------------------------------------------------------
Find and fix application performance issues faster with Applications Manager
Applications Manager provides deep performance insights into multiple tiers of
your business applications. It resolves application problems quickly and
reduces your MTTR. Get your free trial!
https://ad.doubleclick.net/ddm/clk/302982198;130105516;z
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users