Python upgrade from 2 to 3 fails

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Python upgrade from 2 to 3 fails

Sebastian Schubert
Hi,

you want to have bug reports for the upcoming 4.2, right? Since there is
no version 4.2 in the bug tracker, I'll post my error here.

When upgrading from a python2 4.1.3 database to the python3 4.2 database
using git version ba8392923a0aaf82a76727bd1964f280363f9f58 from Mon Jun
1 13:02:55 2015 -0400, I get the following errors (the first part is
probably not interesting, I post them just to be sure):

##############################################################
$ python3 Gramps.py
.gramps.gen.utils.grampslocale.WARNING: ICU not loaded because No module
named 'PyICU'. Localization will be impaired. Use your package manager
to install PyICU
2015-06-02 13:22:03.582: WARNING: grampsgui.py: line 170: GTK
translations missing, GUI will be broken, especially for RTL languages!
Gtk-Message: GtkDialog mapped without a transient parent. This is
discouraged.
2015-06-02 13:22:50.403: WARNING: write.py: line 653: Python upgrade
requested from 2 to 3
2015-06-02 13:22:50.480: WARNING: write.py: line 547: If upgrade and
loading the Family Tree works, you can delete the zip file at XXXXXXXX
2015-06-02 13:22:59.060: ERROR: dbloader.py: line 104: 'ascii' codec
can't decode byte 0xc3 in position 0: ordinal not in range(128)
Traceback (most recent call last):
  File "/home/schubert/repositories/gramps/gramps/gui/dbloader.py", line
325, in read_file
    force_python_upgrade)
  File "/home/schubert/repositories/gramps/gramps/gen/db/write.py", line
399, in try_
    return func(self, *args, **kwargs)
  File "/home/schubert/repositories/gramps/gramps/gen/db/write.py", line
873, in load
    self.__load_metadata()
  File "/home/schubert/repositories/gramps/gramps/gen/db/write.py", line
980, in __load_metadata
    self.note_types = set(meta(b'note_types'))
  File "/home/schubert/repositories/gramps/gramps/gen/db/write.py", line
956, in meta
    return self.metadata.get(key, default=[])
  File "/usr/lib64/python3.4/site-packages/bsddb3/dbshelve.py", line
250, in get
    return pickle.loads(data)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 0:
ordinal not in range(128)
##############################################################

(Backup file name substituted with XXXXXXXX)

My system is openSUSE 13.2 with

python 2.7.8  and  python-bsddb3 6.1.0
python 3.4.1  and  python3-bsddb3 5.3.0

Do you need more information?

Cheers
Sebastian

------------------------------------------------------------------------------
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re : Python upgrade from 2 to 3 fails

jerome
Hi,


There is a 4.2.0 (and 4.2.1) item into bug tracker!


--------------------------------------------
En date de : Mar 2.6.15, Sebastian Schubert <[hidden email]> a écrit :

 Objet: [Gramps-devel] Python upgrade from 2 to 3 fails
 À: "[hidden email]" <[hidden email]>
 Date: Mardi 2 juin 2015, 11h35
 
 Hi,
 
 you want to have bug reports for the upcoming 4.2, right?
 Since there is
 no version 4.2 in the bug tracker, I'll post my error here.
 
 When upgrading from a python2 4.1.3 database to the python3
 4.2 database
 using git version ba8392923a0aaf82a76727bd1964f280363f9f58
 from Mon Jun
 1 13:02:55 2015 -0400, I get the following errors (the first
 part is
 probably not interesting, I post them just to be sure):
 
 ##############################################################
 $ python3 Gramps.py
 .gramps.gen.utils.grampslocale.WARNING: ICU not loaded
 because No module
 named 'PyICU'. Localization will be impaired. Use your
 package manager
 to install PyICU
 2015-06-02 13:22:03.582: WARNING: grampsgui.py: line 170:
 GTK
 translations missing, GUI will be broken, especially for RTL
 languages!
 Gtk-Message: GtkDialog mapped without a transient parent.
 This is
 discouraged.
 2015-06-02 13:22:50.403: WARNING: write.py: line 653: Python
 upgrade
 requested from 2 to 3
 2015-06-02 13:22:50.480: WARNING: write.py: line 547: If
 upgrade and
 loading the Family Tree works, you can delete the zip file
 at XXXXXXXX
 2015-06-02 13:22:59.060: ERROR: dbloader.py: line 104:
 'ascii' codec
 can't decode byte 0xc3 in position 0: ordinal not in
 range(128)
 Traceback (most recent call last):
   File
 "/home/schubert/repositories/gramps/gramps/gui/dbloader.py",
 line
 325, in read_file
     force_python_upgrade)
   File
 "/home/schubert/repositories/gramps/gramps/gen/db/write.py",
 line
 399, in try_
     return func(self, *args, **kwargs)
   File
 "/home/schubert/repositories/gramps/gramps/gen/db/write.py",
 line
 873, in load
     self.__load_metadata()
   File
 "/home/schubert/repositories/gramps/gramps/gen/db/write.py",
 line
 980, in __load_metadata
     self.note_types = set(meta(b'note_types'))
   File
 "/home/schubert/repositories/gramps/gramps/gen/db/write.py",
 line
 956, in meta
     return self.metadata.get(key, default=[])
   File
 "/usr/lib64/python3.4/site-packages/bsddb3/dbshelve.py",
 line
 250, in get
     return pickle.loads(data)
 UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in
 position 0:
 ordinal not in range(128)
 ##############################################################
 
 (Backup file name substituted with XXXXXXXX)
 
 My system is openSUSE 13.2 with
 
 python 2.7.8  and  python-bsddb3 6.1.0
 python 3.4.1  and  python3-bsddb3 5.3.0
 
 Do you need more information?
 
 Cheers
 Sebastian
 
 ------------------------------------------------------------------------------
 _______________________________________________
 Gramps-devel mailing list
 [hidden email]
 https://lists.sourceforge.net/lists/listinfo/gramps-devel
 

------------------------------------------------------------------------------
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: Python upgrade from 2 to 3 fails

enno
In reply to this post by Sebastian Schubert
Hallo Sebastian,

> When upgrading from a python2 4.1.3 database to the python3 4.2 database
> using git version ba8392923a0aaf82a76727bd1964f280363f9f58 from Mon Jun
> 1 13:02:55 2015 -0400, I get the following errors (the first part is
> probably not interesting, I post them just to be sure):
>
> ##############################################################
> $ python3 Gramps.py
> .gramps.gen.utils.grampslocale.WARNING: ICU not loaded because No module
> named 'PyICU'. Localization will be impaired. Use your package manager
> to install PyICU
> 2015-06-02 13:22:03.582: WARNING: grampsgui.py: line 170: GTK
> translations missing, GUI will be broken, especially for RTL languages!
> Gtk-Message: GtkDialog mapped without a transient parent. This is
> discouraged.
> 2015-06-02 13:22:50.403: WARNING: write.py: line 653: Python upgrade
> requested from 2 to 3
> 2015-06-02 13:22:50.480: WARNING: write.py: line 547: If upgrade and
> loading the Family Tree works, you can delete the zip file at XXXXXXXX
> 2015-06-02 13:22:59.060: ERROR: dbloader.py: line 104: 'ascii' codec
> can't decode byte 0xc3 in position 0: ordinal not in range(128)
> Traceback (most recent call last):
>    File "/home/schubert/repositories/gramps/gramps/gui/dbloader.py", line
> 325, in read_file
>      force_python_upgrade)
>    File "/home/schubert/repositories/gramps/gramps/gen/db/write.py", line
> 399, in try_
>      return func(self, *args, **kwargs)
>    File "/home/schubert/repositories/gramps/gramps/gen/db/write.py", line
> 873, in load
>      self.__load_metadata()
>    File "/home/schubert/repositories/gramps/gramps/gen/db/write.py", line
> 980, in __load_metadata
>      self.note_types = set(meta(b'note_types'))
>    File "/home/schubert/repositories/gramps/gramps/gen/db/write.py", line
> 956, in meta
>      return self.metadata.get(key, default=[])
>    File "/usr/lib64/python3.4/site-packages/bsddb3/dbshelve.py", line
> 250, in get
>      return pickle.loads(data)
> UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 0:
> ordinal not in range(128)
> ##############################################################
I've seen similar things with earlier versions of master (before the
gramps42 branch), but the upgrade works fine here, on my 4.1 database,
so the cause must be specific to yours.

To me the error suggests that you may have a German character in your
source types. Can that be the case? I have some accented characters in
person names, and they all convert OK.

If you can send your backup file to my email address, I can check
whether I get the same error here. My Python and BSDDB are almost the
same as yours, so I doubt whether they are causing this.

regards,

Enno

Gramps Settings:
----------------
  python    : 3.4.0
  gramps    : 4.2.0-1
  gtk++     : 3.10.8
  pygobject : 3.12.0
  pango     : 1.36.3
  bsddb     : 6.0.1
  bsddb.db  : 5.3.28
  cairo     : 1.13.1
  pycairo   : 1.10.0
  osmgpsmap : not found
  GExiv2    : not found
  ICU       : 52.1
  PyICU     : 1.5
  o.s.      : linux
  kernel    : 3.13.0-37-generic

Environment settings:
---------------------
  LANG      : nl_NL.UTF-8
  LANGUAGE  : nl
  GRAMPSI18N: not set
  GRAMPSHOME: not set
  GRAMPSDIR : not set
  PYTHONPATH:
     /home/enno/gramps-enno/gramps
     /home/enno/gramps-enno
     /usr/lib/python3.4
     /usr/lib/python3.4/plat-x86_64-linux-gnu
     /usr/lib/python3.4/lib-dynload
     /usr/local/lib/python3.4/dist-packages
     /usr/lib/python3/dist-packages




------------------------------------------------------------------------------
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: Python upgrade from 2 to 3 fails

Sebastian Schubert
In reply to this post by jerome
Hi devs,

I submitted the bug to

https://gramps-project.org/bugs/view.php?id=8614

Enno was able to confirm it.

(Maybe I am stupid but I DID NOT FIND a version 4.2.0 or 4.2.1)

Cheers
Sebastian

On 02/06/15 14:29, jerome wrote:

> Hi,
>
>
> There is a 4.2.0 (and 4.2.1) item into bug tracker!
>
>
> --------------------------------------------
> En date de : Mar 2.6.15, Sebastian Schubert <[hidden email]> a écrit :
>
>  Objet: [Gramps-devel] Python upgrade from 2 to 3 fails
>  À: "[hidden email]" <[hidden email]>
>  Date: Mardi 2 juin 2015, 11h35
>  
>  Hi,
>  
>  you want to have bug reports for the upcoming 4.2, right?
>  Since there is
>  no version 4.2 in the bug tracker, I'll post my error here.
>  
>  When upgrading from a python2 4.1.3 database to the python3
>  4.2 database
>  using git version ba8392923a0aaf82a76727bd1964f280363f9f58
>  from Mon Jun
>  1 13:02:55 2015 -0400, I get the following errors (the first
>  part is
>  probably not interesting, I post them just to be sure):
>  
>  ##############################################################
>  $ python3 Gramps.py
>  .gramps.gen.utils.grampslocale.WARNING: ICU not loaded
>  because No module
>  named 'PyICU'. Localization will be impaired. Use your
>  package manager
>  to install PyICU
>  2015-06-02 13:22:03.582: WARNING: grampsgui.py: line 170:
>  GTK
>  translations missing, GUI will be broken, especially for RTL
>  languages!
>  Gtk-Message: GtkDialog mapped without a transient parent.
>  This is
>  discouraged.
>  2015-06-02 13:22:50.403: WARNING: write.py: line 653: Python
>  upgrade
>  requested from 2 to 3
>  2015-06-02 13:22:50.480: WARNING: write.py: line 547: If
>  upgrade and
>  loading the Family Tree works, you can delete the zip file
>  at XXXXXXXX
>  2015-06-02 13:22:59.060: ERROR: dbloader.py: line 104:
>  'ascii' codec
>  can't decode byte 0xc3 in position 0: ordinal not in
>  range(128)
>  Traceback (most recent call last):
>    File
>  "/home/schubert/repositories/gramps/gramps/gui/dbloader.py",
>  line
>  325, in read_file
>      force_python_upgrade)
>    File
>  "/home/schubert/repositories/gramps/gramps/gen/db/write.py",
>  line
>  399, in try_
>      return func(self, *args, **kwargs)
>    File
>  "/home/schubert/repositories/gramps/gramps/gen/db/write.py",
>  line
>  873, in load
>      self.__load_metadata()
>    File
>  "/home/schubert/repositories/gramps/gramps/gen/db/write.py",
>  line
>  980, in __load_metadata
>      self.note_types = set(meta(b'note_types'))
>    File
>  "/home/schubert/repositories/gramps/gramps/gen/db/write.py",
>  line
>  956, in meta
>      return self.metadata.get(key, default=[])
>    File
>  "/usr/lib64/python3.4/site-packages/bsddb3/dbshelve.py",
>  line
>  250, in get
>      return pickle.loads(data)
>  UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in
>  position 0:
>  ordinal not in range(128)
>  ##############################################################
>  
>  (Backup file name substituted with XXXXXXXX)
>  
>  My system is openSUSE 13.2 with
>  
>  python 2.7.8  and  python-bsddb3 6.1.0
>  python 3.4.1  and  python3-bsddb3 5.3.0
>  
>  Do you need more information?
>  
>  Cheers
>  Sebastian
>  
>  ------------------------------------------------------------------------------
>  _______________________________________________
>  Gramps-devel mailing list
>  [hidden email]
>  https://lists.sourceforge.net/lists/listinfo/gramps-devel
>  
>

------------------------------------------------------------------------------
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: Python upgrade from 2 to 3 fails

jerome
Maybe they were not visible, but they have been added for the roadmap[1].

[1] https://gramps-project.org/bugs/roadmap_page.php


--------------------------------------------
En date de : Mer 3.6.15, Sebastian Schubert <[hidden email]> a écrit :

 Objet: Re: [Gramps-devel] Python upgrade from 2 to 3 fails
 À: "jerome" <[hidden email]>, "[hidden email]" <[hidden email]>
 Date: Mercredi 3 juin 2015, 10h05
 
 Hi devs,
 
 I submitted the bug to
 
 https://gramps-project.org/bugs/view.php?id=8614
 
 Enno was able to confirm
 it.
 
 (Maybe I am stupid but
 I DID NOT FIND a version 4.2.0 or 4.2.1)
 
 Cheers
 Sebastian
 
 On 02/06/15 14:29, jerome wrote:
 > Hi,
 >
 >
 > There is a 4.2.0
 (and 4.2.1) item into bug tracker!
 >
 >
 >
 --------------------------------------------
 > En date de : Mar 2.6.15, Sebastian
 Schubert <[hidden email]>
 a écrit :
 >
 > 
 Objet: [Gramps-devel] Python upgrade from 2 to 3 fails
 >  À: "[hidden email]"
 <[hidden email]>
 >  Date: Mardi 2 juin 2015, 11h35
 > 
 >  Hi,
 > 
 >  you want to have
 bug reports for the upcoming 4.2, right?
 >  Since there is
 >  no
 version 4.2 in the bug tracker, I'll post my error
 here.
 > 
 >  When
 upgrading from a python2 4.1.3 database to the python3
 >  4.2 database
 > 
 using git version
 ba8392923a0aaf82a76727bd1964f280363f9f58
 >  from Mon Jun
 >  1
 13:02:55 2015 -0400, I get the following errors (the
 first
 >  part is
 > 
 probably not interesting, I post them just to be sure):
 > 
 > 
 ##############################################################
 >  $ python3 Gramps.py
 >  .gramps.gen.utils.grampslocale.WARNING:
 ICU not loaded
 >  because No module
 >  named 'PyICU'. Localization will
 be impaired. Use your
 >  package
 manager
 >  to install PyICU
 >  2015-06-02 13:22:03.582: WARNING:
 grampsgui.py: line 170:
 >  GTK
 >  translations missing, GUI will be
 broken, especially for RTL
 > 
 languages!
 >  Gtk-Message: GtkDialog
 mapped without a transient parent.
 > 
 This is
 >  discouraged.
 >  2015-06-02 13:22:50.403: WARNING:
 write.py: line 653: Python
 >  upgrade
 >  requested from 2 to 3
 >  2015-06-02 13:22:50.480: WARNING:
 write.py: line 547: If
 >  upgrade and
 >  loading the Family Tree works, you can
 delete the zip file
 >  at XXXXXXXX
 >  2015-06-02 13:22:59.060: ERROR:
 dbloader.py: line 104:
 > 
 'ascii' codec
 >  can't
 decode byte 0xc3 in position 0: ordinal not in
 >  range(128)
 > 
 Traceback (most recent call last):
 >   
 File
 > 
 "/home/schubert/repositories/gramps/gramps/gui/dbloader.py",
 >  line
 >  325, in
 read_file
 >     
 force_python_upgrade)
 >    File
 > 
 "/home/schubert/repositories/gramps/gramps/gen/db/write.py",
 >  line
 >  399, in
 try_
 >      return func(self, *args,
 **kwargs)
 >    File
 > 
 "/home/schubert/repositories/gramps/gramps/gen/db/write.py",
 >  line
 >  873, in
 load
 >      self.__load_metadata()
 >    File
 > 
 "/home/schubert/repositories/gramps/gramps/gen/db/write.py",
 >  line
 >  980, in
 __load_metadata
 >      self.note_types
 = set(meta(b'note_types'))
 >   
 File
 > 
 "/home/schubert/repositories/gramps/gramps/gen/db/write.py",
 >  line
 >  956, in
 meta
 >      return
 self.metadata.get(key, default=[])
 >   
 File
 > 
 "/usr/lib64/python3.4/site-packages/bsddb3/dbshelve.py",
 >  line
 >  250, in
 get
 >      return
 pickle.loads(data)
 > 
 UnicodeDecodeError: 'ascii' codec can't decode
 byte 0xc3 in
 >  position 0:
 >  ordinal not in range(128)
 > 
 ##############################################################
 > 
 >  (Backup file
 name substituted with XXXXXXXX)
 > 
 >  My system is openSUSE 13.2 with
 > 
 >  python 2.7.8 
 and  python-bsddb3 6.1.0
 >  python
 3.4.1  and  python3-bsddb3 5.3.0
 > 
 
 >  Do you need more information?
 > 
 >  Cheers
 >  Sebastian
 > 
 > 
 ------------------------------------------------------------------------------
 > 
 _______________________________________________
 >  Gramps-devel mailing list
 >  [hidden email]
 >  https://lists.sourceforge.net/lists/listinfo/gramps-devel
 > 
 >
 

------------------------------------------------------------------------------
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: Python upgrade from 2 to 3 fails

jerome
In reply to this post by Sebastian Schubert
Maybe not visible, but they were added for the roadmap(s)[1].

I did not look if they are available on the list when we create
a bug report.

[1] https://gramps-project.org/bugs/roadmap_page.php


--------------------------------------------
En date de : Mer 3.6.15, Sebastian Schubert <[hidden email]> a écrit :

 Objet: Re: [Gramps-devel] Python upgrade from 2 to 3 fails
 À: "jerome" <[hidden email]>, "[hidden email]" <[hidden email]>
 Date: Mercredi 3 juin 2015, 10h05
 
 Hi devs,
 
 I submitted the bug to
 
 https://gramps-project.org/bugs/view.php?id=8614
 
 Enno was able to confirm
 it.
 
 (Maybe I am stupid but
 I DID NOT FIND a version 4.2.0 or 4.2.1)
 
 Cheers
 Sebastian
 
 On 02/06/15 14:29, jerome wrote:
 > Hi,
 >
 >
 > There is a 4.2.0
 (and 4.2.1) item into bug tracker!
 >
 >
 >
 --------------------------------------------
 > En date de : Mar 2.6.15, Sebastian
 Schubert <[hidden email]>
 a écrit :
 >
 > 
 Objet: [Gramps-devel] Python upgrade from 2 to 3 fails
 >  À: "[hidden email]"
 <[hidden email]>
 >  Date: Mardi 2 juin 2015, 11h35
 > 
 >  Hi,
 > 
 >  you want to have
 bug reports for the upcoming 4.2, right?
 >  Since there is
 >  no
 version 4.2 in the bug tracker, I'll post my error
 here.
 > 
 >  When
 upgrading from a python2 4.1.3 database to the python3
 >  4.2 database
 > 
 using git version
 ba8392923a0aaf82a76727bd1964f280363f9f58
 >  from Mon Jun
 >  1
 13:02:55 2015 -0400, I get the following errors (the
 first
 >  part is
 > 
 probably not interesting, I post them just to be sure):
 > 
 > 
 ##############################################################
 >  $ python3 Gramps.py
 >  .gramps.gen.utils.grampslocale.WARNING:
 ICU not loaded
 >  because No module
 >  named 'PyICU'. Localization will
 be impaired. Use your
 >  package
 manager
 >  to install PyICU
 >  2015-06-02 13:22:03.582: WARNING:
 grampsgui.py: line 170:
 >  GTK
 >  translations missing, GUI will be
 broken, especially for RTL
 > 
 languages!
 >  Gtk-Message: GtkDialog
 mapped without a transient parent.
 > 
 This is
 >  discouraged.
 >  2015-06-02 13:22:50.403: WARNING:
 write.py: line 653: Python
 >  upgrade
 >  requested from 2 to 3
 >  2015-06-02 13:22:50.480: WARNING:
 write.py: line 547: If
 >  upgrade and
 >  loading the Family Tree works, you can
 delete the zip file
 >  at XXXXXXXX
 >  2015-06-02 13:22:59.060: ERROR:
 dbloader.py: line 104:
 > 
 'ascii' codec
 >  can't
 decode byte 0xc3 in position 0: ordinal not in
 >  range(128)
 > 
 Traceback (most recent call last):
 >   
 File
 > 
 "/home/schubert/repositories/gramps/gramps/gui/dbloader.py",
 >  line
 >  325, in
 read_file
 >     
 force_python_upgrade)
 >    File
 > 
 "/home/schubert/repositories/gramps/gramps/gen/db/write.py",
 >  line
 >  399, in
 try_
 >      return func(self, *args,
 **kwargs)
 >    File
 > 
 "/home/schubert/repositories/gramps/gramps/gen/db/write.py",
 >  line
 >  873, in
 load
 >      self.__load_metadata()
 >    File
 > 
 "/home/schubert/repositories/gramps/gramps/gen/db/write.py",
 >  line
 >  980, in
 __load_metadata
 >      self.note_types
 = set(meta(b'note_types'))
 >   
 File
 > 
 "/home/schubert/repositories/gramps/gramps/gen/db/write.py",
 >  line
 >  956, in
 meta
 >      return
 self.metadata.get(key, default=[])
 >   
 File
 > 
 "/usr/lib64/python3.4/site-packages/bsddb3/dbshelve.py",
 >  line
 >  250, in
 get
 >      return
 pickle.loads(data)
 > 
 UnicodeDecodeError: 'ascii' codec can't decode
 byte 0xc3 in
 >  position 0:
 >  ordinal not in range(128)
 > 
 ##############################################################
 > 
 >  (Backup file
 name substituted with XXXXXXXX)
 > 
 >  My system is openSUSE 13.2 with
 > 
 >  python 2.7.8 
 and  python-bsddb3 6.1.0
 >  python
 3.4.1  and  python3-bsddb3 5.3.0
 > 
 
 >  Do you need more information?
 > 
 >  Cheers
 >  Sebastian
 > 
 > 
 ------------------------------------------------------------------------------
 > 
 _______________________________________________
 >  Gramps-devel mailing list
 >  [hidden email]
 >  https://lists.sourceforge.net/lists/listinfo/gramps-devel
 > 
 >
 

------------------------------------------------------------------------------
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: Python upgrade from 2 to 3 fails

enno
Jerome,
> Maybe not visible, but they were added for the roadmap(s)[1].
>
> I did not look if they are available on the list when we create
> a bug report.
>
> [1] https://gramps-project.org/bugs/roadmap_page.php
When I create a bug report, I can select 4.2.0 and 4.2.1, but I am a
developer on Mantis, and you are an admin, I think. Sebastian may not
see these, because I think that he wrote that he is a normal user.

Can you check? Maybe this is on purpose, because there is no 4.2 release
yet.

regards,

Enno


------------------------------------------------------------------------------
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel