Quantcast

Question about icu

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Question about icu

Peter Landgren
Hi,
I have installed icu from my Mageia repository, but when I start with
python3 Gramps.py I get
grampslocale.WARNING: ICU is not installed because No module named 'icu', localization will be
impaired

So something seems to be missing?

/Peter

------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_jan
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Question about icu

John Ralls-2

On Feb 3, 2013, at 7:40 AM, Peter Landgren <[hidden email]> wrote:

> Hi,
> I have installed icu from my Mageia repository, but when I start with
> python3 Gramps.py I get
> grampslocale.WARNING: ICU is not installed because No module named 'icu', localization will be
> impaired
>
> So something seems to be missing?

PyICU, perhaps?

Regards,
John Ralls


------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_jan
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Question about icu

Nick Hall-6
On 03/02/13 15:54, John Ralls wrote:

> On Feb 3, 2013, at 7:40 AM, Peter Landgren <[hidden email]> wrote:
>
>> Hi,
>> I have installed icu from my Mageia repository, but when I start with
>> python3 Gramps.py I get
>> grampslocale.WARNING: ICU is not installed because No module named 'icu', localization will be
>> impaired
>>
>> So something seems to be missing?
> PyICU, perhaps?

In Ubuntu they are:

python-pyicu
python3-pyicu

Nick.


>
> Regards,
> John Ralls
>
>
> ------------------------------------------------------------------------------
> Everyone hates slow websites. So do we.
> Make your web apps faster with AppDynamics
> Download AppDynamics Lite for free today:
> http://p.sf.net/sfu/appdyn_d2d_jan
> _______________________________________________
> Gramps-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gramps-devel
>
>


------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_jan
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Question about icu

Peter Landgren
Hi,

I have tried both John's and Nick's suggestions, but no luck so far.

Thanks
/Peter


> On 03/02/13 15:54, John Ralls wrote:
> > On Feb 3, 2013, at 7:40 AM, Peter Landgren <[hidden email]> wrote:
> >> Hi,
> >> I have installed icu from my Mageia repository, but when I start with
> >> python3 Gramps.py I get
> >> grampslocale.WARNING: ICU is not installed because No module named
> >> 'icu', localization will be impaired
> >>
> >> So something seems to be missing?
> >
> > PyICU, perhaps?
>
> In Ubuntu they are:
>
> python-pyicu
> python3-pyicu
>
> Nick.
>
> > Regards,
> > John Ralls
> >
> >
> > -------------------------------------------------------------------------
> > ----- Everyone hates slow websites. So do we.
> > Make your web apps faster with AppDynamics
> > Download AppDynamics Lite for free today:
> > http://p.sf.net/sfu/appdyn_d2d_jan
> > _______________________________________________
> > Gramps-devel mailing list
> > [hidden email]
> > https://lists.sourceforge.net/lists/listinfo/gramps-devel
>
> ---------------------------------------------------------------------------
> --- Everyone hates slow websites. So do we.
> Make your web apps faster with AppDynamics
> Download AppDynamics Lite for free today:
> http://p.sf.net/sfu/appdyn_d2d_jan
> _______________________________________________
> Gramps-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gramps-devel

------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_jan
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Question about icu

John Ralls-2

On Feb 3, 2013, at 9:35 AM, Peter Landgren <[hidden email]> wrote:

> Hi,
>
> I have tried both John's and Nick's suggestions, but no luck so far.

Meaning that your distro doesn't have PyICU, or that having installed it Gramps still can't find it?

Regards,
John Ralls


------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_jan
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Question about icu

Tim Lyons
Administrator
In reply to this post by Peter Landgren
I get the same problem. It seems they changed the name of the module from PyICU to icu: I have an outdated PyICU that only seems to support 'import PyICU'. Perhaps the version of PyICU that you get installed only supports the old name.

I think the new one supports both, so perhaps the import should be changed to PyICU. I changed it to that and now it works in my environment for LANG=en_GB.UTF-8.

To test, at the console, do:

python
import PyICU
PyICU.Collator.getAvailableLocales()

That should print out all the available locales.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Question about icu

John Ralls-2

On Feb 3, 2013, at 3:59 PM, Tim Lyons <[hidden email]> wrote:

> I get the same problem. It seems they changed the name of the module from
> PyICU to icu: I have an outdated PyICU that only seems to support 'import
> PyICU'. Perhaps the version of PyICU that you get installed only supports
> the old name.
>
> I think the new one supports both, so perhaps the import should be changed
> to PyICU. I changed it to that and now it works in my environment for
> LANG=en_GB.UTF-8.
>
> To test, at the console, do:
>
> python
> import PyICU
> PyICU.Collator.getAvailableLocales()
>
> That should print out all the available locales.

Ah, that's probably it.

I just committed r21287 which will try to import PyICU if icu fails.

Regards,
John Ralls


------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_jan
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Question about icu

Peter Landgren
In reply to this post by John Ralls-2
Den Sunday 03 February 2013 19.55.10 skrev John Ralls:

> On Feb 3, 2013, at 9:35 AM, Peter Landgren <[hidden email]> wrote:
> > Hi,
> >
> > I have tried both John's and Nick's suggestions, but no luck so far.
>
> Meaning that your distro doesn't have PyICU, or that having installed it
> Gramps still can't find it?
>
> Regards,
> John Ralls

The distro does not have it. I have made a request for it.

/Peter


------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_jan
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Loading...