Re: [Gramps-users] Postgresql

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: [Gramps-users] Postgresql

manzi.sam
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: [Gramps-users] Postgresql

manzi.sam
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: [Gramps-users] Postgresql

manzi.sam
In reply to this post by manzi.sam
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: [Gramps-users] Postgresql

jerome
In reply to this post by manzi.sam
Hi,

It seems that current code does not clearly explain why it could fail.
Maybe related to "psycopg2" dependency?

> failed to import module 'gramps.plugins.db.dbapi.postgresql';
the following exception was raised:
Traceback (most recent call last):
  File "/usr/local/lib/python3.4/dist-packages/Sphinx-1.5.2-py3.4.egg/sphinx/ext/autodoc.py",
line 551, in import_object
    __import__(self.modname)
  File "gramps/plugins/db/dbapi/postgresql.py", line 27, in <module>
    import psycopg2
ImportError: No module named 'psycopg2'

https://gramps-project.org/bugs/view.php?id=8855#c51089

I did not look if we should try to play, here, with conditional stuff (try/except)
on file "gramps/plugins/db/dbapi/postgresql.py", line 27.

Maybe try to install 'psycopg2'?


Hope this can help.

Jérôme



--------------------------------------------
En date de : Mar 2.5.17, Sam Manzi <[hidden email]> a écrit :

 Objet: Re: [Gramps-users] Postgresql
 À: "[hidden email]" <[hidden email]>, "[hidden email]" <[hidden email]>
 Date: Mardi 2 mai 2017, 4h05
 
 Hello john,
 
 Gramps 5 has not been
 released yet. As for using Gramps master(eg: the future
 Gramps 5) with postgresql I can only direct you to the
 following page:
 
 https://gramps-project.org/
 wiki/index.php?title=DB-API_ Database_Backend
 
 Note that the information
 provided may not work any longer as I seem to recall one of
 the developers mentioning that only sqlite3 will be
 initially supported.
 
 Kind regards
 Sam
 ------------------------------------------------------------------------------
 Check out the vibrant tech community on one of
 the world's most
 engaging tech sites,
 Slashdot.org! http://sdm.link/slashdot_______________________________________________
 Gramps-users mailing list
 [hidden email]
 https://lists.sourceforge.net/lists/listinfo/gramps-users
 https://gramps-project.org

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel