Re: help installing Gramps 4.2.8 in Centos 7

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

Re: help installing Gramps 4.2.8 in Centos 7

John Doorty

Hi All

I have been trying to install latest release 4.2.8 on Centos 7. I am relatively new to Linux and this is a new installation of Gramps.

I have tried installing the source with bsddb3 and Berkeley following the instructions on the download page.

.gramps.gen.utils.grampslocale.WARNING: ICU not loaded because No module named 'PyICU'. Localization will be impaired. Use your package manager to install PyICU
2018-02-17 18:09:19.788: WARNING: line 172:
You don't have the python3 bsddb3 package installed. This package is needed to start Gramps.

Even though the error above says python3 bsddb3 package is not installed, afaik I have installed this successfully.

I have also tried virtualenv to get over the python 2.7 of Centos, But still can't get Gramps to work.

Do you have any documentation on getting Gramps working on Centos?

Appreciate any help you can give.

Kind regards


Find the home of your dreams with eircom net property
Sign up for email alerts now

Check out the vibrant tech community on one of the world's most
engaging tech sites,!
Gramps-devel mailing list
[hidden email]