Trouble installing Gramps-2.2.3 on FreeBSD 6.1-RELEASE-p3

classic Classic list List threaded Threaded
17 messages Options
Reply | Threaded
Open this post in threaded view
|

Trouble installing Gramps-2.2.3 on FreeBSD 6.1-RELEASE-p3

Leslie Jensen
Hi all

I'm having trouble installing Gramps-2.2.3 on FreeBSD 6.1-RELEASE-p3.
Don wrote me an instruction a while back but due to circumstances I
haven't been at it for a while. I've done the following


1) Download the source code
2) Extract the source code

     $ gunzip gramps-2.2.3.tar.gz
     $ tar xvf gramps-2.2.3.tar

3) Configure the source code to use /usr/X11R6 for its path, since that
    is where FreeBSD likes to put gtk/gnome stuff

     $ cd gramps-2.2.3
     $ ./configure --prefix=/usr/X11R6

4) Build the program, then change to root and install

     $ make
     $ su
     $ make install



When I do make something goes wrong!

lesbsdpc# make
Making all in m4
Making all in po
Error expanding embedded variable.
*** Error code 1


Can you help me, Please?

Thanks Leslie


-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Trouble installing Gramps-2.2.3 on FreeBSD 6.1-RELEASE-p3

Alex Roitman
Leslie,

On Thu, 2006-12-14 at 20:11 +0100, Leslie Jensen wrote:
> When I do make something goes wrong!
>
> lesbsdpc# make
> Making all in m4
> Making all in po
> Error expanding embedded variable.
> *** Error code 1

This is a bit sparse on details :-)
Is there anything else in the error message?
Are you using GNU make?
Do you have gettext installed?

Alex

--
Alexander Roitman   http://www.gramps-project.org

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Trouble installing Gramps-2.2.3 on FreeBSD 6.1-RELEASE-p3

Leslie Jensen

Alex Roitman skrev:

> Leslie,
>
> On Thu, 2006-12-14 at 20:11 +0100, Leslie Jensen wrote:
>> When I do make something goes wrong!
>>
>> lesbsdpc# make
>> Making all in m4
>> Making all in po
>> Error expanding embedded variable.
>> *** Error code 1
>




> This is a bit sparse on details :-)
Yes, for sure. But that's all I've got.


> Is there anything else in the error message?
I'm afraid not!


> Are you using GNU make?
I think so :-)

pkg_info | grep make

automake-1.4.6_2    GNU Standards-compliant Makefile generator (1.4)
automake-1.5_2,1    GNU Standards-compliant Makefile generator (1.5)
automake-1.9.6      GNU Standards-compliant Makefile generator (1.9)
gmake-3.81_1        GNU version of 'make' utility
gnu-automake-1.10   GNU Standards-compliant Makefile generator (GNU
unmodified)


> Do you have gettext installed?

pkg_info | grep gettext
gettext-0.14.5_2    GNU gettext package
p5-gettext-1.05_1   Message handling functions


I'll be thankfull for any advise.
/Leslie

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Trouble installing Gramps-2.2.3 on FreeBSD 6.1-RELEASE-p3

Alex Roitman
Leslie,

On Fri, 2006-12-15 at 20:27 +0100, Leslie Jensen wrote:
> > Is there anything else in the error message?
> I'm afraid not!

I see.

> > Do you have gettext installed?
>
> pkg_info | grep gettext
> gettext-0.14.5_2    GNU gettext package
> p5-gettext-1.05_1   Message handling functions

OK, next stop should be intltool, libglib2.0-dev,
and gnome-doc-utils. Install those and try again,
let me know how it goes.

We are using gnome build tools, sorry for the dependencies :-)

Alex

--
Alexander Roitman   http://www.gramps-project.org

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Trouble installing Gramps-2.2.3 on FreeBSD 6.1-RELEASE-p3

Leslie Jensen

Alex Roitman skrev:
>
> OK, next stop should be intltool, libglib2.0-dev,
> and gnome-doc-utils. Install those and try again,
> let me know how it goes.
>
> We are using gnome build tools, sorry for the dependencies :-)
>
> Alex
>
It's the libglib2.0-dev I'm missing. But I can't find a port with that
name. Is it part of another port? I've done some Googling but have not
found anything I can use.
/Leslie

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Trouble installing Gramps-2.2.3 on FreeBSD 6.1-RELEASE-p3

Alex Roitman
On Sat, 2006-12-16 at 21:39 +0100, Leslie Jensen wrote:
> >
> It's the libglib2.0-dev I'm missing. But I can't find a port with that
> name. Is it part of another port? I've done some Googling but have not
> found anything I can use.

I found glib-2.12.4 here http://cvsweb.freebsd.org/ports/devel/glib20
Not sure if it has devel side as well.

The name libglib2.0-dev is from Debian, and in debian that package
is built from the source of glib2.0.

If you have files in /usr/include/glib-2.0/glib/ (or whatever
the include place for glib would be on your system) then you're
all set.

Alex

--
Alexander Roitman   http://www.gramps-project.org

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Trouble installing Gramps-2.2.3 on FreeBSD 6.1-RELEASE-p3

Leslie Jensen


Alex Roitman skrev:

> On Sat, 2006-12-16 at 21:39 +0100, Leslie Jensen wrote:
>> It's the libglib2.0-dev I'm missing. But I can't find a port with that
>> name. Is it part of another port? I've done some Googling but have not
>> found anything I can use.
>
> I found glib-2.12.4 here http://cvsweb.freebsd.org/ports/devel/glib20
> Not sure if it has devel side as well.
>
> The name libglib2.0-dev is from Debian, and in debian that package
> is built from the source of glib2.0.
>
> If you have files in /usr/include/glib-2.0/glib/ (or whatever
> the include place for glib would be on your system) then you're
> all set.
>
> Alex
>
Thanks Axel

I've got that one installed already.

So what do I do now, anything else I need?
/Leslie

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Trouble installing Gramps-2.2.3 on FreeBSD 6.1-RELEASE-p3

Alex Roitman
On Sat, 2006-12-16 at 23:32 +0100, Leslie Jensen wrote:
> So what do I do now, anything else I need?

Maybe this is it. Ideally, you would want to run:
   ./autogen.sh --prefix=[your_prefix]
and then make and make install. Ideally you would
use GNU autotools and GNU make. Your mileage may vary :-)

Does it work? Any new errors?
Alex

--
Alexander Roitman   http://www.gramps-project.org

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Trouble installing Gramps-2.2.3 on FreeBSD 6.1-RELEASE-p3

Leslie Jensen


Alex Roitman skrev:

> On Sat, 2006-12-16 at 23:32 +0100, Leslie Jensen wrote:
>> So what do I do now, anything else I need?
>
> Maybe this is it. Ideally, you would want to run:
>    ./autogen.sh --prefix=[your_prefix]
> and then make and make install. Ideally you would
> use GNU autotools and GNU make. Your mileage may vary :-)
>
> Does it work? Any new errors?
> Alex
>

So here's what I've done. Installed autoconf261

I do not understand why it says that automake is not installed!

pkg_info | grep automake
automake-1.4.6_2    GNU Standards-compliant Makefile generator (1.4)
automake-1.5_2,1    GNU Standards-compliant Makefile generator (1.5)
automake-1.9.6      GNU Standards-compliant Makefile generator (1.9)
gnome-common-2.12.0 Common automake macros for GNOME and GNOME 2
gnu-automake-1.10   GNU Standards-compliant Makefile generator (GNU
unmodified)

I can see that the glib-gettext >= 2.2.0 but the latest port I can find
is 2.12.4 and it's installed! I see that this version is referred to as
(current stable version) Is the 2.2.0 unstable?

 > pkg_info | grep glib
dbus-glib-0.72      GLib bindings for the D-BUS messaging system
glib-1.2.10_12      Some useful routines of C programming (previous
stable vers
glib-2.12.4         Some useful routines of C programming (current
stable versi
glibmm-2.12.3       C++ interfaces for glib2
linux-glib2-2.6.6   Version 2.X Linux/i386 binary port of GLib
taglib-1.4_2        Library for manipulating ID3 tags and Ogg comments

 > pkg_info | grep gettext
gettext-0.14.5_2    GNU gettext package
p5-gettext-1.05_1   Message handling functions


So what do you recommend I do now?
Thanks
/Leslie




 > ./autogen.sh --prefix=/usr/X11R6
You need to install gnome-common package.
 > rehash
 > ./autogen.sh --prefix=/usr/X11R6
/usr/local/bin/gnome-autogen.sh
checking for autoconf >= 2.53...
   testing autoconf2.50... autoconf2.50: not found
not found.
   testing autoconf... autoconf: not found
not found.
   testing autoconf-2.53... autoconf-2.53: not found
not found.
***Error***: You must have autoconf >= 2.53 installed
   to build gramps.  Download the appropriate package for
   from your distribution or get the source tarball at
     http://ftp.gnu.org/pub/gnu/autoconf/autoconf-2.53.tar.gz

checking for automake >= 1.9...
   testing automake-1.9... automake-1.9: not found
not found.
***Error***: You must have automake >= 1.9 installed
   to build gramps.  Download the appropriate package for
   from your distribution or get the source tarball at
     http://ftp.gnu.org/pub/gnu/automake/automake-1.9.tar.gz

checking for glib-gettext >= 2.2.0...
   testing glib-gettextize... found 2.12.4
checking for intltool >= 0.25...
   testing intltoolize... found 0.35.1
checking for gnome-doc-utils >= 0.3.2...
   testing gnome-doc-prepare... found 0.7.2
--print-ac-dir: not found
vc_min_version='0.3.2'
want_libtool=false
KDE_FULL_SESSION=true
INTLTOOLIZE=intltoolize
DM_CONTROL=/var/run/xdmctl
GS_LIB='/home/les/.fonts'
REQUIRED_GTK_DOC_VERSION='1.0'
MACHTYPE=i386
KONSOLE_DCOP_SESSION='DCOPRef(konsole-7789,session-1)'
USER=les
MAIL=/var/mail/les
REQUIRED_GLIB_GETTEXT_VERSION='2.2.0'
cm_macrodirs=''
vc_comparator='>='
ECHO_N=-n
GNOME_DOC_PREPARE_VERSION='0.7.2'
boldface=''
SHLVL=1
VENDOR=intel
HOME=/home/les
XDM_MANAGED=/var/run/xdmctl/xdmctl-:0,maysd,mayfn,sched,rsvd,method=classic
DESKTOP_SESSION=kde
PAGER=more
GTK_RC_FILES='/etc/gtk/gtkrc:/home/les/.gtkrc:/home/les/.kde/share/config/gtkrc'
vc_source='http://ftp.gnome.org/pub/GNOME/sources/gnome-doc-utils/'
WANT_AUTOCONF_2_5=1
PS1='$ '
OPTIND=1
DIE=1
want_intltool=true
PS2='> '
REQUIRED_GETTEXT_VERSION='0.10.40'
USE_GNOME2_MACROS=1
GROUP=wheel
COLORTERM=''
configure_files='./configure.in'
want_gtk_doc=false
ACLOCAL=''
REQUIRED_INTLTOOL_VERSION='0.25'
MM_CHARSET=iso-8859-1
automake_progs='automake-1.9'
LOGNAME=les
want_gettext=false
WINDOWID=46137349
want_pkg_config=false
GLIB_GETTEXTIZE_VERSION='2.12.4'
want_glib_gettext=true
REQUIRED_GNOME_DOC_UTILS_VERSION='0.3.2'
PKG_NAME=gramps
TERM=xterm
BLOCKSIZE=K
want_gnome_doc_utils=true
GTK2_RC_FILES='/etc/gtk-2.0/gtkrc:/home/les/.gtkrc-2.0:/home/les/.kde/share/config/gtkrc-2.0'
ch_save_IFS=

SESSION_MANAGER='local/lesbsdpc.homenet.home:/tmp/.ICE-unix/770'
PPID=7874
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin:/home/les/bin
INTLTOOLIZE_VERSION='0.35.1'
ch_min=3
KONSOLE_DCOP='DCOPRef(konsole-7789,konsole)'
XCURSOR_THEME=default
GNOME_DOC_PREPARE=gnome-doc-prepare
ch_status=0
AUTOHEADER=''
REQUIRED_AUTOMAKE_VERSION='1.9'
DISPLAY=':0.0'
REQUIRED_M4MACROS=' glib-gettext.m4 intltool.m4'
LANG='sv_SE.ISO8859-1'
REQUIRED_PKG_CONFIG_VERSION='0.14.0'
HOST='lesbsdpc.homenet.home'
SHELL=/bin/tcsh
ch_cur=7
vc_checkprogs=gnome-doc-prepare
vc_status=0
configure_ac='./configure.in'
IFS='.'
vc_checkprog=gnome-doc-prepare
vc_package=gnome-doc-utils
normal=''
srcdir='.'
ch_actual_version=''
REQUIRED_AUTOCONF_VERSION='2.53'
KDE_MULTIHEAD=false
FORBIDDEN_M4MACROS=' gnome-cxx-check.m4'
OSTYPE=FreeBSD
ch_min_version='1.7'
PWD='/home/les/downloads/gramps-2.2.3'
REQUIRED_DOC_COMMON_VERSION='2.3.0'
XDG_CONFIG_DIRS=:/etc/xdg:/usr/local/etc/xdg:/usr/X11R6/etc/xdg:/usr/local/etc/xdg/xfce4
XDG_DATA_DIRS=:/usr/share:/usr/local/share:/usr/local/share/gnome:/usr/X11R6/share:/usr/X11R6/share/gnome
vc_variable=GNOME_DOC_PREPARE
REQUIRED_LIBTOOL_VERSION='1.4.3'
GLIB_GETTEXTIZE=glib-gettextize
FTP_PASSIVE_MODE=YES
vc_actual_version='0.7.2'
HOSTTYPE=FreeBSD
EDITOR=vi
shift: can't shift that many
Checking for required M4 macros...
   glib-gettext.m4 not found
   intltool.m4 not found
Checking for forbidden M4 macros...
***Error***: some autoconf macros required to build gramps
   were not found in your aclocal path, or some forbidden
   macros were found.  Perhaps you need to adjust your
   ACLOCAL_FLAGS?


-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Trouble installing Gramps-2.2.3 on FreeBSD 6.1-RELEASE-p3

Don Allingham
Over the next week or so, I will try building a 6.1 machine. I haven't
built a FreeBSD system since 5.1, so it is about time for me to upgrade.

Unfortunately, we don't have a FreeBSD packager. We probably ought to
put out a call for one.

On Sun, 2006-12-17 at 14:07 +0100, Leslie Jensen wrote:

>
> Alex Roitman skrev:
> > On Sat, 2006-12-16 at 23:32 +0100, Leslie Jensen wrote:
> >> So what do I do now, anything else I need?
> >
> > Maybe this is it. Ideally, you would want to run:
> >    ./autogen.sh --prefix=[your_prefix]
> > and then make and make install. Ideally you would
> > use GNU autotools and GNU make. Your mileage may vary :-)
> >
> > Does it work? Any new errors?
> > Alex
> >
>
> So here's what I've done. Installed autoconf261
>
> I do not understand why it says that automake is not installed!
>
> pkg_info | grep automake
> automake-1.4.6_2    GNU Standards-compliant Makefile generator (1.4)
> automake-1.5_2,1    GNU Standards-compliant Makefile generator (1.5)
> automake-1.9.6      GNU Standards-compliant Makefile generator (1.9)
> gnome-common-2.12.0 Common automake macros for GNOME and GNOME 2
> gnu-automake-1.10   GNU Standards-compliant Makefile generator (GNU
> unmodified)
>
> I can see that the glib-gettext >= 2.2.0 but the latest port I can find
> is 2.12.4 and it's installed! I see that this version is referred to as
> (current stable version) Is the 2.2.0 unstable?
>
>  > pkg_info | grep glib
> dbus-glib-0.72      GLib bindings for the D-BUS messaging system
> glib-1.2.10_12      Some useful routines of C programming (previous
> stable vers
> glib-2.12.4         Some useful routines of C programming (current
> stable versi
> glibmm-2.12.3       C++ interfaces for glib2
> linux-glib2-2.6.6   Version 2.X Linux/i386 binary port of GLib
> taglib-1.4_2        Library for manipulating ID3 tags and Ogg comments
>
>  > pkg_info | grep gettext
> gettext-0.14.5_2    GNU gettext package
> p5-gettext-1.05_1   Message handling functions
>
>
> So what do you recommend I do now?
> Thanks
> /Leslie
>
>
>
>
>  > ./autogen.sh --prefix=/usr/X11R6
> You need to install gnome-common package.
>  > rehash
>  > ./autogen.sh --prefix=/usr/X11R6
> /usr/local/bin/gnome-autogen.sh
> checking for autoconf >= 2.53...
>    testing autoconf2.50... autoconf2.50: not found
> not found.
>    testing autoconf... autoconf: not found
> not found.
>    testing autoconf-2.53... autoconf-2.53: not found
> not found.
> ***Error***: You must have autoconf >= 2.53 installed
>    to build gramps.  Download the appropriate package for
>    from your distribution or get the source tarball at
>      http://ftp.gnu.org/pub/gnu/autoconf/autoconf-2.53.tar.gz
>
> checking for automake >= 1.9...
>    testing automake-1.9... automake-1.9: not found
> not found.
> ***Error***: You must have automake >= 1.9 installed
>    to build gramps.  Download the appropriate package for
>    from your distribution or get the source tarball at
>      http://ftp.gnu.org/pub/gnu/automake/automake-1.9.tar.gz
>
> checking for glib-gettext >= 2.2.0...
>    testing glib-gettextize... found 2.12.4
> checking for intltool >= 0.25...
>    testing intltoolize... found 0.35.1
> checking for gnome-doc-utils >= 0.3.2...
>    testing gnome-doc-prepare... found 0.7.2
> --print-ac-dir: not found
> vc_min_version='0.3.2'
> want_libtool=false
> KDE_FULL_SESSION=true
> INTLTOOLIZE=intltoolize
> DM_CONTROL=/var/run/xdmctl
> GS_LIB='/home/les/.fonts'
> REQUIRED_GTK_DOC_VERSION='1.0'
> MACHTYPE=i386
> KONSOLE_DCOP_SESSION='DCOPRef(konsole-7789,session-1)'
> USER=les
> MAIL=/var/mail/les
> REQUIRED_GLIB_GETTEXT_VERSION='2.2.0'
> cm_macrodirs=''
> vc_comparator='>='
> ECHO_N=-n
> GNOME_DOC_PREPARE_VERSION='0.7.2'
> boldface=''
> SHLVL=1
> VENDOR=intel
> HOME=/home/les
> XDM_MANAGED=/var/run/xdmctl/xdmctl-:0,maysd,mayfn,sched,rsvd,method=classic
> DESKTOP_SESSION=kde
> PAGER=more
> GTK_RC_FILES='/etc/gtk/gtkrc:/home/les/.gtkrc:/home/les/.kde/share/config/gtkrc'
> vc_source='http://ftp.gnome.org/pub/GNOME/sources/gnome-doc-utils/'
> WANT_AUTOCONF_2_5=1
> PS1='$ '
> OPTIND=1
> DIE=1
> want_intltool=true
> PS2='> '
> REQUIRED_GETTEXT_VERSION='0.10.40'
> USE_GNOME2_MACROS=1
> GROUP=wheel
> COLORTERM=''
> configure_files='./configure.in'
> want_gtk_doc=false
> ACLOCAL=''
> REQUIRED_INTLTOOL_VERSION='0.25'
> MM_CHARSET=iso-8859-1
> automake_progs='automake-1.9'
> LOGNAME=les
> want_gettext=false
> WINDOWID=46137349
> want_pkg_config=false
> GLIB_GETTEXTIZE_VERSION='2.12.4'
> want_glib_gettext=true
> REQUIRED_GNOME_DOC_UTILS_VERSION='0.3.2'
> PKG_NAME=gramps
> TERM=xterm
> BLOCKSIZE=K
> want_gnome_doc_utils=true
> GTK2_RC_FILES='/etc/gtk-2.0/gtkrc:/home/les/.gtkrc-2.0:/home/les/.kde/share/config/gtkrc-2.0'
> ch_save_IFS=
>
> SESSION_MANAGER='local/lesbsdpc.homenet.home:/tmp/.ICE-unix/770'
> PPID=7874
> PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin:/home/les/bin
> INTLTOOLIZE_VERSION='0.35.1'
> ch_min=3
> KONSOLE_DCOP='DCOPRef(konsole-7789,konsole)'
> XCURSOR_THEME=default
> GNOME_DOC_PREPARE=gnome-doc-prepare
> ch_status=0
> AUTOHEADER=''
> REQUIRED_AUTOMAKE_VERSION='1.9'
> DISPLAY=':0.0'
> REQUIRED_M4MACROS=' glib-gettext.m4 intltool.m4'
> LANG='sv_SE.ISO8859-1'
> REQUIRED_PKG_CONFIG_VERSION='0.14.0'
> HOST='lesbsdpc.homenet.home'
> SHELL=/bin/tcsh
> ch_cur=7
> vc_checkprogs=gnome-doc-prepare
> vc_status=0
> configure_ac='./configure.in'
> IFS='.'
> vc_checkprog=gnome-doc-prepare
> vc_package=gnome-doc-utils
> normal=''
> srcdir='.'
> ch_actual_version=''
> REQUIRED_AUTOCONF_VERSION='2.53'
> KDE_MULTIHEAD=false
> FORBIDDEN_M4MACROS=' gnome-cxx-check.m4'
> OSTYPE=FreeBSD
> ch_min_version='1.7'
> PWD='/home/les/downloads/gramps-2.2.3'
> REQUIRED_DOC_COMMON_VERSION='2.3.0'
> XDG_CONFIG_DIRS=:/etc/xdg:/usr/local/etc/xdg:/usr/X11R6/etc/xdg:/usr/local/etc/xdg/xfce4
> XDG_DATA_DIRS=:/usr/share:/usr/local/share:/usr/local/share/gnome:/usr/X11R6/share:/usr/X11R6/share/gnome
> vc_variable=GNOME_DOC_PREPARE
> REQUIRED_LIBTOOL_VERSION='1.4.3'
> GLIB_GETTEXTIZE=glib-gettextize
> FTP_PASSIVE_MODE=YES
> vc_actual_version='0.7.2'
> HOSTTYPE=FreeBSD
> EDITOR=vi
> shift: can't shift that many
> Checking for required M4 macros...
>    glib-gettext.m4 not found
>    intltool.m4 not found
> Checking for forbidden M4 macros...
> ***Error***: some autoconf macros required to build gramps
>    were not found in your aclocal path, or some forbidden
>    macros were found.  Perhaps you need to adjust your
>    ACLOCAL_FLAGS?
>
>
> -------------------------------------------------------------------------
> Take Surveys. Earn Cash. Influence the Future of IT
> Join SourceForge.net's Techsay panel and you'll get the chance to share your
> opinions on IT & business topics through brief surveys - and earn cash
> http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
> _______________________________________________
> Gramps-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gramps-users

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Trouble installing Gramps-2.2.3 on FreeBSD 6.1-RELEASE-p3

Alex Roitman
In reply to this post by Leslie Jensen
Leslie,

On Sun, 2006-12-17 at 14:07 +0100, Leslie Jensen wrote:

>  > ./autogen.sh --prefix=/usr/X11R6
> /usr/local/bin/gnome-autogen.sh
> checking for autoconf >= 2.53...
>    testing autoconf2.50... autoconf2.50: not found
> not found.
>    testing autoconf... autoconf: not found
> not found.
>    testing autoconf-2.53... autoconf-2.53: not found
> not found.
> ***Error***: You must have autoconf >= 2.53 installed
>    to build gramps.  Download the appropriate package for
>    from your distribution or get the source tarball at
>      http://ftp.gnu.org/pub/gnu/autoconf/autoconf-2.53.tar.gz
>
> checking for automake >= 1.9...
>    testing automake-1.9... automake-1.9: not found
> not found.
> ***Error***: You must have automake >= 1.9 installed
>    to build gramps.  Download the appropriate package for
>    from your distribution or get the source tarball at
>      http://ftp.gnu.org/pub/gnu/automake/automake-1.9.tar.gz
I saw issues in the past when the existence of automake-1.4
and -1.5 somehow prevented automake 1.9 from being properly
seen. Maybe removing the 1.4 and 1.5 will help.

No clue about autoconf.

Alex

--
Alexander Roitman   http://www.gramps-project.org

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Trouble installing Gramps-2.2.3 on FreeBSD 6.1

Don Allingham
In reply to this post by Leslie Jensen
Okay, here is what I had to do to get GRAMPS working under FreeBSD 6.1.
Hopefully, whoever is maintaining the ports will update from 2.0.9.

Packages to make sure are installed:

py24-gnome
py24-gnome-extras
automake19
gnomecommon
autoconf259
gnu-automake
gnu-libtool
gmake

Then do the following:

$ export PATH=/usr/local/gnu-autotools/bin:$PATH
$ export ACLOCAL_FLAGS="-I /usr/local/gnu-autotools/share/aclocal -I. -I /usr/local/share/aclocal -I /usr/X11R6/share/aclocal"
$ ./autogen.sh
$ gmake
$ gmake install

This will compile and install GRAMPS correctly. Unfortunately, on my
system, I have a broken python install which causes a error due to
_bsddb.

Don

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users

signature.asc (198 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Trouble installing Gramps-2.2.3 on FreeBSD 6.1

Leslie Jensen
Thanks Don

I needed to install the py24-gnome-extras!

I did write the porter of Gramps a while back. His answer was that he
did not use Gramps anymore and therefore would not continue the porting.

I now get an error with export.
export PATH=/usr/local/gnu-autotools/bin:$PATH
export: Command not found.

I've found several ports with export but I'm not sure which one I need.
http://www.freebsd.org/cgi/ports.cgi?query=export&stype=all&sektion=all

Please give me you advice :-)

Thanks
Leslie

Don Allingham skrev:

> Okay, here is what I had to do to get GRAMPS working under FreeBSD 6.1.
> Hopefully, whoever is maintaining the ports will update from 2.0.9.
>
> Packages to make sure are installed:
>
> py24-gnome
> py24-gnome-extras
> automake19
> gnomecommon
> autoconf259
> gnu-automake
> gnu-libtool
> gmake
>
> Then do the following:
>
> $ export PATH=/usr/local/gnu-autotools/bin:$PATH
> $ export ACLOCAL_FLAGS="-I /usr/local/gnu-autotools/share/aclocal -I. -I /usr/local/share/aclocal -I /usr/X11R6/share/aclocal"
> $ ./autogen.sh
> $ gmake
> $ gmake install
>
> This will compile and install GRAMPS correctly. Unfortunately, on my
> system, I have a broken python install which causes a error due to
> _bsddb.
>
> Don


-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Trouble installing Gramps-2.2.3 on FreeBSD 6.1

Alex Roitman
Leslie,


On Mon, 2006-12-18 at 23:23 +0100, Leslie Jensen wrote:
> I now get an error with export.
> export PATH=/usr/local/gnu-autotools/bin:$PATH
> export: Command not found.

The 'export' is a bash statement. With C shell you
need setenv instead:
   setenv PATH=/usr/local/gnu-autotools/bin:$PATH
(if I am not mistaken).

Alex

--
Alexander Roitman   http://www.gramps-project.org

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Trouble installing Gramps-2.2.3 on FreeBSD 6.1

Leslie Jensen
In reply to this post by Don Allingham

Automake is still giving me problems. I've removed version 1.4 and 1.5.
Made deinstall and reinstall of 1.9 but still it complains about not
having automake 1.9 :-(

pkg_info | grep automake
automake-1.9.6      GNU Standards-compliant Makefile generator (1.9)
gnome-common-2.12.0 Common automake macros for GNOME and GNOME 2
gnu-automake-1.10   GNU Standards-compliant Makefile generator (GNU
unmodified)

I'll have to go to bed now. Thanks for all you help so far. I'll get
back to the problem tomorrow.
/Leslie


  ./autogen.sh
/usr/local/bin/gnome-autogen.sh
checking for autoconf >= 2.53...
   testing autoconf2.50... autoconf2.50: not found
not found.
   testing autoconf... found 2.61
checking for automake >= 1.9...
   testing automake-1.9... automake-1.9: not found
not found.
***Error***: You must have automake >= 1.9 installed
   to build gramps.  Download the appropriate package for
   from your distribution or get the source tarball at
     http://ftp.gnu.org/pub/gnu/automake/automake-1.9.tar.gz

checking for glib-gettext >= 2.2.0...
   testing glib-gettextize... found 2.12.4
checking for intltool >= 0.25...
   testing intltoolize... found 0.35.1
checking for gnome-doc-utils >= 0.3.2...
   testing gnome-doc-prepare... found 0.7.2
--print-ac-dir: not found
vc_min_version='0.3.2'
want_libtool=false
KDE_FULL_SESSION=true
INTLTOOLIZE=intltoolize
DM_CONTROL=/var/run/xdmctl
GS_LIB='/home/les/.fonts'
REQUIRED_GTK_DOC_VERSION='1.0'
MACHTYPE=i386
KONSOLE_DCOP_SESSION='DCOPRef(konsole-99339,session-1)'
USER=les
MAIL=/var/mail/les
REQUIRED_GLIB_GETTEXT_VERSION='2.2.0'
cm_macrodirs=''
vc_comparator='>='
ECHO_N=-n
GNOME_DOC_PREPARE_VERSION='0.7.2'
boldface=''
SHLVL=1
VENDOR=intel
ACLOCAL_FLAGS='-I /usr/local/gnu-autotools/share/aclocal -I. -I
/usr/local/share/aclocal -I /usr/X11R6/share/aclocal'
HOME=/home/les
XDM_MANAGED=/var/run/xdmctl/xdmctl-:0,maysd,mayfn,sched,rsvd,method=classic
DESKTOP_SESSION=kde
AUTOCONF=autoconf
PAGER=more
GTK_RC_FILES='/etc/gtk/gtkrc:/home/les/.gtkrc:/home/les/.kde/share/config/gtkrc'
vc_source='http://ftp.gnome.org/pub/GNOME/sources/gnome-doc-utils/'
WANT_AUTOCONF_2_5=1
PS1='$ '
OPTIND=1
DIE=1
want_intltool=true
PS2='> '
REQUIRED_GETTEXT_VERSION='0.10.40'
USE_GNOME2_MACROS=1
GROUP=wheel
COLORTERM=''
configure_files='./configure.in'
want_gtk_doc=false
ACLOCAL=''
REQUIRED_INTLTOOL_VERSION='0.25'
MM_CHARSET=iso-8859-1
automake_progs='automake-1.9'
LOGNAME=les
want_gettext=false
WINDOWID=37748741
want_pkg_config=false
GLIB_GETTEXTIZE_VERSION='2.12.4'
want_glib_gettext=true
REQUIRED_GNOME_DOC_UTILS_VERSION='0.3.2'
PKG_NAME=gramps
TERM=xterm
BLOCKSIZE=K
want_gnome_doc_utils=true
GTK2_RC_FILES='/etc/gtk-2.0/gtkrc:/home/les/.gtkrc-2.0:/home/les/.kde/share/config/gtkrc-2.0'
ch_save_IFS=

SESSION_MANAGER='local/lesbsdpc.homenet.home:/tmp/.ICE-unix/770'
PPID=99341
PATH=/usr/local/gnu-autotools/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin:/home/les/bin
INTLTOOLIZE_VERSION='0.35.1'
ch_min=3
KONSOLE_DCOP='DCOPRef(konsole-99339,konsole)'
XCURSOR_THEME=default
GNOME_DOC_PREPARE=gnome-doc-prepare
AUTOHEADER=autoheader
ch_status=0
REQUIRED_AUTOMAKE_VERSION='1.9'
DISPLAY=':0.0'
REQUIRED_M4MACROS=' glib-gettext.m4 intltool.m4'
LANG='sv_SE.ISO8859-1'
REQUIRED_PKG_CONFIG_VERSION='0.14.0'
HOST='lesbsdpc.homenet.home'
SHELL=/bin/tcsh
ch_cur=7
vc_checkprogs=gnome-doc-prepare
vc_status=0
configure_ac='./configure.in'
IFS='.'
AUTOCONF_VERSION='2.61'
vc_checkprog=gnome-doc-prepare
vc_package=gnome-doc-utils
normal=''
srcdir='.'
ch_actual_version=''
REQUIRED_AUTOCONF_VERSION='2.53'
KDE_MULTIHEAD=false
FORBIDDEN_M4MACROS=' gnome-cxx-check.m4'
OSTYPE=FreeBSD
ch_min_version='1.7'
PWD='/home/les/downloads/gramps-2.2.3'
REQUIRED_DOC_COMMON_VERSION='2.3.0'
XDG_CONFIG_DIRS=:/etc/xdg:/usr/local/etc/xdg:/usr/X11R6/etc/xdg:/usr/local/etc/xdg/xfce4
XDG_DATA_DIRS=:/usr/share:/usr/local/share:/usr/local/share/gnome:/usr/X11R6/share:/usr/X11R6/share/gnome
vc_variable=GNOME_DOC_PREPARE
REQUIRED_LIBTOOL_VERSION='1.4.3'
GLIB_GETTEXTIZE=glib-gettextize
FTP_PASSIVE_MODE=YES
vc_actual_version='0.7.2'
HOSTTYPE=FreeBSD
EDITOR=vi
shift: can't shift that many
Checking for required M4 macros...
Checking for forbidden M4 macros...
 >




-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Trouble installing Gramps-2.2.6-1 on FreeBSD 6.2

Leslie Jensen
Hi all
I'm back working on installing Gramps under BSD. I'm getting help from a
friend, who is working on porting Gramps to FreeBSD. It compiles and
installs without problems, but when I start Gramps and try to do for
example a new database the following happens


19569: ERROR: DbLoader.py: line 468: Failed to open database.
Traceback (most recent call last):
   File "/usr/local/share/gramps/DbLoader.py", line 447, in read_file
     self.dbstate.db.load(filename,self.uistate.pulse_progressbar,mode)
   File "/usr/local/share/gramps/GrampsDb/_GrampsBSDDB.py", line 347, in
load
     self.env.set_flags(db.DB_LOG_AUTOREMOVE,1)  # clean up unused logs
AttributeError: 'module' object has no attribute 'DB_LOG_AUTOREMOVE'


Can anyone help me in this case?
Thanks :-)


Leslie Jensen


Leslie Jensen wrote:
> Automake is still giving me problems. I've removed version 1.4 and 1.5.
> Made deinstall and reinstall of 1.9 but still it complains about not
> having automake 1.9 :-(


-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys-and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: Trouble installing Gramps-2.2.6-1 on FreeBSD 6.2

Don Allingham
What version of BSDDB (berkeley database) is installed on your system?
It sounds as if there is a problem with this installation.

Don

On Fri, 2007-02-23 at 11:42 +0100, Leslie Jensen wrote:

> Hi all
> I'm back working on installing Gramps under BSD. I'm getting help from a
> friend, who is working on porting Gramps to FreeBSD. It compiles and
> installs without problems, but when I start Gramps and try to do for
> example a new database the following happens
>
>
> 19569: ERROR: DbLoader.py: line 468: Failed to open database.
> Traceback (most recent call last):
>    File "/usr/local/share/gramps/DbLoader.py", line 447, in read_file
>      self.dbstate.db.load(filename,self.uistate.pulse_progressbar,mode)
>    File "/usr/local/share/gramps/GrampsDb/_GrampsBSDDB.py", line 347, in
> load
>      self.env.set_flags(db.DB_LOG_AUTOREMOVE,1)  # clean up unused logs
> AttributeError: 'module' object has no attribute 'DB_LOG_AUTOREMOVE'
>
>
> Can anyone help me in this case?
> Thanks :-)
>
>
> Leslie Jensen
>
>
> Leslie Jensen wrote:
> > Automake is still giving me problems. I've removed version 1.4 and 1.5.
> > Made deinstall and reinstall of 1.9 but still it complains about not
> > having automake 1.9 :-(
>

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys-and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users

signature.asc (198 bytes) Download Attachment