Where is the unstable CVS ?

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Where is the unstable CVS ?

wb-3

I am trying to retrieve the latest development source from
CVS.

What branches do I populate from?

Thanks.

                        -- Wayne Bergeron




-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: Where is the unstable CVS ?

Don Allingham
The latest development branch is not in CVS. We have switched to using
Subversion instead.

To get the tree, initialize your tree with:

$ svn co https://svn.sourceforge.net/svnroot/gramps/trunk/gramps2 

Then to keep it up to date, from the top level of the source directory,
all you have to do is:

$ svn up


Don

On Fri, 2006-07-14 at 19:12 -0500, wb wrote:

> I am trying to retrieve the latest development source from
> CVS.
>
> What branches do I populate from?
>
> Thanks.
>
> -- Wayne Bergeron
>
>
>
>
> -------------------------------------------------------------------------
> Using Tomcat but need to do more? Need to support web services, security?
> Get stuff done quickly with pre-integrated technology to make your job easier
> Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
> http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
> _______________________________________________
> Gramps-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gramps-devel


-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel

signature.asc (198 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Where is the unstable CVS ?

wb-3
On Friday July 14 2006 19:18, Don Allingham wrote:
> The latest development branch is not in CVS. We have
> switched to using Subversion instead.
>
> To get the tree, initialize your tree with:
>
> $ svn co
> https://svn.sourceforge.net/svnroot/gramps/trunk/gramps2
<snip>

Thanks for that.

A detail you probably need to add to the build process for
newbies like me:

I had to
copy /usr/share/gnome-doc-utils/gnome-doc-utils.make to the
gramps2/ directory.  The ./autogen.sh wouldn't work until I
did that.  I imagine that's a detail that just never got
into the process.

BUT!:

I rebuilt version 7028 and tried to load my old database,
and got this error:

--------------------------------------------------------------
>gramps ~/genealogy/TWDT.grdb
Spelling checker is not installed
Trying to open: /home/wbg/genealogy/TWDT.grdb ...
Type: GRAMPS database
2719: ERROR: DbLoader.py: line 406: Failed to open database.
Traceback (most recent call last):
  File "/home/wbg/svn/gramps/gramps2/src/DbLoader.py", line
396, in read_file
   
self.dbstate.db.load(filename,self.uistate.pulse_progressbar,mode)
  File
"/home/wbg/svn/gramps/gramps2/src/GrampsDb/_GrampsBSDDB.py",
line 320, in load
    self.env.open(env_name,env_flags)
DBRunRecoveryError: (-30978, 'DB_RUNRECOVERY: Fatal error,
run database recovery -- PANIC: DB_PAGE_NOTFOUND: Requested
page not found')
Cannot open %s. Exiting...

--------------------------------------------------------------

It couldn't submit the error report, so I thought I'd send
this one in via email.  Maybe it is my build procedure, but
it seemed to work OK.  It opens GED files OK.


                        -- Wayne Bergeron



-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: Where is the unstable CVS ?

Alex Roitman
Wayne,

On Sat, 2006-07-15 at 17:55 -0500, wb wrote:
> A detail you probably need to add to the build process for
> newbies like me:
>
> I had to
> copy /usr/share/gnome-doc-utils/gnome-doc-utils.make to the
> gramps2/ directory.  The ./autogen.sh wouldn't work until I
> did that.  I imagine that's a detail that just never got
> into the process.

It works fine for me. If gnome-doc-utils.make does not exist
in gramps2 then autogen.sh-created configure copies it.
What exactly does not work in autogen.sh? How do you run it?

Can you try prefix=/usr/share for autogen.sh ?

> I rebuilt version 7028 and tried to load my old database,
> and got this error:
>
> --------------------------------------------------------------
> >gramps ~/genealogy/TWDT.grdb
> Spelling checker is not installed
> Trying to open: /home/wbg/genealogy/TWDT.grdb ...
> Type: GRAMPS database
> 2719: ERROR: DbLoader.py: line 406: Failed to open database.
> Traceback (most recent call last):
>   File "/home/wbg/svn/gramps/gramps2/src/DbLoader.py", line
> 396, in read_file
>    
> self.dbstate.db.load(filename,self.uistate.pulse_progressbar,mode)
>   File
> "/home/wbg/svn/gramps/gramps2/src/GrampsDb/_GrampsBSDDB.py",
> line 320, in load
>     self.env.open(env_name,env_flags)
> DBRunRecoveryError: (-30978, 'DB_RUNRECOVERY: Fatal error,
> run database recovery -- PANIC: DB_PAGE_NOTFOUND: Requested
> page not found')
> Cannot open %s. Exiting...
Could you please send me the original version of your database,
*before* it has been attempted to open with any 2.1.x version?
In other word, a good 2.0.x grdb file.

Thanks,
Alex

--
Alexander Roitman   http://www.gramps-project.org


-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Where is the unstable CVS ?

wb-3
On Saturday July 15 2006 18:24, Alex Roitman wrote:

> Wayne,
>
> On Sat, 2006-07-15 at 17:55 -0500, wb wrote:
> > A detail you probably need to add to the build process
> > for newbies like me:
> >
> > I had to
> > copy /usr/share/gnome-doc-utils/gnome-doc-utils.make to
> > the gramps2/ directory.  The ./autogen.sh wouldn't work
> > until I did that.  I imagine that's a detail that just
> > never got into the process.
>
> It works fine for me. If gnome-doc-utils.make does not
> exist in gramps2 then autogen.sh-created configure copies
> it. What exactly does not work in autogen.sh? How do you
> run it?
See the attached text file.

It autogen'ed to completion when I copied the mentioned
file.  It took me a while to figure that out.

> Could you please send me the original version of your
> database, *before* it has been attempted to open with any
> 2.1.x version? In other word, a good 2.0.x grdb file.

I'd like to, but it is 12MB after being gzipped.  I am on a
dial-up service, and that would take me hours.  I will see
what I can do.


                        -- Wayne Bergeron

--
        The tendency of taxation is to create a class of
        persons who do not labor, to take from those who
        do labor the produce of that labor, and to give
        it to those who do not labor.
       
                -- William Cobbett, 1881


-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel

ExampleOfAutogenNotWorking.txt (2K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: A GRDB file that kills version 7028

wb-3
In reply to this post by wb-3
On Sunday July 16 2006 09:11, you wrote:
> > Even after being filtered through a .ged file, this
> > grdb file causes the new version of gramps to barf.
>
> Not for me. Your file opened in the SVN version just
> fine.

>Try deleting the ~/.gramps/bsddbenv directory and again
>opening the file that you sent me.

That was enlightening.  It changed the error message to the
one in the attached file.

On further experimentation, it looks like the problem only
happens when the user running gramps does not have his own
X-windows session.

I am user wb.  I cloned user wb to user wbg.  I opened a
console for wbg on wb's desktop, and built and ran gramps.  
I do this with other GUI programs all the time.

That is when gramps has the problem.  On some .grdb files.

When I log into X-Windows as wbg, no similar problem occurs.

I'm sorry for the confusion.  Now, when experimenting with
the unstable gramps, I will open a new X-Windows session
for my clone.

                        -- Wayne Bergeron


-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel

XWindowsErrorMessage.txt (624 bytes) Download Attachment