dependencies

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

dependencies

Stéphane Charette-2
What should our dependencies be?

Here are the dependencies and recommendations in the debian/control file:

Build-Depends-Indep: libxml-parser-perl, python-gtk2, gettext, libgconf2-dev, python-central (>= 0.5.6), python, intltool
Build-Depends:  debhelper (>= 7)
XS-Python-Version: >=2.5
Architecture: all
Depends: ${python:Depends}, librsvg2-common, python-gtk2, xdg-utils, ${misc:Depends}
Replaces: gramps-manual, gramps-extending-doc
Conflicts: gramps-manual, gramps-extending-doc, gramps-common, python-gtk-1.2
Recommends: graphviz, python-webkit, python-gtkmozembed
Suggests: ttf-freefont, python-enchant, python-gtkspell


Am I right in thinking that libgconf2-dev should be removed?  Anything else?

Stéphane
------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: dependencies

Benny Malengier


2010/4/22 Stéphane Charette <[hidden email]>
What should our dependencies be?

Here are the dependencies and recommendations in the debian/control file:

Build-Depends-Indep: libxml-parser-perl, python-gtk2, gettext, libgconf2-dev, python-central (>= 0.5.6), python, intltool
Build-Depends:  debhelper (>= 7)
XS-Python-Version: >=2.5
Architecture: all
Depends: ${python:Depends}, librsvg2-common, python-gtk2, xdg-utils, ${misc:Depends}
Replaces: gramps-manual, gramps-extending-doc
Conflicts: gramps-manual, gramps-extending-doc, gramps-common, python-gtk-1.2
Recommends: graphviz, python-webkit, python-gtkmozembed
Suggests: ttf-freefont, python-enchant, python-gtkspell


Am I right in thinking that libgconf2-dev should be removed?  Anything else?

I think libgconf can indeed be removed. This is in build-depends though, so I would not know if our Makefile system does not need it somewhere
When I mentioned gconf to James he remarked that src/ThumbNails tries to load it, so as to use the gnome thumbnailer on gnome. Gramps works around it though, so not needed, and gconf is always present on Gnome desktops.

Benny


Stéphane

------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel



------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: dependencies

robhealey1
Dear Stephane:

I know that you are speaking about Ubuntu/ Debian dependencies, but here is one for Fedora:

python-reportlab is no longer needed from previous conversations on this list...  Could you possibly pass this onto the Fedora packager?

Sincerely yours,
Rob G. Healey


2010/4/22 Benny Malengier <[hidden email]>


2010/4/22 Stéphane Charette <[hidden email]>

What should our dependencies be?

Here are the dependencies and recommendations in the debian/control file:

Build-Depends-Indep: libxml-parser-perl, python-gtk2, gettext, libgconf2-dev, python-central (>= 0.5.6), python, intltool
Build-Depends:  debhelper (>= 7)
XS-Python-Version: >=2.5
Architecture: all
Depends: ${python:Depends}, librsvg2-common, python-gtk2, xdg-utils, ${misc:Depends}
Replaces: gramps-manual, gramps-extending-doc
Conflicts: gramps-manual, gramps-extending-doc, gramps-common, python-gtk-1.2
Recommends: graphviz, python-webkit, python-gtkmozembed
Suggests: ttf-freefont, python-enchant, python-gtkspell


Am I right in thinking that libgconf2-dev should be removed?  Anything else?

I think libgconf can indeed be removed. This is in build-depends though, so I would not know if our Makefile system does not need it somewhere
When I mentioned gconf to James he remarked that src/ThumbNails tries to load it, so as to use the gnome thumbnailer on gnome. Gramps works around it though, so not needed, and gconf is always present on Gnome desktops.

Benny


Stéphane

------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel



------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel



------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: dependencies

Jay Treacy
In reply to this post by Stéphane Charette-2
On Thu, Apr 22, 2010 at 03:52:18AM -0700, Stéphane Charette wrote:
> Am I right in thinking that libgconf2-dev should be removed?  Anything else?

I just built 3.2.1 without libgconf2-dev installed and it built fine.

--
James Treacy
[hidden email]

------------------------------------------------------------------------------
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel