gramps 4.1.0.0 on Debian Wheezy

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

gramps 4.1.0.0 on Debian Wheezy

Alvin Larson
Hello:

I tried to install python-gramps  4.1.0.0 on a fresh install of Debian
Wheezy 7.6.0.  There seems to be a
problem with python dependencies.  Is there a fix for this?

My reason for asking is I have a .gramps node, which I would like to
use.  It was generated with gramps 4.1.?.? on a Aptosid installation
that went kuput.  I also have a .gpkg backup file made with gramps
4.1.??.  I don't want to go back to Aptosid if I don't have to.

Thank you for help,

Alvin Larson


------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: gramps 4.1.0.0 on Debian Wheezy

Ross Gammon
Hi Alvin,

On 08/09/2014 02:37 AM, Alvin Larson wrote:
> Hello:
>
> I tried to install python-gramps  4.1.0.0 on a fresh install of Debian
> Wheezy 7.6.0.  There seems to be a
> problem with python dependencies.  Is there a fix for this?
>

The default Gramps in Debian Wheezy is 3.4.0. Whilst it is probably
possible to get Gramps 4.x working, I imagine it would be a lot of work
to get all of the dependencies installed. My general advice to people
using Wheezy would be to stick to the 3.4 series (currently 3.4.8).

But as you need to work with a database generated with 4.1.x, this is no
help to you. You could try upgrading to Debian Jessie (currently in
testing) and install 4.1.0 from the Gramps website? Or if you want
something more stable, Ubuntu 14.04 LTS might be a better base?

> My reason for asking is I have a .gramps node, which I would like to
> use.  It was generated with gramps 4.1.?.? on a Aptosid installation
> that went kuput.  I also have a .gpkg backup file made with gramps
> 4.1.??.  I don't want to go back to Aptosid if I don't have to.
>

Maybe some others on the list have some ideas with what you can do using
the .gramps directory or the gpkg backup file?

> Thank you for help,
>
> Alvin Larson
>

Regards,

Ross

------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: gramps 4.1.0.0 on Debian Wheezy

beagle10
In reply to this post by Alvin Larson
My initial experience indicates that Gramps 4.1.1 installs and works in Linux Mint 17.
Before installation, I had to backup old data and remove version 4.0.3.  After installation, I had to install 'python bsddb3'.
Now, the new version seems to work.