gramps-connect under Mint 17.2

classic Classic list List threaded Threaded
15 messages Options
Reply | Threaded
Open this post in threaded view
|

gramps-connect under Mint 17.2

Oldest1
Cloned gramps master from my current fork on github to a dir on my Mint 17.2 machine.
installed python-django (ubuntu version 1.6.1) from the Software Manager as well as Sqlite3 (version 3.8.2 )
Build gramps without error
cd'd to webapp and get:
arnold@Leno ~/grampConnectMaster/gramps/gramps/webapp $ make
mkdir -p grampsdb/fixtures
GRAMPS_RESOURCES=../.. PYTHONPATH=../.. python3 init.py > grampsdb/fixtures/initial_data.json
Traceback (most recent call last):
File "init.py", line 46, in <module>
from gramps.webapp.grampsdb.models import (GenderType, LdsType, LdsStatus,
File "/home/arnold/grampConnectMaster/gramps/gramps/webapp/grampsdb/models.py", line 27, in <module>
from django.db import models
ImportError: No module named 'django'
make: *** [grampsdb/fixtures/initial_data.json] Error 1
arnold@Leno ~/grampConnectMaster/gramps/gramps/webapp $

With this I am stuck :-(

Any suggestions anyone?
TIA
Arnold


-- 
Fight Spam - report it with wxSR 0.7
Vista & Win7 compatible
http://www.columbinehoney.net/wxSR.shtml

------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: gramps-connect under Mint 17.2

Ross Gammon
On 08/21/2015 12:27 AM, jecxz112 wrote:

> Cloned gramps master from my current fork on github to a dir on my Mint
> 17.2 machine.
> installed python-django (ubuntu version 1.6.1) from the Software Manager
> as well as Sqlite3 (version 3.8.2 )
> Build gramps without error
> cd'd to webapp and get:
> arnold@Leno ~/grampConnectMaster/gramps/gramps/webapp $ make
> mkdir -p grampsdb/fixtures
> GRAMPS_RESOURCES=../.. PYTHONPATH=../.. python3 init.py >
> grampsdb/fixtures/initial_data.json
> Traceback (most recent call last):
> File "init.py", line 46, in <module>
> from gramps.webapp.grampsdb.models import (GenderType, LdsType, LdsStatus,
> File
> "/home/arnold/grampConnectMaster/gramps/gramps/webapp/grampsdb/models.py",
> line 27, in <module>
> from django.db import models
> ImportError: No module named 'django'
> make: *** [grampsdb/fixtures/initial_data.json] Error 1
> arnold@Leno ~/grampConnectMaster/gramps/gramps/webapp $
>
> With this I am stuck :-(
>
> Any suggestions anyone?
> TIA
> Arnold
Not really sure what the problem is but note that you are using python
3, but not python3-django (using python-django).


------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel

signature.asc (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: gramps-connect under Mint 17.2

Oldest1
On 8/20/2015 11:40 PM, Ross Gammon wrote:
Thank you, Ross
Installing pip3 and python3-django got me a bit further, but in the end I still get a pile of error,
which I don't understand:
 ........
    Running deferred SQL...
  Installing custom SQL...
Traceback (most recent call last):
  File "/usr/local/lib/python3.4/dist-packages/django/core/serializers/json.py", line 78, in Deserializer
    objects = json.loads(stream_or_string)
  File "/usr/lib/python3.4/json/__init__.py", line 318, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python3.4/json/decoder.py", line 343, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python3.4/json/decoder.py", line 361, in raw_decode
    raise ValueError(errmsg("Expecting value", s, err.value)) from None
ValueError: Expecting value: line 1 column 1 (char 0)

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "manage.py", line 48, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/__init__.py", line 338, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/__init__.py", line 330, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/base.py", line 393, in run_from_argv
    self.execute(*args, **cmd_options)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/base.py", line 444, in execute
    output = self.handle(*args, **options)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/commands/syncdb.py", line 25, in handle
    call_command("migrate", **options)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/__init__.py", line 120, in call_command
    return command.execute(*args, **defaults)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/base.py", line 444, in execute
    output = self.handle(*args, **options)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/commands/migrate.py", line 179, in handle
    created_models = self.sync_apps(connection, executor.loader.unmigrated_apps)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/commands/migrate.py", line 365, in sync_apps
    hide_empty=True,
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/__init__.py", line 120, in call_command
    return command.execute(*args, **defaults)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/base.py", line 444, in execute
    output = self.handle(*args, **options)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/commands/loaddata.py", line 60, in handle
    self.loaddata(fixture_labels)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/commands/loaddata.py", line 90, in loaddata
    self.load_label(fixture_label)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/commands/loaddata.py", line 141, in load_label
    for obj in objects:
  File "/usr/local/lib/python3.4/dist-packages/django/core/serializers/json.py", line 85, in Deserializer
    six.reraise(DeserializationError, DeserializationError(e), sys.exc_info()[2])
  File "/usr/local/lib/python3.4/dist-packages/django/utils/six.py", line 658, in reraise
    raise value.with_traceback(tb)
  File "/usr/local/lib/python3.4/dist-packages/django/core/serializers/json.py", line 78, in Deserializer
    objects = json.loads(stream_or_string)
  File "/usr/lib/python3.4/json/__init__.py", line 318, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python3.4/json/decoder.py", line 343, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python3.4/json/decoder.py", line 361, in raw_decode
    raise ValueError(errmsg("Expecting value", s, err.value)) from None
django.core.serializers.base.DeserializationError: Problem installing fixture '/home/arnold/grampConnectMaster/gramps/gramps/webapp/grampsdb/fixtures/initial_data.json': Expecting value: line 1 column 1 (char 0)
make: *** [update] Error 1
arnold@Leno ~/grampConnectMaster/gramps/gramps/webapp $



-- 
Fight Spam - report it with wxSR 0.7
Vista & Win7 compatible
http://www.columbinehoney.net/wxSR.shtml

------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: gramps-connect under Mint 17.2

DS Blank
Try "make clean" followed by another "make"

I think you are close now.

-Doug

On Fri, Aug 21, 2015 at 1:19 PM, jecxz112 <[hidden email]> wrote:
On 8/20/2015 11:40 PM, Ross Gammon wrote:
Thank you, Ross
Installing pip3 and python3-django got me a bit further, but in the end I still get a pile of error,
which I don't understand:
 ........
    Running deferred SQL...
  Installing custom SQL...
Traceback (most recent call last):
  File "/usr/local/lib/python3.4/dist-packages/django/core/serializers/json.py", line 78, in Deserializer
    objects = json.loads(stream_or_string)
  File "/usr/lib/python3.4/json/__init__.py", line 318, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python3.4/json/decoder.py", line 343, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python3.4/json/decoder.py", line 361, in raw_decode
    raise ValueError(errmsg("Expecting value", s, err.value)) from None
ValueError: Expecting value: line 1 column 1 (char 0)

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "manage.py", line 48, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/__init__.py", line 338, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/__init__.py", line 330, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/base.py", line 393, in run_from_argv
    self.execute(*args, **cmd_options)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/base.py", line 444, in execute
    output = self.handle(*args, **options)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/commands/syncdb.py", line 25, in handle
    call_command("migrate", **options)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/__init__.py", line 120, in call_command
    return command.execute(*args, **defaults)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/base.py", line 444, in execute
    output = self.handle(*args, **options)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/commands/migrate.py", line 179, in handle
    created_models = self.sync_apps(connection, executor.loader.unmigrated_apps)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/commands/migrate.py", line 365, in sync_apps
    hide_empty=True,
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/__init__.py", line 120, in call_command
    return command.execute(*args, **defaults)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/base.py", line 444, in execute
    output = self.handle(*args, **options)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/commands/loaddata.py", line 60, in handle
    self.loaddata(fixture_labels)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/commands/loaddata.py", line 90, in loaddata
    self.load_label(fixture_label)
  File "/usr/local/lib/python3.4/dist-packages/django/core/management/commands/loaddata.py", line 141, in load_label
    for obj in objects:
  File "/usr/local/lib/python3.4/dist-packages/django/core/serializers/json.py", line 85, in Deserializer
    six.reraise(DeserializationError, DeserializationError(e), sys.exc_info()[2])
  File "/usr/local/lib/python3.4/dist-packages/django/utils/six.py", line 658, in reraise
    raise value.with_traceback(tb)
  File "/usr/local/lib/python3.4/dist-packages/django/core/serializers/json.py", line 78, in Deserializer
    objects = json.loads(stream_or_string)
  File "/usr/lib/python3.4/json/__init__.py", line 318, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python3.4/json/decoder.py", line 343, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python3.4/json/decoder.py", line 361, in raw_decode
    raise ValueError(errmsg("Expecting value", s, err.value)) from None
django.core.serializers.base.DeserializationError: Problem installing fixture '/home/arnold/grampConnectMaster/gramps/gramps/webapp/grampsdb/fixtures/initial_data.json': Expecting value: line 1 column 1 (char 0)
make: *** [update] Error 1
arnold@Leno ~/grampConnectMaster/gramps/gramps/webapp $



-- 
Fight Spam - report it with wxSR 0.7
Vista & Win7 compatible
http://www.columbinehoney.net/wxSR.shtml

------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel



------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: gramps-connect under Mint 17.2

Oldest1
On 8/21/2015 11:23 AM, Doug Blank wrote:
Try "make clean" followed by another "make"

I think you are close now.
Thank you, Doug.
The make clean did the trick for the compile. :-)

When I point my browser tp 127.0.0.1:8000, I get whole bunch of errors, starting with:
From the copy & paste view:
--------------------------------------
Environment:


Request Method: GET
Request URL: http://localhost:8000/

Django Version: 1.8.4
Python Version: 3.4.0
Installed Applications:
('django.contrib.auth',
 'django.contrib.contenttypes',
 'django.contrib.sessions',
 'django.contrib.staticfiles',
 'django.contrib.messages',
 'django.contrib.sites',
 'django.contrib.admin',
 'gramps.webapp.grampsdb')
Installed Middleware:
('django.middleware.csrf.CsrfViewMiddleware',
 'django.middleware.common.CommonMiddleware',
 'django.contrib.sessions.middleware.SessionMiddleware',
 'django.contrib.auth.middleware.AuthenticationMiddleware',
 'django.contrib.messages.middleware.MessageMiddleware')


Traceback:
File "/usr/local/lib/python3.4/dist-packages/django/core/handlers/base.py" in get_response
  119.                 resolver_match = resolver.resolve(request.path_info)
File "/usr/local/lib/python3.4/dist-packages/django/core/urlresolvers.py" in resolve
  366.             for pattern in self.url_patterns:
File "/usr/local/lib/python3.4/dist-packages/django/core/urlresolvers.py" in url_patterns
  402.         patterns = getattr(self.urlconf_module, "urlpatterns", self.urlconf_module)
File "/usr/local/lib/python3.4/dist-packages/django/core/urlresolvers.py" in urlconf_module
  396.             self._urlconf_module = import_module(self.urlconf_name)
File "/usr/lib/python3.4/importlib/__init__.py" in import_module
  109.     return _bootstrap._gcd_import(name[level:], package, level)
File "/home/arnold/grampConnectMaster/gramps/gramps/webapp/urls.py" in <module>
  40. from gramps.webapp.grampsdb.views import *
File "/home/arnold/grampConnectMaster/gramps/gramps/webapp/grampsdb/views.py" in <module>
  49. import simplejson

Exception Type: ImportError at /
Exception Value: No module named 'simplejson'

--------------------------------------


Arnold

-- 
Fight Spam - report it with wxSR 0.7
Vista & Win7 compatible
http://www.columbinehoney.net/wxSR.shtml

------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: gramps-connect under Mint 17.2

DS Blank
On Fri, Aug 21, 2015 at 2:42 PM, jecxz112 <[hidden email]> wrote:
On 8/21/2015 11:23 AM, Doug Blank wrote:
Try "make clean" followed by another "make"

I think you are close now.
Thank you, Doug.
The make clean did the trick for the compile. :-)

When I point my browser tp 127.0.0.1:8000, I get whole bunch of errors, starting with:

No, that's just one error and a stack trace. The very bottom gives the clue:

No module named 'simplejson'

So, you should be able to "sudo pip3 install simplejson" and you have that one solved.

-Doug

 
From the copy & paste view:
--------------------------------------
Environment:


Request Method: GET
Request URL: http://localhost:8000/

Django Version: 1.8.4
Python Version: 3.4.0
Installed Applications:
('django.contrib.auth',
 'django.contrib.contenttypes',
 'django.contrib.sessions',
 'django.contrib.staticfiles',
 'django.contrib.messages',
 'django.contrib.sites',
 'django.contrib.admin',
 'gramps.webapp.grampsdb')
Installed Middleware:
('django.middleware.csrf.CsrfViewMiddleware',
 'django.middleware.common.CommonMiddleware',
 'django.contrib.sessions.middleware.SessionMiddleware',
 'django.contrib.auth.middleware.AuthenticationMiddleware',
 'django.contrib.messages.middleware.MessageMiddleware')


Traceback:
File "/usr/local/lib/python3.4/dist-packages/django/core/handlers/base.py" in get_response
  119.                 resolver_match = resolver.resolve(request.path_info)
File "/usr/local/lib/python3.4/dist-packages/django/core/urlresolvers.py" in resolve
  366.             for pattern in self.url_patterns:
File "/usr/local/lib/python3.4/dist-packages/django/core/urlresolvers.py" in url_patterns
  402.         patterns = getattr(self.urlconf_module, "urlpatterns", self.urlconf_module)
File "/usr/local/lib/python3.4/dist-packages/django/core/urlresolvers.py" in urlconf_module
  396.             self._urlconf_module = import_module(self.urlconf_name)
File "/usr/lib/python3.4/importlib/__init__.py" in import_module
  109.     return _bootstrap._gcd_import(name[level:], package, level)
File "/home/arnold/grampConnectMaster/gramps/gramps/webapp/urls.py" in <module>
  40. from gramps.webapp.grampsdb.views import *
File "/home/arnold/grampConnectMaster/gramps/gramps/webapp/grampsdb/views.py" in <module>
  49. import simplejson

Exception Type: ImportError at /
Exception Value: No module named 'simplejson'

--------------------------------------


Arnold

-- 
Fight Spam - report it with wxSR 0.7
Vista & Win7 compatible
http://www.columbinehoney.net/wxSR.shtml

------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel



------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: gramps-connect under Mint 17.2

Oldest1
On 8/21/2015 11:47 AM, Doug Blank wrote:


No, that's just one error and a stack trace. The very bottom gives the clue:

No module named 'simplejson'

So, you should be able to "sudo pip3 install simplejson" and you have that one solved.

OK, got past that one and now I get - even if I run "sudo make run"

ImproperlyConfigured at /

Creating a ModelForm without either the 'fields' attribute or the 'exclude' attribute is prohibited; form EventRefForm needs updating.

Request Method:     GET
Request URL:     http://localhost:8000/
Django Version:     1.8.4
Exception Type:     ImproperlyConfigured
Exception Value:    

Creating a ModelForm without either the 'fields' attribute or the 'exclude' attribute is prohibited; form EventRefForm needs updating.

Exception Location:     /usr/local/lib/python3.4/dist-packages/django/forms/models.py in __new__, line 274
Python Executable:     /usr/bin/python3
Python Version:     3.4.0
Python Path:    

['/home/arnold/grampConnectMaster/gramps/gramps',
 '/home/arnold/grampConnectMaster/gramps/gramps/webapp',
 '/home/arnold/grampConnectMaster/gramps',
 '/usr/lib/python3.4',
 '/usr/lib/python3.4/plat-i386-linux-gnu',
 '/usr/lib/python3.4/lib-dynload',
 '/usr/local/lib/python3.4/dist-packages',
 '/usr/lib/python3/dist-packages']

Server time:     Fri, 21 Aug 2015 14:52:28 -0400

-- 
Fight Spam - report it with wxSR 0.7
Vista & Win7 compatible
http://www.columbinehoney.net/wxSR.shtml

------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: gramps-connect under Mint 17.2

DS Blank
On Fri, Aug 21, 2015 at 2:55 PM, jecxz112 <[hidden email]> wrote:
On 8/21/2015 11:47 AM, Doug Blank wrote:


No, that's just one error and a stack trace. The very bottom gives the clue:

No module named 'simplejson'

So, you should be able to "sudo pip3 install simplejson" and you have that one solved.

OK, got past that one and now I get - even if I run "sudo make run"

ImproperlyConfigured at /

Creating a ModelForm without either the 'fields' attribute or the 'exclude' attribute is prohibited; form EventRefForm needs updating.

Request Method:     GET
Request URL:     http://localhost:8000/
Django Version:     1.8.4
Exception Type:     ImproperlyConfigured
Exception Value:    

Creating a ModelForm without either the 'fields' attribute or the 'exclude' attribute is prohibited; form EventRefForm needs updating.

You're running a version of Django beyond where I have gone. This error on EventRefForm is a deprecation warning in 1.7, but is a full error in your 1.8. You want to look to see how to fix that? You can start with Django release notes.

Or revert back to Django 1.7.

-Doug

 

Exception Location:     /usr/local/lib/python3.4/dist-packages/django/forms/models.py in __new__, line 274
Python Executable:     /usr/bin/python3
Python Version:     3.4.0
Python Path:    

['/home/arnold/grampConnectMaster/gramps/gramps',
 '/home/arnold/grampConnectMaster/gramps/gramps/webapp',
 '/home/arnold/grampConnectMaster/gramps',
 '/usr/lib/python3.4',
 '/usr/lib/python3.4/plat-i386-linux-gnu',
 '/usr/lib/python3.4/lib-dynload',
 '/usr/local/lib/python3.4/dist-packages',
 '/usr/lib/python3/dist-packages']

Server time:     Fri, 21 Aug 2015 14:52:28 -0400

-- 
Fight Spam - report it with wxSR 0.7
Vista & Win7 compatible
http://www.columbinehoney.net/wxSR.shtml

------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel



------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: gramps-connect under Mint 17.2

Oldest1
On 8/21/2015 12:03 PM, Doug Blank wrote:
>
>
> You're running a version of Django beyond where I have
> gone. This error on EventRefForm is a deprecation warning
> in 1.7, but is a full error in your 1.8. You want to look
> to see how to fix that? You can start with Django release
> notes.
Just poling around, reading the error report a bit more
closely and just crashing and thrashing, I added a line to
webapp/grampsdb/forms.py
at line 283:
class EventRefForm(forms.ModelForm):
     class Meta:
         model = EventRef
         exclude = ["handle"]    # AWW  <<<

No idea what implications this would/will have, but the
server now comes up and I get the gramps-connect home screen :-)
Even was able to login as admin - with a bit of guessing
about the user name

I was unable to get any of the import options to work for me
though, nor can I find the Django export option in 4.2

Trying for the Kenedy.ged import, I get:
FIXME: message_set: Your data is now being imported...
[21/Aug/2015 16:07:27] "GET
/report/im_ged/run?options=iff%3Dged%0D%0Ai%3Dhttp%3A%2F%2Farborvita.free.fr%2FKennedy%2FKennedy.ged%0D%0A%0D%0A
HTTP/1.1" 302 0
[21/Aug/2015 16:07:27] "GET /report/ HTTP/1.1" 200 17605
FIXME: message_set: import_file failed: Traceback (most
recent call last):
   File
"/home/arnold/grampConnectMaster/gramps/gramps/webapp/grampsdb/views.py",
line 239, in background
     import_file(db, filename, gramps.cli.user.User()) #
callback
   File
"/home/arnold/grampConnectMaster/gramps/gramps/webapp/reports.py",
line 89, in import_file
     retval = import_function(db, filename, user)
   File
"/home/arnold/grampConnectMaster/gramps/gramps/plugins/importer/importgedcom.py",
line 122, in importData
     config.get('preferences.tag-on-import') else None))
   File
"/home/arnold/grampConnectMaster/gramps/gramps/plugins/lib/libgedcom.py",
line 1888, in __init__
     self.import_researcher = self.dbase.is_empty()
   File
"/home/arnold/grampConnectMaster/gramps/gramps/webapp/dbdjango.py",
line 1727, in is_empty
     return (self.get_number_of_people() == 0 and
   File
"/home/arnold/grampConnectMaster/gramps/gramps/webapp/dbdjango.py",
line 1159, in get_number_of_people
     return self.dji.Person.count()
AttributeError: 'DbDjango' object has no attribute 'dji'

---------------------------------
Would this error be related in some way with my 'fix' for
the original problem?

What sort of tools can one use to debug this web app?? :-)

Unfortunately, I know very little about  any of the
technologies involved with gramps, including json or django,
python ......

But we did make some progress today. Thank you.

Arnold

--
Fight Spam - report it with wxSR 0.7
Vista & Win7 compatible
http://www.columbinehoney.net/wxSR.shtml


------------------------------------------------------------------------------
_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: gramps-connect under Mint 17.2

DS Blank
On Fri, Aug 21, 2015 at 4:18 PM, jecxz112 <[hidden email]> wrote:
On 8/21/2015 12:03 PM, Doug Blank wrote:
>
>
> You're running a version of Django beyond where I have
> gone. This error on EventRefForm is a deprecation warning
> in 1.7, but is a full error in your 1.8. You want to look
> to see how to fix that? You can start with Django release
> notes.
Just poling around, reading the error report a bit more
closely and just crashing and thrashing, I added a line to
webapp/grampsdb/forms.py
at line 283:
class EventRefForm(forms.ModelForm):
     class Meta:
         model = EventRef
         exclude = ["handle"]    # AWW  <<<

No idea what implications this would/will have, but the
server now comes up and I get the gramps-connect home screen :-)

Yes, I think we'll have to read up on what exclude/include mean, and then add the appropriate fields. Maybe exclude can be the empty list?
 
Even was able to login as admin - with a bit of guessing
about the user name

Yes, given in make.py
 

I was unable to get any of the import options to work for me
though, nor can I find the Django export option in 4.2

Trying for the Kenedy.ged import, I get:

Yes, a few things needed adjusting with the new database backends. I rewrote mostly from scratch this new interface, but it should be good to go now.

You might try starting testing smaller parts... adding a person, editing things, etc. As you find things that don't work, you can report them here, or make a ticket. Hopefully, more developers will start to get interested and can help out.

-Doug
 

------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: gramps-connect under Mint 17.2

Oldest1
On 8/21/2015 2:53 PM, Doug Blank wrote:

Trying for the Kenedy.ged import, I get:

Yes, a few things needed adjusting with the new database backends. I rewrote mostly from scratch this new interface, but it should be good to go now.

You might try starting testing smaller parts... adding a person, editing things, etc. As you find things that don't work, you can report them here, or make a ticket. Hopefully, more developers will start to get interested and can help out.
Well, with the difficulties spelled out with the current GUI package, the effort which would be involved
in moving to another cross-platform GUI package, the potential for cooperation via the 'net, my vote
would go for web-connect :-)
So I'll keep pecking away at it and try to learn a bit more each time.

This raised a couple of other questions for me - both for using and for testing

Can this server be accessed via my LAN?
From a Windows box?

That would be convenient to test it via selenium or something similar, I would expect

Arnold

-- 
Fight Spam - report it with wxSR 0.7
Vista & Win7 compatible
http://www.columbinehoney.net/wxSR.shtml

------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: gramps-connect under Mint 17.2

DS Blank
On Fri, Aug 21, 2015 at 6:14 PM, jecxz112 <[hidden email]> wrote:
On 8/21/2015 2:53 PM, Doug Blank wrote:

Trying for the Kenedy.ged import, I get:

Yes, a few things needed adjusting with the new database backends. I rewrote mostly from scratch this new interface, but it should be good to go now.

You might try starting testing smaller parts... adding a person, editing things, etc. As you find things that don't work, you can report them here, or make a ticket. Hopefully, more developers will start to get interested and can help out.
Well, with the difficulties spelled out with the current GUI package, the effort which would be involved
in moving to another cross-platform GUI package, the potential for cooperation via the 'net, my vote
would go for web-connect :-)

Exactly! And not only that, but then no need for versions for iOS, Android, iPad, Tablet, etc.
 
So I'll keep pecking away at it and try to learn a bit more each time.

Feel free to take notes :) It has been so long since I started, I have forgotten much... 

This raised a couple of other questions for me - both for using and for testing

Can this server be accessed via my LAN?
From a Windows box?

I think so... just running the sample webserver can be a stand-in for more serious (and secure) options, although getting running on Apache wasn't that hard... notes on the web. I think if you look at the Makefile, you can see whay commands are issued for "make run" and then look for options for that to use a port that is accessible from outside that machine. May take some additional holes in firewalls, etc.
 

That would be convenient to test it via selenium or something similar, I would expect

Yes, indeed!

-Doug 

PS - update from master... more tiny corrections, and Travis is happy:




Arnold

-- 
Fight Spam - report it with wxSR 0.7
Vista & Win7 compatible
http://www.columbinehoney.net/wxSR.shtml

------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel



------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: gramps-connect under Mint 17.2

Oldest1
In reply to this post by DS Blank
On 8/21/2015 2:53 PM, Doug Blank wrote:


You might try starting testing smaller parts... adding a person, editing things, etc. As you find things that don't work, you can report them here, or make a ticket. Hopefully, more developers will start to get interested and can help out.
When I tried adding a person, I get pretty well the same error as I got from trying to import a gedcom file - which in a way makes some sense,

As I am still way too green with python, I can't make heads or tails of this stuff.

When I click on the '+' in the 'Browse People' page, in the server terminal I get :

[23/Aug/2015 19:28:54] "GET /person/ HTTP/1.1" 200 14044
Internal Server Error: /person/add
Traceback (most recent call last):
  File "/usr/local/lib/python3.4/dist-packages/django/core/handlers/base.py", line 132, in get_response
    response = wrapped_callback(request, *callback_args, **callback_kwargs)
  File "/home/arnold/gramps/mymaster/gramps/webapp/grampsdb/views.py", line 676, in action
    return render_to_response(view_template, context)
  File "/usr/local/lib/python3.4/dist-packages/django/shortcuts.py", line 39, in render_to_response
    content = loader.render_to_string(template_name, context, using=using)
  File "/usr/local/lib/python3.4/dist-packages/django/template/loader.py", line 99, in render_to_string
    return template.render(context, request)
  File "/usr/local/lib/python3.4/dist-packages/django/template/backends/django.py", line 74, in render
    return self.template.render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/base.py", line 209, in render
    return self._render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/base.py", line 201, in _render
    return self.nodelist.render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/base.py", line 903, in render
    bit = self.render_node(node, context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/debug.py", line 79, in render_node
    return node.render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/loader_tags.py", line 135, in render
    return compiled_parent._render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/base.py", line 201, in _render
    return self.nodelist.render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/base.py", line 903, in render
    bit = self.render_node(node, context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/debug.py", line 79, in render_node
    return node.render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/loader_tags.py", line 135, in render
    return compiled_parent._render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/base.py", line 201, in _render
    return self.nodelist.render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/base.py", line 903, in render
    bit = self.render_node(node, context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/debug.py", line 79, in render_node
    return node.render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/loader_tags.py", line 65, in render
    result = block.nodelist.render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/base.py", line 903, in render
    bit = self.render_node(node, context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/debug.py", line 79, in render_node
    return node.render(context)
  File "/home/arnold/gramps/mymaster/gramps/webapp/grampsdb/templatetags/my_tags.py", line 54, in render
    for item in self.args])
  File "/home/arnold/gramps/mymaster/gramps/webapp/utils.py", line 868, in association_table
    person = table.db.get_person_from_handle(obj.handle)
  File "/home/arnold/gramps/mymaster/gramps/gen/db/generic.py", line 1111, in get_person_from_handle
    if handle in self.person_map:
  File "/home/arnold/gramps/mymaster/gramps/gen/db/generic.py", line 263, in __contains__
    return self.table.funcs[self.contains_func](key)
  File "/home/arnold/gramps/mymaster/gramps/webapp/djangodb.py", line 771, in has_handle_for_person
    return self.dji.Person.filter(handle=key).count() > 0
AttributeError: 'DbDjango' object has no attribute 'dji'
[23/Aug/2015 19:28:59] "GET /person/add HTTP/1.1" 500 228397

---------------------
Arnold


-- 
Fight Spam - report it with wxSR 0.7
Vista & Win7 compatible
http://www.columbinehoney.net/wxSR.shtml

------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: gramps-connect under Mint 17.2

DS Blank
On Sun, Aug 23, 2015 at 7:44 PM, jecxz112 <[hidden email]> wrote:
On 8/21/2015 2:53 PM, Doug Blank wrote:


You might try starting testing smaller parts... adding a person, editing things, etc. As you find things that don't work, you can report them here, or make a ticket. Hopefully, more developers will start to get interested and can help out.
When I tried adding a person, I get pretty well the same error as I got from trying to import a gedcom file - which in a way makes some sense,

You should "git pull" to pull the latest code from master. That should be fixed.
 

As I am still way too green with python, I can't make heads or tails of this stuff.

There are some very good tutorials on learning Python. Django has a pretty steep learning curve on top of learning Python.

-Doug
 

When I click on the '+' in the 'Browse People' page, in the server terminal I get :

[23/Aug/2015 19:28:54] "GET /person/ HTTP/1.1" 200 14044
Internal Server Error: /person/add
Traceback (most recent call last):
  File "/usr/local/lib/python3.4/dist-packages/django/core/handlers/base.py", line 132, in get_response
    response = wrapped_callback(request, *callback_args, **callback_kwargs)
  File "/home/arnold/gramps/mymaster/gramps/webapp/grampsdb/views.py", line 676, in action
    return render_to_response(view_template, context)
  File "/usr/local/lib/python3.4/dist-packages/django/shortcuts.py", line 39, in render_to_response
    content = loader.render_to_string(template_name, context, using=using)
  File "/usr/local/lib/python3.4/dist-packages/django/template/loader.py", line 99, in render_to_string
    return template.render(context, request)
  File "/usr/local/lib/python3.4/dist-packages/django/template/backends/django.py", line 74, in render
    return self.template.render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/base.py", line 209, in render
    return self._render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/base.py", line 201, in _render
    return self.nodelist.render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/base.py", line 903, in render
    bit = self.render_node(node, context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/debug.py", line 79, in render_node
    return node.render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/loader_tags.py", line 135, in render
    return compiled_parent._render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/base.py", line 201, in _render
    return self.nodelist.render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/base.py", line 903, in render
    bit = self.render_node(node, context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/debug.py", line 79, in render_node
    return node.render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/loader_tags.py", line 135, in render
    return compiled_parent._render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/base.py", line 201, in _render
    return self.nodelist.render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/base.py", line 903, in render
    bit = self.render_node(node, context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/debug.py", line 79, in render_node
    return node.render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/loader_tags.py", line 65, in render
    result = block.nodelist.render(context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/base.py", line 903, in render
    bit = self.render_node(node, context)
  File "/usr/local/lib/python3.4/dist-packages/django/template/debug.py", line 79, in render_node
    return node.render(context)
  File "/home/arnold/gramps/mymaster/gramps/webapp/grampsdb/templatetags/my_tags.py", line 54, in render
    for item in self.args])
  File "/home/arnold/gramps/mymaster/gramps/webapp/utils.py", line 868, in association_table
    person = table.db.get_person_from_handle(obj.handle)
  File "/home/arnold/gramps/mymaster/gramps/gen/db/generic.py", line 1111, in get_person_from_handle
    if handle in self.person_map:
  File "/home/arnold/gramps/mymaster/gramps/gen/db/generic.py", line 263, in __contains__
    return self.table.funcs[self.contains_func](key)
  File "/home/arnold/gramps/mymaster/gramps/webapp/djangodb.py", line 771, in has_handle_for_person
    return self.dji.Person.filter(handle=key).count() > 0
AttributeError: 'DbDjango' object has no attribute 'dji'
[23/Aug/2015 19:28:59] "GET /person/add HTTP/1.1" 500 228397

---------------------
Arnold


-- 
Fight Spam - report it with wxSR 0.7
Vista & Win7 compatible
http://www.columbinehoney.net/wxSR.shtml

------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel



------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel
Reply | Threaded
Open this post in threaded view
|

Re: gramps-connect under Mint 17.2

Oldest1
On 8/23/2015 5:13 PM, Doug Blank wrote:
On Sun, Aug 23, 2015 at 7:44 PM, jecxz112 <[hidden email]> wrote:
On 8/21/2015 2:53 PM, Doug Blank wrote:


You might try starting testing smaller parts... adding a person, editing things, etc. As you find things that don't work, you can report them here, or make a ticket. Hopefully, more developers will start to get interested and can help out.
When I tried adding a person, I get pretty well the same error as I got from trying to import a gedcom file - which in a way makes some sense,

You should "git pull" to pull the latest code from master. That should be fixed.
Done, but no change wrt this problem.

I see dji defined in other places, but not in django db.
Defining it isn't much of a problem either, but initializing it in the proper place and with the proper values is not 'obvious' to me. :-)

 

As I am still way too green with python, I can't make heads or tails of this stuff.

There are some very good tutorials on learning Python. Django has a pretty steep learning curve on top of learning Python.
Working on it, but ....
Learning the syntax of python isn't too hard.
To monkey with the code as complex as gramps without causing collateral damage is something else :-)

At least I have figured out how to access the server over my lan.

Arnold
-- 
Fight Spam - report it with wxSR 0.7
Vista & Win7 compatible
http://www.columbinehoney.net/wxSR.shtml

------------------------------------------------------------------------------

_______________________________________________
Gramps-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-devel