module load error

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

module load error

Gunnar Haaland
I am trying a calendar report, but it will not work.


Følgende moduler ble ikke lastet:

PdfDoc.py: ReportLab-modulen er ikke installert

LPRDoc.py: ImportError
Traceback (most recent call last):
   File "/opt/gnome/share/gramps/PluginMgr.py", line 126, in load_plugins
     a = __import__(plugin)
   File "/opt/gnome/share/gramps/docgen/LPRDoc.py", line 45, in ?
     import gnomeprint, gnomeprint.ui
ImportError: No module named gnomeprint

Calendar.py: AttributeError
Traceback (most recent call last):
   File "/opt/gnome/share/gramps/PluginMgr.py", line 126, in load_plugins
     a = __import__(plugin)
   File "/opt/gnome/share/gramps/plugins/Calendar.py", line 708, in ?
     category = Report.CATEGORY_DRAW,
AttributeError: 'module' object has no attribute 'CATEGORY_DRAW'


I get no error when I start GRAMPS, which is
GRAMPS 2.0.8-1 a packages made for Opensuse 10.0
Have oneone a tips????

Gunnar



-------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc. Do you grep through log files
for problems?  Stop!  Download the new AJAX search engine that makes
searching your log files as easy as surfing the  web.  DOWNLOAD SPLUNK!
http://ads.osdn.com/?ad_id=7637&alloc_id=16865&op=click
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: module load error

Richard Bos
Op woensdag 28 december 2005 20:34, schreef Gunnar Haaland:

> PdfDoc.py: ReportLab-modulen er ikke installert
>
> LPRDoc.py: ImportError
> Traceback (most recent call last):
>    File "/opt/gnome/share/gramps/PluginMgr.py", line 126, in load_plugins
>      a = __import__(plugin)
>    File "/opt/gnome/share/gramps/docgen/LPRDoc.py", line 45, in ?
>      import gnomeprint, gnomeprint.ui
> ImportError: No module named gnomeprint
>
> Calendar.py: AttributeError
> Traceback (most recent call last):
>    File "/opt/gnome/share/gramps/PluginMgr.py", line 126, in load_plugins
>      a = __import__(plugin)
>    File "/opt/gnome/share/gramps/plugins/Calendar.py", line 708, in ?
>      category = Report.CATEGORY_DRAW,
> AttributeError: 'module' object has no attribute 'CATEGORY_DRAW'
>
>
> I get no error when I start GRAMPS, which is
> GRAMPS 2.0.8-1 a packages made for Opensuse 10.0
> Have oneone a tips????

I just uploaded a new gramps version to my apt component (suser-rbos) on
gwdg.de  It has 2 new dependencies to python-gnome-extras (thanks to David
Geiger to solve this mystery) and python-ReportLab.  The latter is a new
package that is available from my apt repository as well.  I'm not sure if it
works fully, but it seems to take away some Tracebacks that I had.  Let me
know your experiences.

--
Richard Bos
Without a home the journey is endless


-------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc. Do you grep through log files
for problems?  Stop!  Download the new AJAX search engine that makes
searching your log files as easy as surfing the  web.  DOWNLOAD SPLUNK!
<a href="http://ads.osdn.com/?ad_idv37&alloc_id865&op=click">http://ads.osdn.com/?ad_idv37&alloc_id865&op=click
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: module load error

Richard Bos
Op donderdag 29 december 2005 15:02, schreef Richard Bos:
> I just uploaded a new gramps version to my apt component (suser-rbos) on
> gwdg.de  It has 2 new dependencies to python-gnome-extras (thanks to David
> Geiger to solve this mystery) and python-ReportLab.  The latter is a new
> package that is available from my apt repository as well.  I'm not sure if
> it works fully, but it seems to take away some Tracebacks that I had.  Let
> me know your experiences.

Just forgot, it will only be available after I think 1700 hours from the apt
repository.  Make sure you have gramps version 2.0.9-2 and not 1!

--
Richard Bos
Without a home the journey is endless


-------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc. Do you grep through log files
for problems?  Stop!  Download the new AJAX search engine that makes
searching your log files as easy as surfing the  web.  DOWNLOAD SPLUNK!
<a href="http://ads.osdn.com/?ad_idv37&alloc_id865&op=click">http://ads.osdn.com/?ad_idv37&alloc_id865&op=click
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users