names don't appear in relationship graph

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

names don't appear in relationship graph

Dionysis Boukouvalas

I use "relationship graph" option to export a jpeg of a tree.

Many boxes have only the relevant ID number of an entry, instead of the "Surname, Name" format, which appears normaly in the tree.

I cannot seem to discern a pattern in the way this happens (i.e. why in this entry and not the other).

Can you help me?

Dionysis.


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
https://gramps-project.org
Reply | Threaded
Open this post in threaded view
|

Re: names don't appear in relationship graph

Paul Franklin-5
On 6/18/17, Dionysis Boukouvalas <[hidden email]> wrote:

> I use "relationship graph" option to export a jpeg of a tree.
>
> Many boxes have only the relevant ID number of an entry, instead of the
> "Surname, Name" format, which appears normaly in the tree.
>
> I cannot seem to discern a pattern in the way this happens (i.e. why in this
> entry and not the other).
>
> Can you help me?
>
> Dionysis.
>

That report has been used by many people over many years.

If it doesn't work for you I suspect there is something different
about your computer environment or perhaps your user names,
which could be triggering some (heretofore unknown) bug in
gramps.

What happens when you output it in a different way?  PDF?
OpenOffice?  Are the names there then?  What happens if
you temporarily put in a few people whose names are using
English/Latin letters (assuming your normal names are not
using that script)?  Do those people then appear?

What happens when you output it as a "Graphviz file" and
then look at that file with a text editor?  Are the names there
then?  (Gramps just makes that file, internally, then passes
it on to a program external to gramps, for final output, to PDF
or jpeg or whatever.)

In general, this gramps-users list is a good place to ask for
help.  How to do something for instance.  Or whether others
have seen behavior you are seeing.  Like you are asking now.

But if you reach the point where some gramps behavior is
repeatable, and wrong, then it's likely a bug and you should
file a report on the bug tracker.  But if you can't say how to
reproduce the error -- possibly including a small family tree
which shows the behavior, with non-real people of course --
then it will be harder to fix.

HTH.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
https://gramps-project.org
Reply | Threaded
Open this post in threaded view
|

Re: names don't appear in relationship graph

Dionysis Boukouvalas
I tried pdf export. Same problem.
I replaced greek characters from a name not displayed with latin ones. The name is still not displayed in the graph.
I used graphviz export. The non-displayed names of the graph are also not present in the graphviz file (viewed in notepad).
How should I proceed?
Reply | Threaded
Open this post in threaded view
|

Re: names don't appear in relationship graph

prculley
I would suggest you file a bug report https://gramps-project.org/bugs/bug_report_page.php
and include either your real tree or a small tree with names changed that still shows the error.  Export the test tree as XML (.gramps) file and attach it to the report.

On the off chance it may be related to your installation, you should also include the output of "gramps -v" from the command line if you are on linux.
If on Windows, find the gramps.exe file which is usually somewhere like
C:\Program Files\GrampsAIO64-4.2.1\bin
or C:\Program Files\GrampsAIO64-4.2.5

open a command window , cd to the path where gramps.exe was found, and do the "gramps -v" there.

Paste the results in the 'additional information' window of the bug report.

We will try to reproduce your results and either fix it (if it is a bug), or let you know what you can do to fix it.

Paul C.

On Sun, Jun 18, 2017 at 3:15 PM, Dionysis Boukouvalas <[hidden email]> wrote:
I tried pdf export. Same problem.
I replaced greek characters from a name not displayed with latin ones. The
name is still not displayed in the graph.
I used graphviz export. The non-displayed names of the graph are also not
present in the graphviz file (viewed in notepad).
How should I proceed?



--
View this message in context: http://gramps.1791082.n4.nabble.com/names-don-t-appear-in-relationship-graph-tp4680378p4680383.html
Sent from the GRAMPS - User mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
https://gramps-project.org


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
https://gramps-project.org
Reply | Threaded
Open this post in threaded view
|

Re: names don't appear in relationship graph

Paul Franklin-5
In reply to this post by Dionysis Boukouvalas
On 6/18/17, Dionysis Boukouvalas <[hidden email]> wrote:
> I tried pdf export. Same problem.
> I replaced greek characters from a name not displayed with latin ones. The
> name is still not displayed in the graph.
> I used graphviz export. The non-displayed names of the graph are also not
> present in the graphviz file (viewed in notepad).
> How should I proceed?

That's too bad.

Well, I suggest you file a bug report, with directions on
how to reproduce it (in "Steps To Reproduce").  Be sure
to say whether you are running gramps in Greek or in
English, and which one your operating system is also.

Ideally I'd attach some simple gramps-XML family tree
to that bug report, with as many or as few people as you
need to reproduce it.  Who knows, maybe a one-person
family tree will be enough to manifest the bug?  But do
not attach your real family tree without making the bug
"private" first.  Try imaginary people first, when you are
seeing if you can reproduce it with a smaller tree.

But I am guessing such a tree will be needed, since we
have had lots of Windows users but none who have hit
this bug before.

Thanks.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
https://gramps-project.org