osmgpsmap and Kubuntu 14.10

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

osmgpsmap and Kubuntu 14.10

Peter Hewett-2


This email is just some notes that might help someone who strikes the
same problem as I have.

Today, I did a fresh install of Kubuntu 14.10, and had some problems
with the osmgpsmap dependencies.  The Ubuntu repository says there is no
such package, and the packages on the gramps page at sourceforge are
...i386 which won't work on my 64bit install.

However, I found some amd64 deb packages at Debian
 packages.debian.org/sid/gramps
and these appear to work ok.  The packages are;
 libosmgpsmap-1.0-0
 gir1.2-osmgpsmap-1.0

I had to install the libosmgpsmap package first, or the gir1.2 package
says it couldn't install.

The other dependencies (goocanvas, webkit, gexiv, etc) appeared to
install ok from the Ubuntu repositories.

HTH


Peter

------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: osmgpsmap and Kubuntu 14.10

Philippe Couka
Hi

In fact you should look after python-osmgpsmap, which is in ubuntu repositories.

Best regards.

Philippe Couka
21 rue François Menez
29000 Quimper
02 98 90 82 10
[hidden email]

2014-10-26 23:04 GMT+01:00 Peter Hewett <[hidden email]>:


This email is just some notes that might help someone who strikes the
same problem as I have.

Today, I did a fresh install of Kubuntu 14.10, and had some problems
with the osmgpsmap dependencies.  The Ubuntu repository says there is no
such package, and the packages on the gramps page at sourceforge are
...i386 which won't work on my 64bit install.

However, I found some amd64 deb packages at Debian
 packages.debian.org/sid/gramps
and these appear to work ok.  The packages are;
 libosmgpsmap-1.0-0
 gir1.2-osmgpsmap-1.0

I had to install the libosmgpsmap package first, or the gir1.2 package
says it couldn't install.

The other dependencies (goocanvas, webkit, gexiv, etc) appeared to
install ok from the Ubuntu repositories.

HTH


Peter

------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users


------------------------------------------------------------------------------

_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: osmgpsmap and Kubuntu 14.10

Ross Gammon
For Ubuntu systems running 4.x Gramps you need the "gir" osmgpsmap
package. The "python-" package is the older one and was going to be
removed (it has been removed in Debian). But I forgot to do it.

You can find the new one if you enable the Utopic-proposed repository:
https://wiki.ubuntu.com/Testing/EnableProposed

Ross

On 10/26/2014 11:26 PM, Philippe Couka wrote:

> Hi
>
> In fact you should look after python-osmgpsmap, which is in ubuntu
> repositories.
>
> Best regards.
>
> Philippe Couka 21 rue François Menez 29000 Quimper 02 98 90 82 10
> [hidden email] <mailto:[hidden email]>
>
> 2014-10-26 23:04 GMT+01:00 Peter Hewett <[hidden email]
> <mailto:[hidden email]>>:
>
>
>
> This email is just some notes that might help someone who strikes
> the same problem as I have.
>
> Today, I did a fresh install of Kubuntu 14.10, and had some
> problems with the osmgpsmap dependencies.  The Ubuntu repository
> says there is no such package, and the packages on the gramps page
> at sourceforge are ...i386 which won't work on my 64bit install.
>
> However, I found some amd64 deb packages at Debian
> packages.debian.org/sid/gramps
> <http://packages.debian.org/sid/gramps> and these appear to work
> ok.  The packages are; libosmgpsmap-1.0-0 gir1.2-osmgpsmap-1.0
>
> I had to install the libosmgpsmap package first, or the gir1.2
> package says it couldn't install.
>
> The other dependencies (goocanvas, webkit, gexiv, etc) appeared to
> install ok from the Ubuntu repositories.
>
> HTH
>
>
> Peter
>
> ------------------------------------------------------------------------------
>
>
_______________________________________________

> Gramps-users mailing list [hidden email]
> <mailto:[hidden email]>
> https://lists.sourceforge.net/lists/listinfo/gramps-users
>
>
>
>
> ------------------------------------------------------------------------------
>
>
>
>
> _______________________________________________ Gramps-users
> mailing list [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gramps-users
>


------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: osmgpsmap and Kubuntu 14.10

Philippe Couka
Hi

I should have said I'm using 3.4.8, which I will leave when I'm sure there is no trouble left with 4.1.

Best regards

Philippe Couka

2014-10-27 19:48 GMT+01:00 Ross Gammon <[hidden email]>:
For Ubuntu systems running 4.x Gramps you need the "gir" osmgpsmap
package. The "python-" package is the older one and was going to be
removed (it has been removed in Debian). But I forgot to do it.

You can find the new one if you enable the Utopic-proposed repository:
https://wiki.ubuntu.com/Testing/EnableProposed

Ross

On 10/26/2014 11:26 PM, Philippe Couka wrote:
> Hi
>
> In fact you should look after python-osmgpsmap, which is in ubuntu
> repositories.
>
> Best regards.
>
> Philippe Couka 21 rue François Menez 29000 Quimper 02 98 90 82 10
> [hidden email] <mailto:[hidden email]>
>
> 2014-10-26 23:04 GMT+01:00 Peter Hewett <[hidden email]
> <mailto:[hidden email]>>:
>
>
>
> This email is just some notes that might help someone who strikes
> the same problem as I have.
>
> Today, I did a fresh install of Kubuntu 14.10, and had some
> problems with the osmgpsmap dependencies.  The Ubuntu repository
> says there is no such package, and the packages on the gramps page
> at sourceforge are ...i386 which won't work on my 64bit install.
>
> However, I found some amd64 deb packages at Debian
> packages.debian.org/sid/gramps
> <http://packages.debian.org/sid/gramps> and these appear to work
> ok.  The packages are; libosmgpsmap-1.0-0 gir1.2-osmgpsmap-1.0
>
> I had to install the libosmgpsmap package first, or the gir1.2
> package says it couldn't install.
>
> The other dependencies (goocanvas, webkit, gexiv, etc) appeared to
> install ok from the Ubuntu repositories.
>
> HTH
>
>
> Peter
>
> ------------------------------------------------------------------------------
>
>
_______________________________________________
> Gramps-users mailing list [hidden email]
> <mailto:[hidden email]>
> https://lists.sourceforge.net/lists/listinfo/gramps-users
>
>
>
>
> ------------------------------------------------------------------------------
>
>
>
>
> _______________________________________________ Gramps-users
> mailing list [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gramps-users
>


------------------------------------------------------------------------------
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users


------------------------------------------------------------------------------

_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users