typelib-1_0-Gtk-3_0 vs typelib-1_0-Gtk-2_0

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

typelib-1_0-Gtk-3_0 vs typelib-1_0-Gtk-2_0

Sebastian Schubert
Hi,

maybe you have a hint what to look at. I have several openSUSE 13.1
machines. One some, the following problem occurs, one some not although
they seem to be rather similar:

If typelib-1_0-Gtk-2_0 is not installed (which breaks a lot of things so
not recommended), gramps will work fine. However, having
typelib-1_0-Gtk-3_0 and typelib-1_0-Gtk-2_0, the command line

gramps -e blub -O blab

produces the error

/usr/lib64/python2.7/site-packages/gi/overrides/Gtk.py:49:
RuntimeWarning: You have imported the Gtk 2.0 module.  Because Gtk 2.0
was not designed for use with introspection some of the interfaces and
API will fail.  As such this is not supported by the pygobject
development team and we encourage you to port your app to Gtk 3 or
greater. PyGTK is the recomended python module to use with Gtk 2.0


Any idea what to do to prefer the GTK3 version?

Cheers
Sebastian


------------------------------------------------------------------------------
Managing the Performance of Cloud-Based Applications
Take advantage of what the Cloud has to offer - Avoid Common Pitfalls.
Read the Whitepaper.
http://pubads.g.doubleclick.net/gampad/clk?id=121054471&iu=/4140/ostg.clktrk
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users

signature.asc (271 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: typelib-1_0-Gtk-3_0 vs typelib-1_0-Gtk-2_0

Ron Johnson
Which version of gramps?  If v4.0.x, have you tried v3.4?

On 02/18/2014 05:00 AM, Sebastian Schubert wrote:

> Hi,
>
> maybe you have a hint what to look at. I have several openSUSE 13.1
> machines. One some, the following problem occurs, one some not although
> they seem to be rather similar:
>
> If typelib-1_0-Gtk-2_0 is not installed (which breaks a lot of things so
> not recommended), gramps will work fine. However, having
> typelib-1_0-Gtk-3_0 and typelib-1_0-Gtk-2_0, the command line
>
> gramps -e blub -O blab
>
> produces the error
>
> /usr/lib64/python2.7/site-packages/gi/overrides/Gtk.py:49:
> RuntimeWarning: You have imported the Gtk 2.0 module.  Because Gtk 2.0
> was not designed for use with introspection some of the interfaces and
> API will fail.  As such this is not supported by the pygobject
> development team and we encourage you to port your app to Gtk 3 or
> greater. PyGTK is the recomended python module to use with Gtk 2.0
>
>
> Any idea what to do to prefer the GTK3 version?
>
> Cheers
> Sebastian

--
Carrot juice constitutes murder; Greenhouses prisons for slaves.


------------------------------------------------------------------------------
Managing the Performance of Cloud-Based Applications
Take advantage of what the Cloud has to offer - Avoid Common Pitfalls.
Read the Whitepaper.
http://pubads.g.doubleclick.net/gampad/clk?id=121054471&iu=/4140/ostg.clktrk
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users
Reply | Threaded
Open this post in threaded view
|

Re: typelib-1_0-Gtk-3_0 vs typelib-1_0-Gtk-2_0

Sebastian Schubert
Am 18.02.2014 13:56, schrieb Ron Johnson:
> Which version of gramps?  If v4.0.x, have you tried v3.4?

Sorry, it is 4.0.3. I played around some more and found that

typelib-1_0-WebKit-3_0

has to be installed as well. This needs to be added to the spec file of
openSUSE.

Cheers
Sebastian


> On 02/18/2014 05:00 AM, Sebastian Schubert wrote:
>> Hi,
>>
>> maybe you have a hint what to look at. I have several openSUSE 13.1
>> machines. One some, the following problem occurs, one some not although
>> they seem to be rather similar:
>>
>> If typelib-1_0-Gtk-2_0 is not installed (which breaks a lot of things so
>> not recommended), gramps will work fine. However, having
>> typelib-1_0-Gtk-3_0 and typelib-1_0-Gtk-2_0, the command line
>>
>> gramps -e blub -O blab
>>
>> produces the error
>>
>> /usr/lib64/python2.7/site-packages/gi/overrides/Gtk.py:49:
>> RuntimeWarning: You have imported the Gtk 2.0 module.  Because Gtk 2.0
>> was not designed for use with introspection some of the interfaces and
>> API will fail.  As such this is not supported by the pygobject
>> development team and we encourage you to port your app to Gtk 3 or
>> greater. PyGTK is the recomended python module to use with Gtk 2.0
>>
>>
>> Any idea what to do to prefer the GTK3 version?
>>
>> Cheers
>> Sebastian
>


------------------------------------------------------------------------------
Managing the Performance of Cloud-Based Applications
Take advantage of what the Cloud has to offer - Avoid Common Pitfalls.
Read the Whitepaper.
http://pubads.g.doubleclick.net/gampad/clk?id=121054471&iu=/4140/ostg.clktrk
_______________________________________________
Gramps-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gramps-users